LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-26-2007, 06:14 AM   #1
wearetheborg
Member
 
Registered: Sep 2004
Distribution: Mint 13 Maya
Posts: 268

Rep: Reputation: 31
Install Guide: Debian Etch on T42 incl. Compiz


I have installed Debian Etch on my recently acquired IBM thinkpad T42.
I am planning to install all the bells and whistles on it, including undervolting, cpu frequency control, HDD shock proctection, compiz, wireless. I will post updates whenever I successfully install each module.

This guide is meant for noobs, I'm a pretty noob too, so experts, please bear with me. Suggestions for improvement are welcome.


Specs
: IBM thinkpad T42
Pentium M 2Ghz Dothan
2GB ram
38GB HDD
1400x1050 SXGA+ screen
ATI Mobility radeon 7500 video card with 32 mb ram
Atheros a/b/g wireles card


Done:
Base install, Suspend/hibernate, cpu frequency control, compiz.



Base Install:

I installed using the net install debian etch CD.
I was connected to the internet via the ethernet. I partitioned the HDD (38GB) into
Windows partiton
A fat32 partition (4.5GB)
A / partition (6.3GB)
A /home partition (17GB)
A swap partition (2GB)

I chose the "laptop" and "desktop" and "standard system" packages.
It installed everything, there was one warning message on one of the packages, I think it had to do with suspend to ram, I just clicked ok.

It rebooted into SXGA+ resolution, I logged in, did an update immediately, then immediately rebooted. This was via ethernet.

Post Install Configuration:
I edited my /etc/apt/sources.list file to the following:
Code:
#
# deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official i386 NETINST Binary-1 20070407-11:29]/ etch contrib main

deb http://ftp.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.debian.org/debian/ etch main contrib non-free

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free

deb http://www.debian-multimedia.org/ etch main
Most debian installation instructions are of the format
Code:
apt-get install ...
But I recommend aptitude instead of apt-get. Aptitude is a better package manager than apt-get, and can be be used whereever apt-get can be used.
Just substitute aptitude instead of apt-get.
If you just type aptitude by itslef, it will open up in the console a list of packages installed, those available etc.
More on aptitude as a REF:
http://people.debian.org/~dburrows/aptitude-doc/en/

Back to the install.
I did
Code:
aptitude update
to update the database.
Then I installed some packages:
Code:
aptitude install build-essential
Then I had to type in the terminal

Code:
uname -r
to find out what kernel version I was running. The kernel I had was 2.6.18-4-686. From there I installed the kernel headers by typing in the terminal as root user :

Code:
aptitude install linux-headers-2.6.18-4-868
Obviously you should type “uname -r” in the terminal to find out which kernel you are running and install the appropriate linux headers for that particular kernel. As an example if you have 2.6.18-5-686 then you should install linux-headers-2.6.18-5-686.

Then the next thing to install is:
Code:
aptitude install debian-multimedia-keyring
This will put in the public key.
Then do update:
Code:
aptitude update
I then installed some more packages:
Code:
aptitude install  kaffeine xmms xpdf gv mplayer xine-ui 
digikam sun-java5-jre sun-java5-plugin w32codecs libdvdcss2 rcconf
At this point mp3, avi files were playing fine.
rcconf is a neat console based utility to select which services should and should not be started at boot time.
I then deslected some services that were starting up, like mail-server utilities, printer, bittorent.

Standby/Hibernate:
These were working out of the box, provide I was logged in. I get kernel panic if I'm at the lgin menu. But if I'm logged in, then work fine.
Standby to RAM works espcially fast, like 5 seconds. And wake up equally fast.
Only problem is the area below the spacebar remains a bit warm in stanby. The wireless card and the gpu are in that area. I'm not sure how to fix that.

CPU Frequency Control:

I have to first remove this:
Code:
aptitude remove powernowd
The I installed sysfsutils, cpufreqd, cpufrequtils:
Code:
aptitude install sysfsutils cpufreqd cpufrequtils
Now we'll load the modules:
Code:
modprobe speedstep-centrino
modprobe cpufreq_conservative
modprobe cpufreq_ondemand
modprobe cpufreq_powersave
modprobe cpufreq_stats
modprobe cpufreq_userspace
speedstep-centrino is the module for controlling centrino processors, the rest are frequency "governors"
We'll test that everything went as expected:
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
You should see output similar to
Code:
powersave conservative ondemand performance userspace
You can change the current scheme by something like
Code:
echo powersave > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
And view the current cpu frequency by
Code:
cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq
Now we need to load them at boot time.
Add the following lines to the end of /etc/modules
Code:
speedstep-centrino
cpufreq_conservative
cpufreq_ondemand
cpufreq_powersave
cpufreq_stats
cpufreq_userspace
Add the following lines to /etc/sysfs.conf
Code:
devices/system/cpu/cpu0/cpufreq/scaling_governor=userspace
Where userspace can be changed to another governor type (i.e. conservative, powersave, etc.). You can also add other configuration options that are specific to the governor selected.

Then I added a cpu frequency changing applet as described here:http://www.ubuntugeek.com/howto-chan...in-ubuntu.html

This applet can also change governors.
Tip: Whenever I plug out of AC power and plug in again, I would find myself on "performance" governor, I would then change to powersave to change the cpu frequency.


Compiz:
/etc/X11/xorg.conf had to be modified first.
Make a backup:
Code:
cp /etc/X11/xorg.conf  /etc/X11/xorg.conf.bak
Then edit xorg.conf to have the following lines:
Under the section "Device"
Code:
Section "Device"
        Identifier      "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
        Driver          "ati"
        BusID           "PCI:1:0:0"
        VideoRam        32768
        Option          "AGPMode" "4"
        Option          "AGPSize" "32"
        Option          "DRI" "true"
        Option          "AGPFastWrite" "true"
        Option          "EnablePageFlip" "true"
        Option          "XAANoOffscreenPixmaps" "true"
        Option          "AllowGLXWithComposite" "true"
        Option          "RenderAccel"   "true"
EndSection
Then in the section "Screen, make sure these lines are there just after "monitor"
Code:
        Monitor         "Generic Monitor"
        DefaultDepth    16
        Option "AddRGBGLXVisuals" "true"
        Option "DisableGLXRootClipping" "true"
        Option  "XAANoOffscreenPixmaps" "true"
In Section "Module", make sure you have
Code:
Load   "dbe"
in first position.


Finally, at the end of xorg.cong, you should have
Code:
Section "DRI"
        Mode    0666
EndSection

Section "Extensions"
        Option "Composite" "Enable"
EndSection
I assume that you have direct rendering enabled. In other words, the output of
Code:
glxinfo | grep direct
should say (if glxinfo doesn't work, make sure you have the package mesa-utils installed) :
Code:
direct rendering: Yes


Starting with xorg 7.1, AIGLX is integrated in the X server. Also, it should get loaded automatically. Ensure that it does :
Code:
cat /var/log/Xorg.0.log | grep -i aiglx
which should say (==) AIGLX enabled. If it doesn't get loaded, you can force it by adding :
Code:
   Option   "AIGLX"   "true"
to Section "ServerLayout" of your /etc/X11/xorg.conf.


Log out, restart X (CTRL+ALT+BACKSPACE), and verify things still work

Log in.
Now we install compiz:
Code:
aptitude install compiz
Start compiz:
Code:
compiz --replace --fast-filter
3d-cube etc should now be working.
This can be started automatically in gnome upon login:
Go in Desktop -> Preferences -> Sessions. Then choose the Startup Programs tab and add an entry for Compiz :
Code:
compiz --replace --fast-filter
Unfortunately, I dont know how to change the compiz setings yet


ToDo:

Wireless, undervolting, HDD shock protection.

References:
http://www.linuxquestions.org/questi...splay.php?f=26
http://lunapark6.com/debian-40-etch.html
http://www.debiantutorials.org/content/view/161/211/
http://www.debian-multimedia.org/
http://people.debian.org/~dburrows/a...h02s02s02.html
http://ubuntuforums.org/showthread.php?t=248867
http://www.ubuntugeek.com/howto-chan...in-ubuntu.html
http://www.student.tue.nl/Q/j.f.berndsen/debian/
http://technowizah.com/2006/10/debia...lx-compiz.html
http://aparateys.blogspot.com/2007/0...y-fawn-on.html
https://www.dedigentoo.org/trac/linu...#Documentation
http://ubuntuforums.org/showthread.php?t=146366
http://www.thinkwiki.org/wiki/Pentiu..._underclocking

Last edited by wearetheborg; 05-05-2008 at 02:32 AM.
 
Old 08-26-2007, 06:15 AM   #2
wearetheborg
Member
 
Registered: Sep 2004
Distribution: Mint 13 Maya
Posts: 268

Original Poster
Rep: Reputation: 31
This is a placeholder.
 
Old 08-26-2007, 12:56 PM   #3
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
I'm running an older version of the same machine, a T42. Yours has a different wireless card, different processor, but the rest of it seems similar.

Its too bad about the processor/wireless change. Your processor is faster for sure, but having the one in mine came with an intel ipw2200 wireless, which now has modules in the main kernel. All you needed to get it working in Debian is the firmware.

Code:
jim@jimsworktop:~$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.60GHz
stepping        : 6
cpu MHz         : 600.000
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe up est tm2
bogomips        : 1199.86
clflush size    : 64
Code:
jim@jimsworktop:~$ lsmod |grep ipw
ipw2200               131396  0
ieee80211              31592  1 ipw2200
firmware_class          9504  2 ipw2200,pcmcia
All you should need to get wireless working on your model is the madwifi package.

Also, its great that you're helping other people out by posting a guide like this, but trying to do an "everything" guide will only work as long as the hardware stays consistent. If I had done the work you're doing (and obviously I didn't), my guide would be useless now, as half the hardware seems to have changed. I'm not trying to discourage you from doing it, but hand holding like that isn't very Debian.

Peace,
JimBass
 
Old 08-26-2007, 04:28 PM   #4
wearetheborg
Member
 
Registered: Sep 2004
Distribution: Mint 13 Maya
Posts: 268

Original Poster
Rep: Reputation: 31
That is OK. I hope my guide will be applicable to all T42s with 7500 ATI card, except for perhaps wireless. Even if its only applicable to only my configs, I'll be happy. I need me some handholding
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Virtual Hosting With PureFTPd And MySQL (Incl. Quota And Bandwidth Management) On Debian Etch LXer Syndicated Linux News 0 05-06-2007 08:16 AM
LXer: Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch LXer Syndicated Linux News 0 04-29-2007 03:31 PM
Urgent: Installing debian etch on a new hdd but grub won't install (fatal error) MrInept Debian 4 09-14-2006 08:54 AM
Intel Pro wireless 2100 on IBM T42 laptop running FC3 tvmaly Linux - Software 1 02-25-2005 09:00 AM
IBM T42 with USB External HDD install question eshurtle Linux - Laptop and Netbook 4 02-21-2005 01:18 PM


All times are GMT -5. The time now is 11:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration