LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-16-2004, 03:57 PM   #1
amnesty_puppy
Member
 
Registered: Aug 2004
Location: Britain
Distribution: Gentoo
Posts: 52

Rep: Reputation: 15
Increase performance


After intial problems with my Debian install I've got a good working system with a nice new 2.6.9 kernel, although I now have it dual booted with windows (for gaming only) but my debian desktop seems a little slow. It's not really jerky or overly noticable, just things take that tiny bit longer to work - one major thing: firefox on debian seems to load slower than IE on windows. Is there anything I can do to get things going a bit faster? I've heard using a different x server can speed things up like directfb or xorg. Also, as a seperate question, how much does using a source based distro like Gentoo actually increase performance?

Thanks, Dom.

(Athlon XP 2400, 512mb + Debian unstable (I think) + XFCE)
 
Old 11-16-2004, 04:32 PM   #2
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
Did you compile the kernel for amd/k7? This makes a big difference and also using the proper video drivers speeds up X. You make no mention of this.
 
Old 11-16-2004, 05:34 PM   #3
amnesty_puppy
Member
 
Registered: Aug 2004
Location: Britain
Distribution: Gentoo
Posts: 52

Original Poster
Rep: Reputation: 15
I'm a bit of a newb to linux so I forget things like that, sorry. I used the proper optimisations I think, 6x86. Not so sure on video drivers, I use vesa but I use an aging 3dfx Blaster Banshee, although I haven't been able to get any other drivers to work (tried "tdfx" and "glide" each had a different problem). Using my mobos on-board graphics I can't use 24bit for some reason so I have to put up with a substandard gradient on my desktop.

Thanks.

EDIT: My ace girlfriend just bought me Half Life 2 so looks like I'll be getting a new graphics card anyway!

Last edited by amnesty_puppy; 11-16-2004 at 06:14 PM.
 
Old 11-16-2004, 06:34 PM   #4
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
I used to have a voodoo2, 3 and 4 (in that order ) which works well, but it is not so easy to configure. The banshee should work well too.

You have to load the kernel modules for 3dfx (dri, drm modules, agpgart) and install the libglide3 package. Using tdfx for X should give you full direct rendering. Check with "glxinfo". Be aware of the fact that resolutions above 1024x768 may not be supported. Direct rendering will than fail no matter what.

http://www.linuxquestions.org/questions/history/169948
http://lists.debian.org/debian-user/.../msg04584.html

Optimised kernels from Debian for AMD have a "k7" mentioned in the name, such as kernel-image-2.6.7-1-k7. That way you can skip compiling yourself for a while and use a kernel which makes use of the processor features.
 
Old 11-17-2004, 10:52 AM   #5
amnesty_puppy
Member
 
Registered: Aug 2004
Location: Britain
Distribution: Gentoo
Posts: 52

Original Poster
Rep: Reputation: 15
Installed the new kernel. X now quits on load with this warning "tdfx failed to set up write combining range" then this error "xf86OpenSerial: Cannot open device /dev/psaux" plus some other mouse errors coming from this, it also tries something else, /dev/input/mice I think, with the same error. It also says DRI can't be used in 24/32 bpp mode, which means back to 16bit.
Further investigating showed I needed to load some extra modules for the mouse - input and mousedev. input gave module not found and mousedev loaded with a message about ps/2 standard or something, but when the x server is loaded (in 16 bit mode) the mouse doesn't move. Hopefully this is just a case of loading modules which I don't know. Any thoughts?

Thanks!
 
Old 11-17-2004, 03:27 PM   #6
Moloko
Member
 
Registered: Mar 2004
Location: Netherlands
Distribution: Debian
Posts: 729

Rep: Reputation: 30
You're close to salvation

Map your mouse to /dev/input/mice or /dev/input/mouse0 and load the modules using modconf in the console. Switch with ctrl+alt+F1 to a terminal and kill X (/etc/init.d/xdm stop or use kdm), load the modules, reconfigure X to 16 bbp and restart X.
 
Old 11-17-2004, 04:17 PM   #7
amnesty_puppy
Member
 
Registered: Aug 2004
Location: Britain
Distribution: Gentoo
Posts: 52

Original Poster
Rep: Reputation: 15
How would I go abouting mapping my mouse?

I tried modprobing the modules, is modconf any different? And it had the same "cannot open device" error for /dev/input/mice. modprobe input produces the "module not found" error but that may be for an older kernel version (2.6.9 atm btw).

EDIT: tried that and loaded anything to do with mice and it seems to have done the trick. Thanks for your help. The next problem is installing libglide "apt-get install libglide3" then it installs but when it trys to configure says "pcilib: Cannot open /sys/bus/pci/devices" and the same for dpkg-reconfigure.

Last edited by amnesty_puppy; 11-18-2004 at 02:10 AM.
 
Old 11-20-2004, 04:06 AM   #8
rbos36
LQ Newbie
 
Registered: Jul 2004
Location: The Netherlands
Posts: 1

Rep: Reputation: 0
My experience is that tuning the filesystem helps a lot. Ext3, although very reliable, is not the fastest fs around.

Basically, there are two strategies.

(1) Tune your current fs.
A thing you might consider is turning off access time updates (atime), which already speeds up your fs considerably.
For ext3, also the journaling option data=writeback helped me speed up the fs.

(2) Migrate your system to a faster fs.
A month ago, I reinstalled my Debian root partition on a ReiserFS (v3.6) filesystem and this made a huge difference; the system feels a lot faster, and I can really feel that application startup times have dropped considerably. Before, I had it on ext3.
For reliability, my /home partition is still on ext3, for my data is valuable to me.

Hope this helps somehow.
 
Old 11-20-2004, 11:08 PM   #9
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
if you're using gnome as your desktop, it's bound to be slow. kde is an improvement, but for real speed, use icewm or fluxbox. you can also try the prelink package that can improve app start up times by 2x or more ("apt-get install prelink" and do a search for proper usage). you can also install hdparm to tweak hard drive performance.

Last edited by zero79; 11-20-2004 at 11:16 PM.
 
Old 11-21-2004, 12:54 AM   #10
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
Yes, prelink helps. Also you have to realize that on windows when the machine boots it loads IE into memory so it will start faster, linux doesn't do this, which is fine with me because I'd rather have access to the extra memory when I game. You can try using a non-vanilla kernel like a ck (Con Kolivas) kernel, or I like the kernels that ccrma puts out for professional audio work they are much faster than a vanilla kernel.
 
Old 11-21-2004, 04:55 AM   #11
amnesty_puppy
Member
 
Registered: Aug 2004
Location: Britain
Distribution: Gentoo
Posts: 52

Original Poster
Rep: Reputation: 15
I use ReiserFS and XFCE (can't stand bloated desktops), that prelink sounds good - I'll try it out. Thanks to all!
 
Old 11-21-2004, 10:40 AM   #12
ernobe
Member
 
Registered: Nov 2004
Location: Costa Rica
Distribution: Debian SID
Posts: 33

Rep: Reputation: 15
Kernel mode linux will increase performance dramatically. Go to the kernel mode linux website and follow the instructions.
 
Old 11-21-2004, 06:17 PM   #13
zuralin
Member
 
Registered: Sep 2003
Distribution: Debian testing/unstable
Posts: 225

Rep: Reputation: 30
Quote:
Originally posted by ernobe
Kernel mode linux will increase performance dramatically. Go to the kernel mode linux website and follow the instructions.
Also sounds like a huge security threat. It also seems to be going the opposite direction the kernel is (moving things into kernel space rather than userspace)
 
Old 11-22-2004, 04:33 PM   #14
ernobe
Member
 
Registered: Nov 2004
Location: Costa Rica
Distribution: Debian SID
Posts: 33

Rep: Reputation: 15
>
> Kernel patch looks good but can't get it to patch
> properly - thought it might be to do with the debian
> patched kernel. Should I get a "vanilla" kernel
> from kernel.org first then patch kernel mode then
> debian patches? I'm new to this.

Just get the latest source from kernel.org, currently its 2.6.9, and apply the kernel mode linux patch with the patch command ( patch -p1 <kml-patch ). You may need to unzip it before with gzip if it ends in .gz.

As explained at the kml website, you then need to install libc6-i686 ( apt-get install libc6-i686 ). You then need to follow the instructions at the link:
http://web.yl.is.s.u-tokyo.ac.jp/~to...use_glibc.html
Look at step No. 4 at the bottom of the page.

In my case, I log into kernel mode linux by using a program called qlogin and configuring /etc/inittab, like so:
1:2345:respawn:/sbin/qlogin /dev/tty1 root --command="/usr/local/sbin/beg"
2:23:respawn:/sbin/qlogin /dev/tty2 root
3:23:respawn:/sbin/qlogin /dev/tty3 root
4:23:respawn:/sbin/qlogin /dev/tty4 root
5:23:respawn:/sbin/qlogin /dev/tty5 root
6:23:respawn:/sbin/qlogin /dev/tty6 root

Qlogin automatically logs you in. Do a Google search for it.

The /usr/local/sbin/beg file contains the following:
Code:
#!/bin/bash --login
exec /trusted/ld-linux.so.2 --library-path /lib/tls/i686/cmov:/lib:/lib64:/usr/lib:/usr/lib64 /bin/bash --login
Whatever I then do at that screen executes in the kernel space, including startx. I found that it then looks for .xinitrc instead of .xsession.

As for the Debian patches, I gave up on trying to install Debian packages of the kernel, so I don't know what you mean by these patches. If it is something you need then obviously you'll need to see if they don't conflict with the kml patch ( if during the patch you get any errors you need to start over and not include some of the patches ).
 
Old 11-22-2004, 04:47 PM   #15
amnesty_puppy
Member
 
Registered: Aug 2004
Location: Britain
Distribution: Gentoo
Posts: 52

Original Poster
Rep: Reputation: 15
AFAIK the debian kernel packages already have the debian kernel patches applied, but you can also download the source of these, and the debian patches seperately. I'm not really sure what they do, something about cramfs is part of it, but if it works without them then I'm not really bothered. Thanks for the help - I'll try it out later, when I've finished this darn project design.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile from source - increase in performance? csvke Linux - Software 15 01-18-2005 10:08 PM
Increase Performance berkay Fedora 10 08-23-2004 04:24 PM
how to increase performance(geforce2) mandosi Linux - Hardware 0 03-17-2004 04:21 AM
CGI Performance Increase?? bretthoward Programming 9 01-25-2003 07:33 PM
Why does performance increase when I mount? Vlad_M Linux - Hardware 4 10-11-2002 07:35 AM


All times are GMT -5. The time now is 07:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration