LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Incorrect Mouse, Incorrect Keymap, and Trapped in X (http://www.linuxquestions.org/questions/debian-26/incorrect-mouse-incorrect-keymap-and-trapped-in-x-355675/)

Kenji Miyamoto 08-21-2005 10:41 PM

Incorrect Mouse, Incorrect Keymap, and Trapped in X
 
During the configuration at the first real boot of Debian, I never got a chance to do a standard xorgconfig, and now my mouse and keyboard don't work. I have KDM set up, so the X escape sequence just returns to the login screen, and I can't pull down the menu. Is there a way to get out of X without a mouse?

ankscorek 08-22-2005 03:07 AM

what is your xorg file

o/p of /var/log/messages


what errors are u getting

Kenji Miyamoto 08-22-2005 03:18 AM

I honestly am unable to check anything, since I have KDM set up. The cursor won't respond to movement, and the keyboard has the wrong keymap.

runlevel0 08-22-2005 06:35 AM

Quote:

Originally posted by Kenji Miyamoto
I honestly am unable to check anything, since I have KDM set up. The cursor won't respond to movement, and the keyboard has the wrong keymap.
You should be able to switch to a console with CTRL+ALT+F1 / F6 and disable KDM using
Code:

/etc/init.d/kdm stop
You don't even need to stop it, as what you need is to take a glance at the logs in /var/log/Xorg.0.log or in $HOME/.xsession-errors, which you can do without having to do anything on the X.

You can also try to edit your /etc/X11/xorg.conf from there and take a look at the "corepointer" section. Normally this should be enough to load the module, but you should also use debian's module configuration system modconf and load your mouse's modules.
Quote:

Section "InputDevice"
#here is where your mouse must be configured
#this is a standard PS/2 mouse
#this should work out of the box for most mice, mine is an USB optical mouse
# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "ZAxis Mapping" "4 5"

EndSection
...
...
Section "ServerLayout"
# stuff related to the monitor, kbd and other things
# should include the lines below
...
InputDevice "Mouse1" "CorePointer"
...
EndSection

Sometimes there is a little precedence issue related to USB and PS/2 modules. I don't know where Debian stores the list of modules to be load, but the only thing you need is to get the PS/2 modules evdev and psmouse to load before any USB modules such as usb-core.

after making changes to the modules run update-modules

Hope this helps,
try it anyway and post the error log. Please only the 20-50 final lines:

Code:

cat /var/log/Xorg.0.log | tail -n 50 > $HOME/textfile

Kenji Miyamoto 08-22-2005 01:22 PM

I just had the wrong protocol entered for the mouse.

I can't figure out the X.org package name is.

Now that I've rebooted into XFree86, I have no sound and no mouse movement. I didn't do anything other than rebooting after editing XF86Config-4.

Dead Parrot 08-22-2005 10:49 PM

Shouldn't there be a "recovery mode" to choose from in the grub boot loader screen? That should boot your system into a single user mode, ask for the root user's password, and bypass kdm, so that you can fix the X configuration from the CLI.

If you've got XFree86, then the file to edit is /etc/X11/XF86Config-4 but if you've installed X.org, then you should edit /etc/X11/xorg.conf . "dpkg-reconfigure xserver-xfree86" will edit the XFree86 config file and "dpkg-reconfigure xserver-xorg" will edit the X.org config file. However, if you've already manually edited one of these files, then you need to use a text editor, like "nano /etc/X11/XF86Config-4" or "nano /etc/X11/xorg.conf".

Kenji Miyamoto 08-22-2005 10:58 PM

Well, with the exact samd device and 'auto' driver, it worked before I rebooted. And that doesn't explain my sound problems.

Which packages are needed to do a complete intall of X.org?

Dead Parrot 08-23-2005 12:30 AM

"apt-get install x-window-system"

X.org is currently only available in debian unstable. Debian testing and debian stable both have XFree86.

ankscorek 08-24-2005 02:42 PM

just use ps-2 protocol for timebeing and later u can change over to imps2


All times are GMT -5. The time now is 07:19 PM.