LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-21-2010, 06:00 PM   #1
compul
Member
 
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Rep: Reputation: 15
Red face im-switch says scim-bridge but system im is still "simple" - whats wrong?


hey,
after a long time without succes to get my scim running as default im on debian testing with fluxbox as wm, i switched my wm to awesome 2 days ago.

when i first started awesome, scim worked just perfectly. started on startup and i could write everywhere, without terrible rightclick->...->scim

now, i have been experimenting with awesome a little and done apt-get upgrade.
unfortunately, i dont remember when exactly scim stopped working, but it did .

i registered scim-bridge to update-alternatives with the priority of 50, everything _seems_ fine... but it just doesnt start up, and system im is still "Simple".

what have i done wrong? any ideas what might have happened?

best wishes,
compul
 
Old 02-22-2010, 05:03 PM   #2
compul
Member
 
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Original Poster
Rep: Reputation: 15
okay... it appears that when i logg in with slim it works ! just when i use startx it doesnt. maybe i have to change my xinitrc?

im gonna post my .xsession_errors tomorrow - i dont have my laptop right now. there was still something strange too, i think...

looking forward to hearing from you

lg,
compul
 
Old 02-27-2010, 07:18 AM   #3
compul
Member
 
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Original Poster
Rep: Reputation: 15
ok... i got it working the error somehow was, that my startx didnt call to /etc/X11/Xsession... so when i used slim to login it worked and so i just had to change my /etc/X11/xinit/xinitrc ...

greetz,

林樂寬
 
  


Reply

Tags
method


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie question: whats the difference between "su root", "su" and "su -&quo mojarron Slackware 9 12-07-2009 04:08 PM
"NIM thread blocked" & "Deadman Switch (DMS) close to trigger" errors sosborne Linux - Networking 1 06-28-2006 02:07 PM
"switch" and "bridge" kpachopoulos Linux - General 2 09-14-2005 05:00 PM
Whats wrong with "my" makefile? BBB Programming 4 03-02-2005 05:53 PM


All times are GMT -5. The time now is 12:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration