LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-03-2005, 01:13 PM   #1
lilohatea
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian-Etch
Posts: 26

Rep: Reputation: 15
iceWM


I am running Debian Sarg with 2.6 and iceWM. Over all, I've been pleased with iceWM but there are a couple of issues that are driving me crazy and I was hoping that someone can point me in the right way to resolve:

1. My desktop background "disappears". My "theme" and the default background that goes along with it is restored but I want my "theme" and the background that I selected to go along with it to remain intact. The option to change the background when right-clicking the background isn't available when my background isn't there...
2. Cannot logout or exit the system from within iceWM. When I 'control-alt-delete' - the "lockstation" "reboot" and "shutdown" options are white and are un-executeable from the menu. I am forced to "powerdown" via the command line.

Any help is greatly appreciated.

@lilohatea
 
Old 07-03-2005, 01:18 PM   #2
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
For 2 I think you need to specify the commands for each of those in ~/.icewm/preferences (copy the sample config if it doesn't exist already). Can you elaborate on 1?
 
Old 07-03-2005, 03:15 PM   #3
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 51
IceWM Tips
http://www.linuxquestions.org/questi...icle&artid=307

This will give you some idea on how to do the basics.

Edit your ~/.xsession, add this line:

exec icewm-session

if you just write 'exec icewm' it will start the wm but it will not show the bg image.

Go to your ~/.icewm/preferences and enable the third option from the bottom up:

# Desktop background image
# DesktopBackgroundImage=""

Put the background image location between the quotation marks for e.g.:

# Desktop background image
DesktopBackgroundImage="/home/macondo/cancun.jpg"

save/exit
logout/login

it should be there, when you enter X.

As for getting out, i installed sudo, executed 'visudo' as root, and added this line:

username ALL = (ALL) NOPASSWD: ALL

replaced 'username' with my user name, save/exit

and from the terminal (aterm), i just issue the command:

$ sudo halt or reboot

simple...

Last edited by macondo; 07-03-2005 at 03:20 PM.
 
Old 07-04-2005, 09:31 AM   #4
lilohatea
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian-Etch
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks to the both of you.

Some other interesting side-effects:

When my background is default -

* my xterm display is also set to default background and font.
* the logout option off of the start menu works
* when pressing "control-alt-delete" only "lock workstation is unavailable. All other options are available.

When my custom background "appears" -

* my xterm custom settings return.
* the logout option off of the start menu does not work.
* the "lockstation" "reboot" and "shutdown" options are white and are un-executeable from the menu.

I'm still trying to "find a method to the madness" and find out if there is something that I am doing to make it appear because it does seem to be random...

macondo -

You are the one that actually got me to revisit and give iceWM another chance. I did a search and found an old post from you pointing out the key bindings, etc. I tried it out years ago but was unaware of the key bindings. That changes everything for me and I really like it so far. I've doubled the task bar and have nearly the entire extra row displaying my CPU. I am running the "Jaywalk" theme and it seems to go together rather well. So...thanks for turning me on to icewm.

Ok, I have followed your instructions to the best of my ability and it has not worked. Let me detail exactly what I have done and you can tell me if I missed a step or if I did something incorrectly:

1. Edited my /etc/X11/.xsession~ file. Wasn't sure where to enter the "exec icewm-session" line but entered it directly above the 'exec >>"$ERRFILE" 2>&' line.
2. Added my background to the .icewm/preferences file. (I think I'm ok here).
3. Logged out/in.

Thanks!

@lilohatea
 
Old 07-04-2005, 07:20 PM   #5
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 51
"Ok, I have followed your instructions to the best of my ability and it has not worked. Let me detail exactly what I have done and you can tell me if I missed a step or if I did something incorrectly:

1. Edited my /etc/X11/.xsession~ file. Wasn't sure where to enter the "exec icewm-session" line but entered it directly above the 'exec >>"$ERRFILE" 2>&' line.
2. Added my background to the .icewm/preferences file. (I think I'm ok here).
3. Logged out/in."

*********************************************************

Ok, go back to your /etc/X11/.xsession and erase what you did. Save/exit.

The instructions were to go to your ~/.xsession, which means your home dir: e.g. /home/your user name/.xsession, this file does not exist, you will have to create like so:

# nano /home/your user name/.xsession

this will open an empty file, write/paste this:

exec icewm-session

Ctrl+O <Enter>
Ctrl+X <Enter>

now the file is created.

(the letters O and X are not caps)

then logout/login (Ctrl+Alt+Backspace)

then re-enter the X environment with 'startx' or whatever you use. You should have IceWM with the background image if you correctly set the path in the icewm Preferences file. =)

On your ~/.icewm/preferences on line 457 you will see these two options:

# Command to shutdown the system
# ShutdownCommand=""

write this btwn the quotations marks:

shutdown -h now

# Command to reboot the system
# RebootCommand=""

ditto here:

shutdown -r now

then when you are at the terminal try to shutdown first with:

# halt

and reboot with:

# reboot

logout/login or reboot to make sure.

it it doesn't work, then write the whole expression:

shutddown -h now or -r now, depending on what you wanna do.

Later on you will inquire about 'sudo' that's another story.
 
Old 07-06-2005, 02:38 PM   #6
lilohatea
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian-Etch
Posts: 26

Original Poster
Rep: Reputation: 15
Quote:
Ok, go back to your /etc/X11/.xsession and erase what you did. Save/exit. The instructions were to go to your ~/.xsession, which means your home dir: e.g. /home/your user name/.xsession, this file does not exist, you will have to create like so:
Ah, that is what I did initially but when I saw that I was creating a file and not editing a file, I assumed you were referring to the X11 file. I'll try it when I get home.

Quote:
Later on you will inquire about 'sudo' that's another story.
I know about SUDO, I just don't think that I want it. Having to type SUDO before everything seems to be more of a pain in the *** than just logging in as root. Certaintly I can add the authorization to shutdown with my regular user id, no? There is another way when using iceWM, right? I also want the option to click on the start button and logout from there. That is my problem.

I finally found out that it is when I open Nautilus that my background appears...


Last edited by lilohatea; 07-06-2005 at 06:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
icewm help Tereno Linux - General 2 12-02-2004 06:27 AM
like to try icewm Paxmaster Linux - General 10 11-23-2004 12:29 PM
Regarding ICEWM zameer_india Linux - Software 1 10-27-2004 05:52 AM
Icewm JMK Linux - Newbie 1 01-07-2004 03:29 PM
who's using icewm right now unimaginative General 15 01-04-2004 02:47 AM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration