LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-03-2012, 08:04 AM   #1
michalng
Member
 
Registered: Dec 2005
Distribution: Debian KDE / Fluxbox
Posts: 216

Rep: Reputation: 36
Iceweasel warning about IcedTea Plugin


As some of the banking sites that I use requires java, I had install icedtea-plugin on my Debian Squeeze laptop.

Detail of application as follows:

Iceweasel (backports) -> Version: 11.0-4~bpo60+1
openjdk-6-jre -> Version: 6b18-1.8.13-0+squeeze1
openjdk-6-jre-headless -> Version: 6b18-1.8.13-0+squeeze1
openjdk-6-jre-lib -> Version: 6b18-1.8.13-0+squeeze1
icedtea6-plugin -> Version: 6b18-1.8.13-0+squeeze1


After using Iceweasel to surf the net for some time, this message pops up by itself.


As I am using this laptop is for banking, security is of prime importance. Is there something that I can / should do ?

Last edited by michalng; 04-03-2012 at 08:13 AM. Reason: update image link.
 
Old 04-03-2012, 12:00 PM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 455Reputation: 455Reputation: 455Reputation: 455Reputation: 455
I stopped using OpenJDK6 a while back and went ahead and install Oracle's Java. Haven't had any issues.
 
Old 04-03-2012, 12:41 PM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 455Reputation: 455Reputation: 455Reputation: 455Reputation: 455
Due to security issues with older versions of Java they are now blocked in Firefox. Please update your Java.

Older versions have been added to Firefox's blocklist

As per Blocking Java
 
Old 04-03-2012, 04:55 PM   #4
michalng
Member
 
Registered: Dec 2005
Distribution: Debian KDE / Fluxbox
Posts: 216

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by craigevil View Post
Due to security issues with older versions of Java they are now blocked in Firefox. Please update your Java.

Older versions have been added to Firefox's blocklist

As per Blocking Java
craigevil,

thanks for the info, seems like my perception that packages in stable are always secure may not be correct after all.

will update to Oracle's Java as advised.
 
Old 04-03-2012, 05:47 PM   #5
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,183

Rep: Reputation: 363Reputation: 363Reputation: 363Reputation: 363
Quote:
Originally Posted by michalng View Post
craigevil,

thanks for the info, seems like my perception that packages in stable are always secure may not be correct after all.

will update to Oracle's Java as advised.
I am not sure where it is but Debian did, a couple months ago, recommend the change due to security concerns. Came up in my apt-list changes readout doing a update/upgrade cycle in Squeeze, Wheezy and Sid.
 
Old 04-04-2012, 03:35 AM   #6
michalng
Member
 
Registered: Dec 2005
Distribution: Debian KDE / Fluxbox
Posts: 216

Original Poster
Rep: Reputation: 36
Update :

Seems like there's a new outcome.

As per the link that craigevil shared, someone in the comments highlight that icedtea/openjdk is not affect by this vulnerability and the the block will be lifted.

Last edited by michalng; 04-04-2012 at 04:18 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Iceweasel Flash Plugin lppatmore Debian 20 07-16-2013 08:35 PM
[SOLVED] Plugin java not working on Iceweasel Zolex Linux - Software 7 12-29-2009 07:15 AM
gnash 0.8.3-2 plugin for Iceweasel 3.0 problems vharishankar Debian 7 08-07-2008 06:28 AM
Help! Can not get acrobat plugin to work with iceweasel walterbyrd Debian 2 04-09-2008 11:31 AM
Howto create icedtea plugin for firefox philwynk Linux - Newbie 0 02-05-2008 03:19 PM


All times are GMT -5. The time now is 08:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration