LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 09-21-2007, 03:38 PM   #1
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 31
Iceweasel keeps freezing


For about 2 weeks now, Iceweasel will randomly freeze while loading pages. It'll lock up and then a couple minutes later be fine again. It's getting really annoying, as everything else works, so I've taken to keeping epiphany open as a backup.

Does anyone know how I could figure out what the problem is or anything else that might be useful?

Thanks
 
Old 09-21-2007, 04:33 PM   #2
Mithrilhall
Member
 
Registered: Feb 2002
Location: Massachusetts
Distribution: Debian (Lenny)
Posts: 286

Rep: Reputation: 30
Delete (or move) your profile and see if Iceweasel rebuilds it when you launch it.

Let me know if that works or not.
 
Old 09-21-2007, 04:34 PM   #3
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Try creating a new profile for Firefox/Iceweasel. Most problems I have run into have traced back to something in the profile.

I copy the bookmarks.htm to the new profile and then re-install any extensions one at a time and test.. Doesn't take long and the couple times i have had problems this has resolved the issue.
 
Old 09-21-2007, 05:23 PM   #4
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Original Poster
Rep: Reputation: 31
Praytell, how do I create a new profile? The answer doesn't seem overly obvious to me at the moment.
 
Old 09-21-2007, 05:41 PM   #5
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Original Poster
Rep: Reputation: 31
Changed the profile... still freezes.
 
Old 09-21-2007, 07:43 PM   #6
slackass
Member
 
Registered: Apr 2006
Location: SE Texas
Distribution: Slack64-C ML
Posts: 890

Rep: Reputation: 78
I once had a similar problem from an installed theme.
I removed the theme an it just went away.
 
Old 09-21-2007, 09:14 PM   #7
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
IW/firefox freezes/problems are almost always caused by bad extension,theme or plugins not playing nice.

If a clean profile with no extensions/themes doesnt solve the problem, chance are its flash,java causing issues or even a bad install.

Try running it from a console and see what if any error message you see, then post them so others have more info to go on.
 
Old 09-21-2007, 09:29 PM   #8
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Original Poster
Rep: Reputation: 31
I think I tried running it from console once, the only thing is it doesn't spit out any errors, it just hangs. I'll try it again and see.
 
Old 09-21-2007, 09:45 PM   #9
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Original Poster
Rep: Reputation: 31
It's something with nspluginwrapper... I'll try to figure out more about it. I think it freezes when it tries to load certain things from like ad sites or something.

war1025@Engel:~/bzr$ iceweasel
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Message timeout
*** NSPlugin Wrapper *** ERROR: NP_Shutdown() invoke: Message timeout
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsdsp.so.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libartsc.so.0' from LD_PRELOAD cannot be preloaded: ignored.
 
Old 09-22-2007, 12:48 AM   #10
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
Hm iw shouldnt even be using nspluginwrapper, thats a konqueror/opera plugin.

atsd might also be the issue, I turn arts off and use alsa.

Only thing I get when starting it from konsole is:
craig@craigevil:~$ iceweasel
OpenOffice path is '/usr/lib/openoffice'
FG: canHandleContent application/vnd.google.desktop-filter)
FG: _shouldIntercept(application/vnd.google.desktop-filter)
FG: canHandleContent application/vnd.google.desktop-filter)
FG: _shouldIntercept(application/vnd.google.desktop-filter)

Generated: Sat Sep 22 2007 00:46:35 GMT-0400 (EDT)
User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070723 Iceweasel/2.0.0.6 (Debian-2.0.0.6-1)
Build ID: 2007072301

Enabled Extensions: [20]
- Bookmark Duplicate Detector 0.6.3
- ColorfulTabs 2.0.6
- CookieSafe 2.0.6
- Copy URL + 1.3.2
- Flashblock 1.5.4.1
- FlashGot 0.6.8
- Google Desktop for Firefox 1.0.2
- Google Toolbar for Firefox 3.0.20070525L
- Greasemonkey 0.7.20070607.0
- InfoLister 0.9f
- Konquefox 1.3
- Mouse Gestures 1.5.2
- MR Tech Local Install 5.3.2.5
- Nightly Tester Tools 1.3b1
- NoScript 1.1.7.2
- PDF Download 0.9.2
- Stylish 0.5.2
- Tabbrowser Preferences 1.3.1.1
- Torbutton 1.0.4
- United States English Dictionary 2.0.0.6

Installed Themes: [3]
- Iceweasel (default)
- Mostly Crystal 2.0.0.17
- NASA Night Launch 0.6.20070910

Installed Plugins: (11)
- Adobe Reader 8.0
- DivX Browser Plug-In
- Helix DNA Plugin: RealPlayer G2 Plug-In Compatible
- Java(TM) Plug-in 1.6.0_02-b05
- MozPlugger 1.8.0 handles QuickTime and Windows Media Player Plugin
- mplayerplug-in 3.45
- OpenOffice.org Plug-in
- QuickTime Plug-in 6.0 / 7
- RealPlayer 9
- Shockwave Flash
- Windows Media Player Plugin
 
Old 09-22-2007, 12:40 PM   #11
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Original Poster
Rep: Reputation: 31
I went through and installed flashplayer-nonfree and mozilla-flash in apt-get, it seems to have solved the problem. There must have been some conflict with the previous one and some of the newer files.

Nspluginwrapper is used to patch 32 bit plugins into 64 bit browsers, it is completely compatible with Iceweasel. Says so on the Debian website even.
 
Old 09-27-2007, 01:12 AM   #12
kyo
LQ Newbie
 
Registered: Jul 2007
Posts: 6

Rep: Reputation: 0
Quote:
I went through and installed flashplayer-nonfree and mozilla-flash in apt-get, it seems to have solved the problem. There must have been some conflict with the previous one and some of the newer files.
Thank you so much. I had the same problem with iceweasel and it never occurred to me that nspluginwrapper might be the problem. I had installed nspluginwrapper through the flashplayer-mozilla package (which installs and sets up nspluginwrapper). So I just typed in:

aptitude reinstall flashplayer-mozilla

All is now well.
 
Old 09-27-2007, 11:41 AM   #13
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Original Poster
Rep: Reputation: 31
glad to hear i'm not the only one who had that problem ... and that I could help. :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Iceweasel Confusions GTrax Debian 7 08-22-2007 01:33 PM
Iceweasel quickie, hopefully. Mr Marmmalade Debian 10 05-03-2007 05:02 PM
help with java in iceweasel kennybob Linux - Software 2 04-20-2007 11:09 PM
Iceweasel slow hraposo Debian 6 01-14-2007 10:06 PM
iceweasel won't start CrashedAgain Debian 7 12-09-2006 05:22 PM


All times are GMT -5. The time now is 06:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration