Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 10-19-2009, 11:34 AM   #1
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Rep: Reputation: 15
iceweasel and (e.g.) rhythmbox cant play music together

I use debian testing with xfce.
suddenly my rhythmbox stopped playing when flash-video was running on iceweasel before and the same the other way round.

ive tried many things. since i heared that rythmbox uses gstreamer, i used gstreamer-properties to set the default output plugin to alsa (pipeline: alsasink). test works, but rhythmbox does not.

when i try esd, pulseaudio or autodetect as plugin, it just works when iceweasel is closed. when iceweasel is closed, alsa just works when i waited some time after selecting, which sounds pretty strange to me.

to me it seems that rhythmbox always uses alsa, cuz when gstreamer-properties set the default output plugin to esd and i start rhythmbox, esd still works but alsa says " beeing used"
gstreamer output at that time:
"gstreamer-properties-Message: Error running pipeline 'ALSA - Advanced Linux Sound Architecture': Could not open audio device for playback. Device is being used by another application. [gstalsasink.c(685): gst_alsasink_open (): /GstPipelineipeline1/GstAlsaSink:alsasink2:
Device 'default' is busy]"

in that moment i can play music with exaile and gstreamer settings (which is esd as i said).

all this sound deamon stuff etc. confuses me pretty much, so if someone could just explain how to set up esd or alsa or something right so that it works with multiple applications?

Old 10-20-2009, 05:39 AM   #2
Senior Member
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 459Reputation: 459Reputation: 459Reputation: 459Reputation: 459
NO trouble here playing shell-fm and flash sound. I do not use esd, pulseaudio, or gstreamer.
My suggestion would be to get rid of pulse and even esd if you can, then make sure you have gstreamer0.10-alsa - GStreamer plugin for ALSA, installed.
Old 10-20-2009, 07:25 AM   #3
Registered: Aug 2009
Distribution: debian testing / slackware 13.0
Posts: 30

Original Poster
Rep: Reputation: 15
hey this really solved the problem
thanks !

but you should install several gstreamer plugins and e.g. gstreamerx.xx-ffmpeg for mp3 and wma support in rhythmbox.


Last edited by compul; 10-20-2009 at 07:27 AM.


alsa, esd, iceweasel, rhythmbox, sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rhythmbox can't play music CD satimis Debian 1 04-02-2009 10:21 PM
LXer: Rhythmbox, Gnome music awesomeness LXer Syndicated Linux News 0 09-22-2008 11:50 AM
LXer: Music Collection Sharing With Rhythmbox LXer Syndicated Linux News 0 05-01-2006 08:54 AM
Rhythmbox music library and other Gnoppix issues TotalLinuxNoob Linux - Software 2 10-26-2005 12:03 PM
Music quality on RhythmBox .8.8 on Slack 10.1 Oholiab Slackware 3 02-27-2005 04:56 PM

All times are GMT -5. The time now is 11:20 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration