LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   I need ALSACONF but alsa-utils conflicts with udev! (http://www.linuxquestions.org/questions/debian-26/i-need-alsaconf-but-alsa-utils-conflicts-with-udev-360807/)

asimov 09-06-2005 03:02 PM

I need ALSACONF but alsa-utils conflicts with udev!
 
So how can I configure my soundcard?

Or is it ok to uninstall the udev package?

Thanks.

(Debian testing on R50e ThinkPad)

HappyTux 09-06-2005 03:13 PM

Re: I need ALSACONF but alsa-utils conflicts with udev!
 
Quote:

Originally posted by asimov
So how can I configure my soundcard?

Or is it ok to uninstall the udev package?

Thanks.

(Debian testing on R50e ThinkPad)

Can't see why not I have never installed it and have not had any problems yet.

Code:

>$ apt-cache policy udev
udev:
  Installed: (none)
  Candidate: 0.068-2
  Version Table:
    0.068-2 0
        500 http://amd64.debian.net unstable/main Packages
    0.056-3 0
        500 http://amd64.debian.net stable/main Packages


asimov 09-06-2005 03:20 PM

thanks, but hal depends on udev, and gnome-volume-manager depends on hal, and gnome-desktop-environment depends on it and so on...

I really want to keep gnome :)

Is it a bug?

HappyTux 09-06-2005 04:45 PM

Quote:

Originally posted by asimov
thanks, but hal depends on udev, and gnome-volume-manager depends on hal, and gnome-desktop-environment depends on it and so on...

I really want to keep gnome :)

Is it a bug?

Ah I see I am running KDE and do not need any of that. It is not a bug you just need a higher version of udev than you are trying to install as you can see below you need greater than 0.6.0.

Code:

>$ acsh alsa-utils
Package: alsa-utils
Priority: optional
Section: sound
Installed-Size: 1924
Maintainer: Debian ALSA Maintainers <pkg-alsa-devel@lists.alioth.debian.org>
Architecture: amd64
Version: 1.0.9a-4
Provides: audio-mixer
Depends: libasound2 (>> 1.0.9), libc6 (>= 2.3.2.ds1-21), libncurses5 (>= 5.4-5), whiptail | dialog, modutils (>= 2.3.5-1) | module-init-tools, pciutils (>= 1:2.1.11-4), python, linux-sound-base (>= 1.0.9b-1)
Recommends: alsa-base (>= 1.0.9b-3)
Suggests: udev (>= 0.063), lsb-base
Conflicts: udev (<< 0.060), alsa-base (<< 1.0.9b-3)
Filename: pool/main/a/alsa-utils/alsa-utils_1.0.9a-4_amd64.deb
Size: 1057884
MD5sum: 8853bf0f0d8151ff8f567f9a4c244f16
Description: ALSA utilities
 This package contains utilities for configuring and using ALSA.
 .
 ALSA is the Advanced Linux Sound Architecture.
Tag: admin::configuring

Package: alsa-utils
Priority: optional
Section: sound
Installed-Size: 536
Maintainer: Debian ALSA Maintainers <pkg-alsa-devel@lists.alioth.debian.org>
Architecture: amd64
Version: 1.0.8-4
Replaces: alsautils, alsaconf
Provides: audio-mixer, alsautils, alsaconf
Depends: libasound2 (>> 1.0.8), libc6 (>= 2.3.2.ds1-4), libncurses5 (>= 5.4-1), dialog | whiptail, modutils (>= 2.3.5-1) | module-init-tools, pciutils (>= 1:2.1.11-4), alsa-base (>= 1.0.8-4)
Conflicts: alsautils (<< 0.5), alsa-utils-0.5, alsaconf, alsa-base-0.4, alsaconf-0.4
Filename: pool/main/a/alsa-utils/alsa-utils_1.0.8-4_amd64.deb
Size: 157948
MD5sum: dcb11af45fec3eae500de08987fc2629
Description: ALSA utilities
 This package contains utilities for configuring and using ALSA.
 .
 ALSA is the Advanced Linux Sound Architecture.


McCloud 09-06-2005 04:47 PM

No, not a bug. I had the same problem. Opened a topic a couple of days ago. The maintainer of alsa-utils said that he should have waited with putting this version in testing until the new udev was accepted in testing. I've got a solution though:

1 - Add the unstable repositories to your /etc/apt/sources.list, like this
Code:

#testing
deb ftp://ftp.nl.debian.org/debian/ testing main contrib non-free
deb-src ftp://ftp.nl.debian.org/debian/ testing main contrib non-free

#unstable
deb ftp://ftp.nl.debian.org/debian/ unstable main contrib non-free
deb-src ftp://ftp.nl.debian.org/debian/ unstable main contrib non-free

#security
deb http://security.debian.org/ testing/updates main contrib non-free

#Skype
deb http://download.skype.com/linux/repos/debian/ stable non-free

#extra software
deb ftp://ftp.nerim.net/debian-marillat/ etch main

2 - Set up Apt Pinning. Create file called 'preferences' in the '/etc/apt' directory and put the following in it:
Code:

Package: *
Pin: release a=testing
Pin-Priority: 700

Package: *
Pin: release a=unstable
Pin-Priority: 650

3 - Create a file called 'apt.conf' in the '/etc/apt' directory. Put the following in it:
Code:

APT::Default-Release "testing";
4 - Run 'aptitude update'

5 - Install udev from the unstable repository (this will also a couple of other packages from unstable). 'aptitude install -t unstable udev'

6 - Install alsa-utils from testing. 'aptitude install alsa-utils'

With Pinning you can install packages from other repositories, but your default repository will be the testing repository.

Good luck.

asimov 09-06-2005 05:33 PM

thanks a lot!

"udev requires a kernel >= 2.6.12, upgrade aborted"

lol..

I'm going to update the whole system to unstable.

Still, it's a great tip, thanks.

Dead Parrot 09-06-2005 05:57 PM

Or you could grab the alsa packages from stable. If you go all the way to unstable, you'll run into broken dependencies very soon again. And when unstable breaks, where are you going to upgrade to in order to fix things? Experimental? :p

McCloud 09-06-2005 06:09 PM

Well, now that you can reach the unstable repository, you can also download the kernel source for 2.6.12 from unstable :D

'aptitude install -t unstable linux-source-2.6.12'

The source will be installed in /usr/src. Untar it, configure it, build the new kernel and install the new kernel.

Maybe you can even install a new precompiled kernel from unstable this way, I've never tried it, but you can give it a go :D

Good luck!!!


All times are GMT -5. The time now is 04:01 PM.