LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-07-2005, 11:14 AM   #1
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Rep: Reputation: 33
I'm back with kernel 2.6 and a fresh install


Hi again,
I am getting to be like a broken record but I did a fresh install and with the tips provided by
dastrike and dead parrot installed sarge with kernel 2.6 on another drive..But I run into the same old bugabo..
After a smooth base and update , xserver refused to start ..After several dpkg-reconfigure xserver-xfree86 attempts it still won't start..The /var/log/XFree86.0.log seems to indicate at the ending that the mouse wont work and stops the core from loading..I tried several tweaks with my MS optical PS/2 mouse but then shut down and decided to try a plain old PS/2 two button mouse..Still indicates mouse problems.Core will not load or start...
I am nearing my wits end..I have never ever had so much trouble on this same systen to get things working..Especially xserver..Debian refuses me ..I can't blame debian because many people use it so it must be me..
It's finally getting to me..
Thanks for reading this dismal post..
jolphil
 
Old 03-07-2005, 12:36 PM   #2
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Hmm... If it is a mouse problem, then this should be easy to solve.

At first, you could try adding the word psmouse to the end of the /etc/modules file and then reboot to see if that fixed the problem. It probably won't, but it's worth a try anyway.

More likely your problem is caused by the "dpkg-reconfigure xserver-xfree86" script configuring two mouse devices ("Generic Mouse" and "Configured Mouse"). Personally I always edit the /etc/X11/XF86Config-4 file afterwards with a text editor, such as nano, and comment out the mouse configuration that seems to cause problems (i.e., I add a hash mark # to the beginning of all the lines which I don't want Xserver to read), and leave just one mouse configuration. Of course, you could simply remove the lines you don't need but commenting is a safer method in case you make some mistake and want to restore the previous settings.

If you have two configured mouse devices and you decide to comment out one of them in /etc/X11/XF86Config-4, remember to check also the section "ServerLayout" and comment the InputDevice you don't want X to notice. The problem with manually editing /etc/X11/XF86Config-4 is that the "dpkg-reconfigure xserver-xfree86" script detects that the file has been modified and refuses to update it. But this is not such a big problem because "dpkg-reconfigure xserver-xfree86" has already written a pretty good outline for /etc/X11/XF86Config-4 and it usually needs only very little fine-tuning afterwards.
 
Old 03-07-2005, 01:02 PM   #3
dastrike
Member
 
Registered: Apr 2004
Location: Stockholm, Sweden
Distribution: Debian 'sid'
Posts: 250

Rep: Reputation: 30
Exactly how does the error messages look like in /var/log/XFree86.0.log at the end there?

Does it look something like this?
Code:
(EE) xf86OpenSerial: Cannot open device /dev/psaux
        No such device.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device "Configured Mouse"
(II) UnloadModule: "mouse"
...
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
        No such device.
(EE) Generic Mouse: cannot open input device
(EE) PreInit failed for input device "Generic Mouse"
(II) UnloadModule: "mouse"
(WW) No core pointer registered
No core pointer
in other words: complaining that it can't open /dev/psaux or /dev/input/mice?
In that case try installing udev to see if that helps
Code:
apt-get install udev
and reboot after that.
 
Old 03-07-2005, 01:37 PM   #4
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I just installed udev in my Sarge box with 2.6 kernel. Seems to work fine here, too.

Try dastrike's suggestion first. Udev represents the new and more advanced technology, and with kernel 2.6 Linux is moving away from the old devfs.
 
Old 03-07-2005, 02:56 PM   #5
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Original Poster
Rep: Reputation: 33
Dastrike,
Yes it looks pretty much like you have shown in your post..
I used apt-get to install udev but it said I already had the latest version so it did not install..
Dead parrot,
I hashed out the generic mouse in my XF86Config-4 file and I will paste in just the mouse part..
Here it is as of now..

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
EndSection
#Section "InputDevice"
# Identifier "Generic Mouse"
# Driver "mouse"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ImPS/2"
# Option "Emulate3Buttons" "true"
#EndSection


I am using Knoppix at the moment(great distro) so when I rebooted I cannot show my /var/log/XFree86.0.log file..
I do not know anything about nano(never heard of it) but use the slow and cumberson "vi"..
I just know enough commands to get by..
Thanks for your help..i am still trying..
jolphil
 
Old 03-07-2005, 03:52 PM   #6
dastrike
Member
 
Registered: Apr 2004
Location: Stockholm, Sweden
Distribution: Debian 'sid'
Posts: 250

Rep: Reputation: 30
Hm. I haven't seen that problem myself with a 2.6 kernel with udev installed.

What does the output of the commands
Code:
ls -l /dev/psaux
and
Code:
ls -l /dev/input/mice
look like?
 
Old 03-07-2005, 06:42 PM   #7
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Original Poster
Rep: Reputation: 33
dastrike,
Not much luck..For whatever reason I get nothing from either..
ls -l /dev/psaux or ls -l /dev/input/mice

I did look from knoppix and they both are there but when I opened them in an editor(kate) they both showed no data in the files...
I am almost sure I was in SU at the time..I will try again and if I come up with anything I will post back..
Is there a way to copy from the command line so that I could save and paste the results into a reply post.. For example the /var/log/XFfree86.0.log file changes with every boot(i think)..When I reboot and try to copy the results from knoppix the results are different because Debian did not boot..
This is what I get looking from knoppix..I'm sure it was different when seen from the active debian
command line..Was even much bigger and i had to scroll down to get to the last part/..
Pasted: /var/log/XFree86.0.log

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Mar 7 19:02:25 2005
(==) Using config file: "/etc/X11/XF86Config-4"
Data incomplete in file /etc/X11/XF86Config-4
Undefined InputDevice "Generic Mouse" referenced by ServerLayout "Default Layout".
(EE) Problem parsing the config file
(EE) Error from xf86HandleConfigFile()
tired, I'll try fresh in the morning
jolphil
 
Old 03-07-2005, 07:26 PM   #8
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
Undefined InputDevice "Generic Mouse" referenced by ServerLayout "Default Layout".
(EE) Problem parsing the config file
This message tells that you forgot to put the hash mark in front of the line:
InputDevice "Generic Mouse"
under the section ServerLayout "Default Layout". You should add this hash mark.

However, your main problem seems to be that udev hasn't created the necessary mouse device(s). Maybe removing udev (apt-get remove udev) and rebooting would help?

If you want to save the output of the command "ls -l /dev/psaux" (not a good example, since it gave you no output, but nevertheless) into a file called listdevices.txt in your home directory, you can pipe the output through an utility called tee, like this:
Code:
ls -l /dev/psaux | tee ~/listdevices.txt
And if you want to save the contents of /var/log/XFree86.0.log into a file called Xlog.txt in your home directory, you can use the cat command and redirect its output, like this:
Code:
cat /var/log/XFree86.0.log > ~/Xlog.txt
 
Old 03-08-2005, 09:09 AM   #9
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Original Poster
Rep: Reputation: 33
Hi DP,
I tried the first command a couple of times and got a "no such file ot directory"
The second command "Cat" seemed to work but I cannot read it from Knoppix to send to you...
I hand copied some of the last parts of my /var/logXFree86.0.log file...Here it is..

EE Configured Mouse: Cannot open input device
EE Preinit failed for input device"configured mouse"
II Unload module"mouse"
WW No core pointer registered
no core pointer
Fatal Server error
failed to initilalize core devices

Please excuse the bad typing..
Thanks for sticking with it..
I much appreciate it..
If I had not had it once operating in the GUI I would have given up long ago but
It appears a great distro and I would like to learn more about it..
jolphil
 
Old 03-08-2005, 12:34 PM   #10
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Yes, the latest error message you posted was kind of expected because the "ls -l /dev/psaux" and "ls -l /dev/input/mice" commands that dastrike suggested gave you no output. This means that neither of these mouse devices is created during boot time and X server cannot start unless you have at least one configured mouse device. (Or, actually, you could probably get X server running by commenting out BOTH mouse devices in XF86Config-4, but what good would that do if you don't have a working mouse?)

So, the next step would be to get Debian to create you a mouse device (either /dev/psaux or /dev/input/mice) during boot time. I think you should try removing udev ("su" to root and do "apt-get remove udev") and reboot your computer. After this you can try if the commands that dastrike suggested ("ls -l /dev/psaux" and "ls -l /dev/input/mice") give any output, like they should.

I know that udev doesn't come with the Debian base installation, so you probably installed Gnome or KDE (perhaps by choosing "desktop environment" in the post-installation phase) and udev was installed along with them. As I said in my earlier post, udev is new and advanced technology, but it hasn't yet been thoroughly tested in Debian and so it may cause unexpected problems.

I haven't got much experience in playing with udev (I just installed it in my own Debian box) but I would guess that removing udev should force the Linux kernel to use the older devfs technique for creating devices. So, if you remove udev and reboot your computer, I expect Debian to use devfs to create a mouse device (/dev/psaux or /dev/input/mice, possibly both). And after the mouse devices have been created, it shouldn't be too difficult to configure mouse in /etc/X11/XF86Config-4 so that X server can accept it.
 
Old 03-08-2005, 03:06 PM   #11
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Original Poster
Rep: Reputation: 33
Dead Parrot..You are the "MAN"

Wait!!! A deceased parrot can't be a man..hehe..
Anyway, your suggestion of uninstalling udev did it first shot..
I uninstalled it,rebooted and bada bing..GUI
Thank you so much for sticking in there kudos to you and to dastrike too..
You guys are great!!

There was no sound and the mouse I don't think had the scroll wheel but that for another day..


jolphil
 
Old 03-09-2005, 07:32 AM   #12
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Good to hear you got the GUI stuff working.

To get scroll wheel working it's usually enough to add the line
Option "ZAxisMapping" "4 5"
to the mouse section (InputDevice) in /etc/X11/XF86Config-4.

To get sound working the usual steps are:
1) Make sure that you've got the packages alsa-base and alsa-utils installed.
2) "su" to root and run alsaconf.
At this point you may want to open the file /etc/default/alsa with a text editor (vi will do fine ) and make sure that it's got the setting
alsactl_store_on_shutdown="always autosave"
3) Type exit to become a normal user and run alsamixer, adjust "Master" and "PCM" volume levels with the arrow keys on the keyboard and exit alsamixer with the Esc key.

I think that should about do it. If any new problems pop up, don't hesitate to ask more questions. There are lots of experienced Debian users here to help you and I'll hang around here, too, every now and then.

Last edited by Dead Parrot; 03-09-2005 at 07:37 AM.
 
Old 03-09-2005, 12:51 PM   #13
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Original Poster
Rep: Reputation: 33
DP,
I installed alsa from snaptic and ran the alsaconf..Went to the /etc/default/alsa and changed from
never save to always save but still no sound..When I open kde I get an message from arts something like this..
Error while initalizing the sound driver
Can't open
Sound systen will continue using null output...
I did a lsmod to see the kernel modules and copied the pertinent parts as follows..

snd_intel8x0 33068 1
snd_ac97_codec 59268 1 snd_intel8x0
snd_pcm_oss 48168 0
snd_mixer_oss 16640 1 snd_pcm_oss
snd_pcm 85384 2 snd_intel8x0,snd_pcm_oss
snd_timer 23172 1 snd_pcm
snd_page_alloc 11144 2 snd_intel8x0,snd_pcm
gameport 4736 1 snd_intel8x0
snd_mpu401_uart 7296 1 snd_intel8x0
snd_rawmidi 23204 1 snd_mpu401_uart
snd_seq_device 7944 1 snd_rawmidi
snd 50660 11 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mix er_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 9824 1 snd
hw_random 5652 0
usbhid 28864 0
uhci_hcd 29328 0
shpchp 87148 0
pciehp 83948 0
pci_hotplug 30640 2 shpchp,pciehp
intel_agp 20512 0
intel_mch_agp 10000 1
agpgart 31784 2 intel_agp,intel_mch_agp
evdev 9088 0
eth1394 19976 0
ehci_hcd 27908 0
usbcore 104164 5 usbhid,uhci_hcd,ehci_hcd
dmfe 18716 0

BTW the mouse suggestion did not work but thats for later...
Can you spot anything from the modules?
thank You,
jolphil
 
Old 03-09-2005, 02:25 PM   #14
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
The modules look similar than mine, with the difference that I have a different soundcard. Anyway, they look like alsa-modules, as they should, so probably the modules are OK.

If alsaconf gave no error messages, then I'm inclined to think that you should be able to get sound by playing with mixer settings. Apparently KDE has its own mixer, called kmix, so you can start some game (like Frozen Bubble) or other program that makes sounds and then launch kmix and tweak the sound settings to see if that helps.

You can also launch alsamixer again and double-check that Master, PCM, and CD channels are not muted. If they are muted, there's MM at the bottom of the volume bar and if they are not muted, there's OO. You can mute and unmute channels by pressing the M key on your keyboard.

Also check with the id command that you belong to the audio group.
 
Old 03-09-2005, 03:21 PM   #15
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Original Poster
Rep: Reputation: 33
Dead Parrot,
I launched kmix and it appeared to install..I now have a speaker icon on the lower right next to the clock..I played a cd and it plays..I don't have frozen bubble but I have pysol and it plays but i think it may have it's own sound server..Not sure about that one though..I undid the "enable" arts sound and no longer get the error when kde starts..
Wow this is a tooth and nail battle..
Thank you again
jolphil
PS any newer problems and I better use a new post..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic on fresh install Dakkar Linux - General 6 07-09-2005 05:18 AM
Possible to fresh install w/ different kernel?? Archalien Linux - General 1 02-01-2005 09:27 PM
New Kernel on Fresh Install thom Slackware 2 01-24-2004 05:20 PM
Kernel Panic on fresh install CyberLord_7 Linux - General 9 09-24-2003 09:38 AM
Fresh install kernel ? wr3ck3d Linux - Newbie 1 03-28-2003 06:25 PM


All times are GMT -5. The time now is 08:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration