LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   HP 630 Notebook no sound through speakers (http://www.linuxquestions.org/questions/debian-26/hp-630-notebook-no-sound-through-speakers-941339/)

qlue 04-23-2012 01:49 PM

HP 630 Notebook no sound through speakers
 
Hi everyone!
I've installed the 64bit version of Crunchbang on a newish HP Notebook and I can't seem to get the speakers to work. Alsa Mixer doesn't give me any controls for speaker volume and I suspect that the speaker volume controls are 0 by default.
Sound plays well through headphone. I also have Commodore OS Vision installed (based on Linux Mint 10) and sound works well with that Distro.

Here is some further info that may help toward the solution. This seems to be a problem with a too new sound card that's not fully supported by Debian Stable.

Code:

qlue@umzinto:~$ alsactl init
Unknown hardware: "HDA-Intel" "Intel G45 DEVCTG" "HDA:10ec0270,103c3676,00100100 HDA:80862802,80860101,00100000" "0x103c" "0x3676"
Hardware is initialized using a guess method
qlue@umzinto:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: INTEL HDMI [INTEL HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
qlue@umzinto:~$ cat ~/.asoundrc
cat: /home/qlue/.asoundrc: No such file or directory


jim_p 04-25-2012 01:38 AM

Can you please post your lspci (your card in it) and the output of
Code:

cat /proc/asound/card0/codec#* | grep Codec
and a screenshot of alsamixer if possible?

Also, crunchbang is based on debian testing and the g45 is definitely supported in squeeze, if not on lenny :P

qlue 04-26-2012 07:26 AM

2 Attachment(s)
lspci
Code:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Code:

:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ID 270
Codec: Intel G45 DEVCTG

Thanks for responding jim_p :)

qlue 04-26-2012 10:52 AM

1 Attachment(s)
I upgraded to the backports version of Crunchbang and this solved the problem!
For anyone else with this issue, you can do this by opening Synaptic Package Manager;
In Synaptic, select Settings>Distribution
Then select Prefer versions from: and choose squeeze-backports.
You'll have to do an update and upgrade.
Then reboot and voila!
The sound card is now correctly identified by alsactl
Code:

qlue@umzinto:~$ alsactl init
Unknown hardware: "HDA-Intel" "Intel Cantiga HDMI" "HDA:10ec0270,103c3676,00100100 HDA:80862802,80860101,00100000" "0x103c" "0x3676"
Hardware is initialized using a guess method

:hattip:

qlue 04-26-2012 11:00 AM

PS: This also fixes multitouch for the touchpad!


All times are GMT -5. The time now is 05:23 AM.