LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-21-2004, 02:40 AM   #1
lazlow69
Member
 
Registered: Jan 2003
Location: Central New Jersey
Distribution: Knoppix to play, Slack current, OpenBSD stables
Posts: 111

Rep: Reputation: 15
Question HOWTO - disable modules at boot


For the life of me, I can't seem to figure out how to trim down the modules that load at boot time on my debian sarge machine...

/sbin/lsmod produces:

Module Size Used by Not tainted
pcmcia_core 35360 0
rtc 6120 0 (autoclean)
via82cxxx_audio 17756 0 (unused)
ac97_codec 11444 0 [via82cxxx_audio]
uart401 6244 0 [via82cxxx_audio]
sound 50568 0 [via82cxxx_audio uart401]
soundcore 3268 4 [via82cxxx_audio sound]
via-rhine 11056 1
mii 1984 0 [via-rhine]
crc32 2848 0 [via-rhine]
usb-uhci 19696 0 (unused)
usbcore 52908 0 [usb-uhci]
parport_pc 19400 1 (autoclean)
lp 5952 0 (autoclean)
parport 21800 1 (autoclean) [parport_pc lp]
ide-cd 27968 0
cdrom 25088 0 [ide-cd]
ide-disk 12512 5 (autoclean)
ext3 53220 3 (autoclean)
jbd 34852 3 (autoclean) [ext3]
ide-detect 288 0 (autoclean) (unused)
via82cxxx 9448 1 (autoclean)
ide-core 94332 5 (autoclean) [ide-cd ide-disk ide-detect via82cxxx]
unix 13260 8 (autoclean)

and I don't need any via82cxxx_audio, usb or ide-cd support. I'd love to comment out whatever conf files or wherever this control could be had.

Any suggestions as to how to trim out the fat for my server box here?

Thanks!
 
Old 01-21-2004, 07:26 AM   #2
Strike
Member
 
Registered: Jun 2001
Location: Houston, TX, USA
Distribution: Debian
Posts: 569

Rep: Reputation: 31
Well, kernel modules hardly make it any fatter, but you just need to remove them from /etc/modules.
 
Old 01-21-2004, 09:34 AM   #3
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
recompile your kernel and you can eliminate a lot more than just the modules your seeing probably!
Jersey RULZ!
 
Old 01-21-2004, 01:33 PM   #4
ricstirato
Member
 
Registered: Jan 2004
Location: Gießen, Germany
Distribution: Xubuntu 12.04, Mythbuntu, Ubuntu Server 12.04
Posts: 174

Rep: Reputation: 24
If you don't like the universal configuration tool (vi) you might use modconf, which lets you select all modules.
 
Old 01-21-2004, 05:04 PM   #5
lazlow69
Member
 
Registered: Jan 2003
Location: Central New Jersey
Distribution: Knoppix to play, Slack current, OpenBSD stables
Posts: 111

Original Poster
Rep: Reputation: 15
Thanks for the advice so far, but I'm still having some troubles...
my /etc/modules contains only "ide-cd" and "ide-detect"... this isn't where the problem is coming from.

I went into /etc/default and nano'd pcmcia so it doesn't start... that's a help. The 'fat' is still there, though...

I'm in the process of building a nice-n-trim kernel for this box now, but that's introduced its own set of problems... I used 'aptitude' to pull down 2.4.23 kernel sources and kernel-package. 'make menuconfig' 'd the deal to get a nice trim kernel, used make-kpgk buildpackage and installed it, but lilo.conf is complaining about /proc/partitions not matching /dev directory structure...

This is for another thread, I know, but just so you folks don't think I'm sitting with my thumbs up my you-know-how waiting for an easy answer!

I'm sure it will all come out fine in the end, just a little frustratin'!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable Modules on startup Kane2002 Slackware 10 01-22-2005 04:26 PM
howto disable/correct frame buffer? Distorts boot screen... BroX Debian 3 08-16-2004 03:02 AM
disable modules from loading on boot spyderusa11 Fedora 1 05-23-2004 05:58 PM
disable 'usbcore' and 'uhci' modules on boot... lazlow69 Slackware 6 05-09-2004 07:52 PM
howto disable eth0 at boot time rydogg Linux - Newbie 2 06-16-2003 09:33 AM


All times are GMT -5. The time now is 09:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration