LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-15-2004, 10:14 AM   #1
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 745

Rep: Reputation: 64
howto disable/correct frame buffer? Distorts boot screen...


Hey all,

Weehooo! Windows free at last! After dual booting Slack and XP I decided to get rid of XP and, hell why not. give Debian a try on the fresh and shiny partition.

All went well, surprisingly because half of the time I couldn't read the config questions because the screen was (how to explain this....) not focussed... as in shifted to below and the left of the LCD screen. Thought it would be cleared up after proper installation and configuration.

But now when Debian boots, it's still like that as soon as (I think) the frame buffer starts. For example, I only see half a penguin at the top! :-(

Anyone know how to correct this, for example with some boot parameter? (don't really want to start to recompile the kernel yet)

Cheers, Leon.

[EDIT] BTW, after the boot messages have flashed by, and gdm starts, everything is ok with the screen.

Last edited by BroX; 08-15-2004 at 10:25 AM.
 
Old 08-15-2004, 11:03 AM   #2
zero79
Member
 
Registered: Nov 2003
Location: Ohio
Distribution: Debian Unstable
Posts: 460

Rep: Reputation: 30
here is an example grub entry that shows you how to change the framebuffer settings using the "vga=xxx" option passed to the kernel. there is a comment which explains what you want to replace "xxx" with.

http://ruslug.rutgers.edu/~mcgrof/gr...linux/menu.lst
 
Old 08-15-2004, 11:04 AM   #3
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 49
In the /etc/lilo.conf, edit the vga line to read:

vga=normal

In the /boot/grub/menu,lst, in the kopt line, do the same as above, or add it to the kernel line at the end after 'ro', in the menu.lst.
 
Old 08-16-2004, 03:02 AM   #4
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 745

Original Poster
Rep: Reputation: 64
vga=xxx does not help.
By the way, I chainload the Debian boot(if that's the right expression). Debian entry is now under 'Other' in Slack's /etc/lilo.conf I tried changing the vga=xxx in Deb's lilo.conf, and it does have an effect until the framebuffer starts. Then the vga= gets back to default letter size and the above described problem.
I think I have to disable any other frambuffer than my card-specific one (SiS630) in the kernel. Tried to get a kernel source from one of the install cd's but couldn't find any. Now i'm online, makes life easier.

How does one read the different packages on the install cd's? (I mean, I couldn't find any listing on the cd's, like packages.txt or something like that)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
frame buffer doesn't seem to work hubabuba Fedora 2 05-03-2005 12:39 PM
Howto disable Login screen GNOME rohan208 Linux - Newbie 1 05-07-2004 06:48 PM
Help Frame buffer screwed up SlackN00b Slackware 3 01-14-2004 05:00 PM
Frame buffer bkeating Linux - Newbie 6 04-22-2003 06:09 PM
kernel 2.4.17 and frame buffer help hanzerik Linux From Scratch 2 03-12-2002 12:53 PM


All times are GMT -5. The time now is 08:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration