LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 04-10-2004, 03:08 PM   #1
Li...
Member
 
Registered: Feb 2004
Posts: 31

Rep: Reputation: 15
Howto accessing parport0


Hi,

yesterday I get a small utility (avrdude) which needs access to parport0. Currently I've these 3 parport devices in /dev/ as parport[012], but I can't access them. My parallelport is well working when I try "cat textfile > /dev/lp0". But when I try the same with /dev/parport0 then I get the message:

cat: /dev/parport0: No such device

Futhermore I've the follwing parallel port as devices:
crw-rw---- 1 root lp 6, 0 Mar 14 2002 /dev/lp0
crw-rw---- 1 root lp 6, 1 Mar 14 2002 /dev/lp1
crw-rw---- 1 root lp 6, 2 Mar 14 2002 /dev/lp2
crw-rw---- 1 root lp 6, 0 Mar 14 2002 /dev/par0
crw-rw---- 1 root lp 6, 1 Mar 14 2002 /dev/par1
crw-rw---- 1 root lp 6, 2 Mar 14 2002 /dev/par2
crw-rw---- 1 root lp 99, 0 Apr 9 22:49 /dev/parport0
crw-rw---- 1 root lp 99, 1 Apr 9 22:49 /dev/parport1
crw-rw---- 1 root lp 99, 2 Apr 9 22:49 /dev/parport2

What's wrong?

Li
 
Old 04-10-2004, 03:50 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,590

Rep: Reputation: 188Reputation: 188
"Currently I've these 3 parport devices in /dev/ as parport[012], but I can't access them. My parallelport is well working when I try "cat textfile > /dev/lp0". But when I try the same with /dev/parport0 then I get the message: "

Your parport drivers may not be loaded. Use:
find /lib -iname "*parport*"
to see if you have your parport drivers installed.

Use:
lsmod
to see if your parport drivers are loaded.

Use modprobe to load the relevent modules. See:
man modprobe

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
accidentally deleted /dev/parport0 ebil Linux - Hardware 5 04-21-2005 08:35 PM
Nothing Prints. Problem with /dev/parport0 VorlonInfoTech Linux - Hardware 3 02-20-2005 02:39 PM
parport0 error using my HP printer sKru Linux - Newbie 4 05-18-2004 02:23 AM
Parport0 error with my HPOfficeJetG85 sKru Linux - Hardware 0 05-17-2004 04:22 AM
/dev/parport0 probs The Yeti Lives Linux - General 0 08-06-2003 03:58 AM


All times are GMT -5. The time now is 03:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration