LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-06-2009, 09:24 AM   #1
mgrant
LQ Newbie
 
Registered: Dec 2008
Posts: 7

Rep: Reputation: 0
how to use xterm instead of Gnome Terminal


Is there something I can set somewhere that will use an xterm instead of the gnome terminal application when I start a terminal session from the Gnome menu? I just am not keen on Gnome Terminal's cut/paste needing multiple clicks in the menu and the fact that it doesn't use the same copy/paste buffer that xterm uses.

This will inevitably bring me to another question... Can someone please tell me where one modifies the default xterm properties like getting it to come up with a scroll-bar and such?

Thanks.

Michael Grant
 
Old 07-06-2009, 09:55 AM   #2
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 664
Blog Entries: 11

Rep: Reputation: 36
On my system I go to "System->Preferences->Preferred Applications" and switch to the "System" tab. From there you would change the settings to suit you. There is a dropdown option on my system for "Standard XTerminal" but I haven't tried it. If that doesn't launch the terminal emulator of your choice, select "Custom" and enter the command that will launch the one you want.

Otherwise you can go to "System->Preferences->Main Menu" and click on "Accessories" on the left. This should bring up the list of all menu items under "Accessories" on the right. Then right click on the "Terminal" listing on the right. This will allow you to change the properties of the menu entry by opening up a dialog box called "Launcher Properties". Change the command to something like "xterm" and save. You can pass command line options in this way as well.
 
1 members found this post helpful.
Old 07-06-2009, 06:03 PM   #3
mgrant
LQ Newbie
 
Registered: Dec 2008
Posts: 7

Original Poster
Rep: Reputation: 0
And it appears you also have to restart the window manager for it the change to take effect.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Get the title of xterm/gnome-terminal redleafong Linux - Software 6 01-10-2011 06:38 PM
Error opening terminal: xterm Terminal type "xterm" unknown Pscylo Slackware 10 04-17-2009 06:33 AM
Gnome-terminal Font size Xterm fhleung Debian 1 09-10-2007 09:30 PM
Need help using xterm or gnome-terminal with -e option?? Rickj42 Programming 1 08-12-2003 12:45 PM
Need help using xterm/gnome-terminal with -e option?? Rickj42 Linux - Software 0 08-11-2003 10:31 PM


All times are GMT -5. The time now is 12:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration