LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-16-2005, 02:40 PM   #1
Naysayer13
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Rep: Reputation: 0
How to stop Xwindows from loading Gnome/Sawfish


**Note - this was originally posted in 'newbie' forum, and it was suggested that I post it here as well**

Some would think this a really easy question, and I hope that it is, but after scouring countless sites and threads, I have yet to find an answer. I have just installed Debian 'woody', and did so without any problems. On reboot, it automatically loads xwindows, then the gnome/sawfish GUI. The gnome/sawfish GUI does not allow me to login as 'root' (I'm assume for security reasons). So I login as a user, and it takes me to the GUI. But I need to exit out of the gnome/sawfish GUI, and login as root, to make sure I have loaded the right modules/devices + I want to play around with some commands to become more familiar.

1) How, step by step, do I exit out of Gnome/sawfish back to the command line to login as ROOT?
2) What are the steps, to stop Xwindows from automatically loading the Gnome/sawfish at bootup?

Thanx in advance
Aj
 
Old 03-16-2005, 03:09 PM   #2
thegeekster
Member
 
Registered: Dec 2003
Location: USA (Pacific coast)
Distribution: Vector 5.8-SOHO, FreeBSD 6.2
Posts: 513

Rep: Reputation: 33
For the first question, you will need to change runlevels.............Open up a gnome terminal or xterm window, then su to root on the command line...................After logging in as root on the command line, run the command 'init 2' to change to runlevel 2.

That's it........If the desktop doesn't shut down automatically at this point, simply log out of Gnome, and you will then be taken to the command line............You can then logout as the current user, and log in as the root user.

For the second question, I'm still new to the Debian way of doing things, so I'm not sure...........I installed Knoppix to the hard drive, which uses KDE and I'm a big fan of KDE, so I haven't bothered to check how it determines the default desktop.........Some distros have a simple file to edit for the default desktop to use, and I know Slackware uses a symlink for /etc/X11/xinit/xinitrc which points to the rc script for the default desktop you want to use........

HTH
 
Old 03-17-2005, 08:24 AM   #3
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
I have not tried disabling Gnome or KDE, but you can choose which windowmanager is started (with startx - with no display manager (xdm/gdm/kdm) running) by editing file

$HOME/.xinitrc

For example, my /home/basil/.xinitrc looks like this:

# My .xinitrc

wmaker

# end of file

So it starts WindowMaker by default. Xdm might actually use the same file to determine which windowmanager to launch...

---

To log into a real console (temporarily) you can press Ctrl-Alt-F1 (or F2-F6) and log in. You can get back to the X-Window system with Ctrl-Alt-F7.

Hope this helps.
 
Old 03-19-2005, 06:39 PM   #4
ruddigger
LQ Newbie
 
Registered: Sep 2004
Distribution: Debian Sarge
Posts: 13

Rep: Reputation: 0
If you change the default runlevel you should make sure that the one that you change to won't start you in graphical mode as well. Even if I'm new to debian myself I read a bit and so far I understand that all the runlevels are the same. You should edit your runlevel configuration for this and get rid of GDM (or whatever you have) by stoping the service...
But I think that there is something else that you might try doing (This works fine for sarge but give it a try) follow the directions in the debian reference manual http://www.debian.org/doc/manuals/re...erence.en.html and go directly to point 9.4.12 Getting root in X
Hope it helps
 
Old 03-19-2005, 06:46 PM   #5
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 31
Code:
apt-get install sysvconfig
Run it, shut off xdm/gdm/kdm, reboot.
 
Old 03-20-2005, 11:07 AM   #6
Naysayer13
LQ Newbie
 
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Thanx to everyone that responded. I tried Xtermial, used the SU, and was able to initiate most commands, so that is fine. The problem which has not resolved itself is 'logout/shutdown' Logging out of the GUI, takes me back to the Gnome 'login' screen, and there is no option to shutdown from there. Funny, you cant login as the root, but when in the GUI and the option 'shutdown' is choosen, it says you must be 'root' - a perpetual catch 22
 
Old 03-20-2005, 01:13 PM   #7
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 591

Rep: Reputation: 31
Hi,

If you have installed the standard sarge normally by default you have installed both desktops ( kdm and gdm) and by default gdm runs at the boot time.
Now the gdm is running by default in level 2 ( unlike redhat for example) so if you want really disable the graphical interface in level 2 , delete the link from /etc/rc2.d.

If you want to log as root with graphical interface, in the log window you have button for preferences , go the security and disable the security for loging as root, and you have other preferences to change you log in.
you can do it ( I mean the configuration of the logging) from your desktop, pop the system menu you 'll find a boutton for customizing the looging window, ( you 'll asked for root pssword).


best regards
bela
 
Old 03-20-2005, 01:15 PM   #8
thegeekster
Member
 
Registered: Dec 2003
Location: USA (Pacific coast)
Distribution: Vector 5.8-SOHO, FreeBSD 6.2
Posts: 513

Rep: Reputation: 33
Quote:
Originally posted by Naysayer13
...The problem which has not resolved itself is 'logout/shutdown' Logging out of the GUI, takes me back to the Gnome 'login' screen, and there is no option to shutdown from there...
Do as ruddigger suggests, by changing the runlevel configuration in the /etc rc#.d directories, such as /etc/rc2.d or /etc/rc3.d. The number in the rc#.d directory correspond to the runlevel being used............You want to make sure there is no S99gdm or S99kdm or S99xdm symlinks (and in the case of a Knoppix installation, remove S90xsession) in the directory of the runlevel you don't want the xserver to start automatically.......Note, you want these links to stay in /etc/rc5.d, as runlevel 5 is the traditional runlevel to automatically start the xserver, while runlevels 2 and 3 are usually reserved for running Linux in text mode and need to be removed in these directories........

I've been digging around since my last post on the Debian way of initiating the startup scripts, and found that a lot of the deb packages will populate ALL the rc#.d directories with links to their startups scripts found in /etc/init.d without asking first.........Very annoying, to say the least, if you don't want to have a whole bunch of daemons started automatically during boot time (To be fair, there are a few packages that will ask first if you want its daemon to be started automatically during boot)....

KDE has a SysV-Init Editor, which allow you to add, remove and edit the startup scripts. I'm not sure what the Gnome equivalent is called, but I'm pretty sure Gnome will have one.............At any rate, by removing those S99 links I mentioned in /etc/rc2.d or /etc/rc3.d will allow you to change to runlevel 2 or 3, respectively, without having the xserver restarting automatically..

HTH
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with sawfish and gnome 2. Sawfish won't load! the mirror Linux - Software 4 05-14-2011 07:48 PM
Gnome/Sawfish with antialias shack Linux - Software 0 12-25-2003 09:29 AM
I don't get the relationship of Sawfish and GNOME 2.0 JoeLinux Linux - Software 1 09-21-2002 02:59 AM
Sawfish Themese /w GNOME ryanstrayer Linux - General 2 01-27-2002 01:13 PM
How do I stop Xwindows from autostarting ehsan Linux - General 2 03-14-2001 09:26 AM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration