LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   how to set keyboard-layout during initialization? (http://www.linuxquestions.org/questions/debian-26/how-to-set-keyboard-layout-during-initialization-201461/)

jonaskoelker 07-05-2004 04:36 PM

how to set keyboard-layout during initialization?
 

STATUS: Solved
Thanks to macondo for providing the solution. It's in post #3. Thanks to everybody else for input; note that the thread goes a bit OT after the solution.


Hello.

I wish to use the dvorak keyboard layout, and I wish it to be loaded when I log in to tty1. Oh, and X doesn't work for me yet, so a console-only solution will do just fine.

I had this set the way I wanted (thanks to Debian for including Dvorak in the installer!), but somehow screwed with it when I completed base-config. I tried re-running base-config, but it didn't bring up the option screen where I screwed up. Hm. I think I'll run tasksel and dselect, just for fun :)

Anyways, the reason I ask for help in the distro forum is that I seached for both "keyboard layout" and "dvorak", no results that work for Woody. I googled for a similar selection of terms, also to no avail.

Also, I'm kinda' embarrased to ask such a simple question, but hey... nobody's perfect. Except August Dvorak :D

- Jonas

Not now, John! 07-05-2004 06:10 PM

This shoul work.
First, look in '/usr/share/kbd/keymaps/i386/dvorak' folder and choose your keyboard layout.
Then make link for default keyboard like this:
Code:

ln -s i386/dvorak/<your-keymap-file> /usr/share/kbd/keymaps/defkeymap.map.gz
Create file /etc/rc.d/init.d/loadkeys with following content:
Code:

#!/bin/sh
# Begin $rc_base/init.d/loadkeys - Loadkeys Script

# Based on loadkeys script from LFS-3.1 and earlier.
# Rewritten by Gerard Beekmans

. /etc/sysconfig/rc
. $rc_functions

case "$1" in
        start)
                echo -n "Loading keymap..."
                loadkeys -d
                evaluate_retval
                ;;
        *)
                echo "Usage: $0 {start}"
                exit 1
                ;;
esac

# End $rc_base/init.d/loadkeys

Now, type this:
Code:

ln -s ../init.d/loadkeys /etc/rc.d/rcsysinit.d/S70loadkeys
After that, your keyboard map should be loaded whenever you start your comp.

macondo 07-05-2004 07:58 PM

jonaskoelker:

as root:

dpkg-reconfigure console-data

Choose keyboard from arch list
Choose Dvorak
if u don't know answers in the next options screens, leave blank press Enter
get outta Dodge
reboot
************************

"Oh, and X doesn't work for me yet,"

The Very Verbose Debian 3.0 Installation Walkthrough
http://osnews.com/story.php?news_id=2016

Sections 9/10
Installing XFree86 - Part I
Installing XFree86 - Part II

jonaskoelker 07-06-2004 06:30 AM

to Not now, John: thanks for the effort, but I guessed it wouldn't work, since /etc/rc.d/ and /etc/sysconfig/ doesn't exist. However, I already have a loadkeys file; "loadkeys dvorak" does what one would expect. The reason I posted in "Debian" was that I wanted a Debian specific (or at least Debian functional solution). Still, thank you for the effort :)

to Macondo: yep, it worked; dvorak is back on track (wohoo!); The installation guide seems very good, in the case the installer does what you want it to; when errors occur (my case), you're on your own though - I'll probably make a post on this too. But thanks for the link, and thanks a lot for the solution. :) :) :)

case closed, court dismissed.

-- Jonas

macondo 07-06-2004 09:27 AM

If you follow the instructions in the article to the letter, there will be no errors. Debian is easy:

dpkg-reconfigure locales or xdm or whatever app you installed.
dpkg-reconfigure xserver-xfree86
dpkg-reconfigure console-data

google for 'debian + dpkg-reconfigure'

Read Debian's documentation, manuals, howtos, at www.debian.org

jonaskoelker 07-06-2004 12:23 PM

thanks, again
 
oh. I'll try that some time; not right now, though...

thanks again :)

jonaskoelker 07-15-2004 09:26 AM

wee, X works
 
yeah, now X works.

It actually have been for a few days (I've lost count since I started to skip sleep);
Dvorak map works, the _right_ windows key (and the menu key) works. NumPad works. Even the internet works.

but one thing's amiss: sound; however, I'm not done testing;
I just wanted do to a heads up and say thanks for the help.

so: thanks.

-- Jonas

macondo 07-15-2004 02:47 PM

as root:

modconf

look for sound modules, press Enter

choose the modules for your sound card, press Enter

follow instructions, if you don't know what to append, leave blank

reboot

zuralin 07-15-2004 05:00 PM

make sure you have yourself added in the audio group (you need to login and log out before changes will take effect). Also make sure your sound isnt muted using something like alsamixergui


All times are GMT -5. The time now is 06:15 PM.