LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-18-2007, 01:13 PM   #1
el amigo*
Member
 
Registered: Dec 2006
Location: República Dominicana
Distribution: CentOS, Scientific Linux
Posts: 122

Rep: Reputation: 15
-How to reset Xfce to "factory" settings in Etch ?


Hi Friends,

My 2 Etch boxes are doing perfect, thanks to the help of some posters here. On one of the boxes, I experiment problem in Xfce : I am missing the "window frame" (the bar on top of the window, with the "minimize", "maximize" and "close" buttons).

I think it is because the first time I used Xfce, its default resolution was 1280x1024, on a 17" CRT monitor that is better under 1024x768 res'... So I booted under Gnome, edited xorg.conf, and all was fine... Except that Xfce behaves funny.

I have to mention that it is only the case under my own user account. When I boot Xfce under my wife's account, it is absolutely fine.

So here's my question :

-Is there a way to reset Xfce to its "factory" settings , or its default configuration ?

Thanks in advance for your advices,
 
Old 04-18-2007, 02:39 PM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
I'm not an XFCE user so you'll want another opinion, but maybe removing (well, first try renaming) the .xfce directory, or equivalent, under your home directory? Some programs create their config files in "hidden" directories (that start with a dot) under the homedirectory of a user, so I'd start off by checking if xfce uses one and then rename it and restart xfce..if it doesn't work, move the directory back in place or if it does, remove it.
 
Old 04-18-2007, 06:17 PM   #3
el amigo*
Member
 
Registered: Dec 2006
Location: República Dominicana
Distribution: CentOS, Scientific Linux
Posts: 122

Original Poster
Rep: Reputation: 15
it didn't work, but thank you for your assistance anyway.
 
Old 04-18-2007, 07:54 PM   #4
SweetLou
Member
 
Registered: Oct 2004
Distribution: Debian Testing
Posts: 171

Rep: Reputation: 30
What did you change/remove? I don't have a .xfce directory. My settings are kept in .config
I have not looked closely, but don't just remove the .xfce/Xfce4 directory, rename the entire .config directory.

Last edited by SweetLou; 04-18-2007 at 07:55 PM.
 
Old 04-19-2007, 05:50 AM   #5
el amigo*
Member
 
Registered: Dec 2006
Location: República Dominicana
Distribution: CentOS, Scientific Linux
Posts: 122

Original Poster
Rep: Reputation: 15
what I did was renaming .config to ***.config***

That didn't change anything...
 
Old 04-19-2007, 06:54 AM   #6
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
If xfce (which I also don't know) creates configuration files on runtime then it's not possible for you to do it.
Either there is an option for xfce Restore default setting
Or you reinstall xfce
1)(apt-get PURGE ... followed by apt-get install, not apt-get reinstall)
2) you reinstall with forcing the overwriting of the configuration files of xfce and it's dependencies.

My way of knowing configuration files for a package is this:
dpkg -s <package_name>
then you have to backup/erase these conf files.
and then you reinstall xfce giving dpkg option
--force-confmiss
so that when reinstalling the package it will see that conf files are missing and recreate them (without confmiss the system will never erase/recreate your conffile for safety reasons)

Sorry it's only rough ideas, not a list of commands.
 
Old 04-19-2007, 09:26 AM   #7
el amigo*
Member
 
Registered: Dec 2006
Location: República Dominicana
Distribution: CentOS, Scientific Linux
Posts: 122

Original Poster
Rep: Reputation: 15
Thank you, I'll try it over the week-end, and post my feedback...

I am mostly a Gnome user, but on those boxes, Xfce makes a difference, because they run on a Via Samuel C3 (796Mhz) cpu...
 
Old 04-19-2007, 03:30 PM   #8
James4coffee
LQ Newbie
 
Registered: Oct 2006
Location: London UK
Distribution: debian etch,Ubuntu Dapper, Edgy
Posts: 25

Rep: Reputation: 15
[QUOTE
I have to mention that it is only the case under my own user account. When I boot Xfce under my wife's account, it is absolutely fine.

So here's my question :

-Is there a way to reset Xfce to its "factory" settings , or its default configuration ?

Thanks in advance for your advices,[/QUOTE]

As it only goes funny in your one account, you could try by creating a new account for yourself and then delete the old account.
Hope this helps
james
 
Old 04-19-2007, 10:46 PM   #9
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 36
I do believe that XFCE settings are also stored in .cache directory. You could try to rename / remove that one as well.
 
Old 04-23-2007, 06:16 PM   #10
el amigo*
Member
 
Registered: Dec 2006
Location: República Dominicana
Distribution: CentOS, Scientific Linux
Posts: 122

Original Poster
Rep: Reputation: 15
Ok,I want to thank all the posters who helped me out. It worked, I now have a brand new Xfce "out of the factory" !

Here's how I managed to do it, thanks to your advices :

-1- In Synaptic, search "Xfce", and select all Xfce related packages, for complete removal. Close Synaptic.

-2- Delete files in .cache (in /home/username, hidden files)

-3- Delete .config (also in /home/username, hidden files)

-4- in terminal, apt-get clean

-5- Open Synaptic again, search for "Xfce", and install all Xfce related packages.

And that's it, folks !

I signed out my session, and signed in again in a "shiny brand new" Xfce, without any of the problems of the old one !!!

I hope this might help other users who encountered the same problem as I did...
 
Old 12-19-2009, 02:08 PM   #11
youngmix
LQ Newbie
 
Registered: Dec 2009
Distribution: Ubuntu 9.10x64 VM XPx32
Posts: 1

Rep: Reputation: 0
Cool Easy Answer

I just opened Nautilus as the root user, went to my .config folder, selected my xfce folders and deleted them. Then I opened a tab in the root user nautilus and navigated to my wife's .config folder and copied her xfce folder to my .config folder. Worked like a charm.
Typing

sudo nautilus

in the terminal will give you the root user file/folder navigation. So, the file paths are

/home/yourname/.config

In Nautilus, click the "View" option, then select "Show Hidden Files". This will reveal your hidden folder, which all begin with a "."
I typed this to help others looking for an easy answer.

Also, you can create a new account and open Xfce with it, and you should have a brand new Xfce .config file to use.

Last edited by youngmix; 12-19-2009 at 02:18 PM. Reason: extra options
 
Old 12-19-2009, 03:10 PM   #12
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,368

Rep: Reputation: 1173Reputation: 1173Reputation: 1173Reputation: 1173Reputation: 1173Reputation: 1173Reputation: 1173Reputation: 1173Reputation: 1173
Hi,
i have a few comments on you "steps"

Quote:
Originally Posted by el amigo* View Post
Here's how I managed to do it, thanks to your advices :

-1- In Synaptic, search "Xfce", and select all Xfce related packages, for complete removal. Close Synaptic.
Unless you "purged" not just removed the packages, system config files would be left behind. Anyway, unless you were doing strange things as root, these files should be fine.

Quote:
-2- Delete files in .cache (in /home/username, hidden files)

-3- Delete .config (also in /home/username, hidden files)
Things other than xfce will store data in these directories so you may now find other programs behaving differently to how they did before.

Quote:
-4- in terminal, apt-get clean
All this does is remove .deb files that apt has previously downloaded, forcing you to download them again: completly unrelated to your problem

Quote:
-5- Open Synaptic again, search for "Xfce", and install all Xfce related packages.

I hope this might help other users who encountered the same problem as I did...
Probably all you had to do was log in on a console and
Code:
mv ~/.config/xfce ~/.config/xfce.back
mv ~/.cache/xfce ~/.cache/xfce.back

Evo2.
 
Old 07-16-2010, 07:53 PM   #13
tocado157
LQ Newbie
 
Registered: Jul 2010
Posts: 1

Rep: Reputation: 0
try this

vi ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml
change <property name="Resolution" type="string" value="1024x768"/>

By ToCaDo157

ps:Fun!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"clear" and "reset" bash commands broken AviJacobson Linux - General 6 07-03-2006 06:28 AM
"clear" and "reset" bash commands broken AviJacobson Linux - Software 1 06-29-2006 02:31 PM
what is difference between "reset" and "clean " commands? zameer_india Linux - Newbie 2 01-10-2005 06:23 AM


All times are GMT -5. The time now is 11:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration