LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   How to Map to SAMBA by same user from 2 different PCs? (http://www.linuxquestions.org/questions/debian-26/how-to-map-to-samba-by-same-user-from-2-different-pcs-413729/)

newinlinux 02-10-2006 03:51 AM

How to Map to SAMBA by same user from 2 different PCs?
 
Hi!
I have a nice debian etch samba server running on a P3. I used to have one MS XP Pro notebook mapped to its shared folder. But today I have a new M$ XP Pro desktop being set up. I thought I can just mapped to the same share just like the notebook. But I cannot.I think there's something theat I have not set correctly. Could you please advise? Both notebook are on a same Windows Server domain and using a single login name(same name). TIA

Here's the smb.conf, pardon the long text:

#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
#
# Any line which starts with a ; (semi-colon) or a # (hash)
# is a comment and is ignored. In this example we will use a #
# for commentary and a ; for parts of the config file that you
# may wish to enable
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not many any basic syntactic
# errors.
#

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = ASIAPACIFIC

# server string is the equivalent of the NT Description field
server string = %h server (Samba %v)

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable its WINS Server
; wins support = no

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
; wins server = w.x.y.z

# This will prevent nmbd to search for NetBIOS names through DNS.
dns proxy = no

# What naming service and in what order should we use to resolve host names
# to IP addresses
; name resolve order = lmhosts host wins bcast


#### Debugging/Accounting ####

# This tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/log.%m

# Put a capping on the size of the log files (in Kb).
max log size = 1000

# If you want Samba to only log through syslog then set the following
# parameter to 'yes'.
; syslog only = no

# We want Samba to log a minimum amount of information to syslog. Everything
# should go to /var/log/samba/log.{smbd,nmbd} instead. If you want to log
# through syslog you should set the following parameter to something higher.
syslog = 0

# Do something sensible when Samba crashes: mail the admin a backtrace
panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# "security = user" is always a good idea. This will require a Unix account
# in this server for every user accessing the server. See
# /usr/share/doc/samba-doc/htmldocs/Samba-HOWTO-Collection/ServerType.html
# in the samba-doc package for details.
security = user

# You may wish to use password encryption. See the section on
# 'encrypt passwords' in the smb.conf(5) manpage before enabling.
encrypt passwords = true

# If you are using encrypted passwords, Samba will need to know what
# password database type you are using.
passdb backend = tdbsam

obey pam restrictions = yes

; guest account = nobody
invalid users = root

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
; unix password sync = no

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
; pam password change = no


########## Printing ##########

# If you want to automatically load your printer list rather
# than setting them up individually then you'll need this
; load printers = yes

# lpr(ng) printing. You may wish to override the location of the
# printcap file
; printing = bsd
; printcap name = /etc/printcap

# CUPS printing. See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
; printing = cups
; printcap name = cups

# When using [print$], root is implicitly a 'printer admin', but you can
# also give this right to other users to add drivers and set printer
# properties
; printer admin = @ntadmin


######## File sharing ########

# Name mangling options
; preserve case = yes
; short preserve case = yes


############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
; include = /home/samba/etc/smb.conf.%m

# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/speed.html
# for details
# You may want to add the following on a Linux system:
# SO_RCVBUF=8192 SO_SNDBUF=8192
socket options = TCP_NODELAY

# The following parameter is useful only if you have the linpopup package
# installed. The samba maintainer and the linpopup maintainer are
# working to ease installation and configuration of linpopup and samba.
; message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

# Domain Master specifies Samba to be the Domain Master Browser. If this
# machine will be configured as a BDC (a secondary logon server), you
# must set this to 'no'; otherwise, the default behavior is recommended.
; domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
; idmap uid = 10000-20000
; idmap gid = 10000-20000
; template shell = /bin/bash

#======================= Share Definitions =======================

[homes]
comment = Home Directories
browseable = no

# By default, the home directories are exported read-only. Change next
# parameter to 'yes' if you want to be able to write to them.
writable = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
create mask = 0775

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
directory mask = 0775

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
; comment = Network Logon Service
; path = /home/samba/netlogon
; guest ok = yes
; writable = no
; share modes = no

[printers]
comment = All Printers
browseable = no
path = /tmp
printable = yes
public = no
writable = no
create mode = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
read only = yes
guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# Replace 'ntadmin' with the name of the group your admin users are
# members of.
; write list = root, @ntadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
; comment = Samba server's CD-ROM
; writable = no
; locking = no
; path = /cdrom
; public = yes

# The next two parameters show how to auto-mount a CD-ROM when the
# cdrom share is accesed. For this to work /etc/fstab must contain
# an entry like this:
#
# /dev/scd0 /cdrom iso9660 defaults,noauto,ro,user 0 0
#
# The CD-ROM gets unmounted automatically after the connection to the
#
# If you don't want to use auto-mounting/unmounting make sure the CD
# is mounted on /cdrom
#
; preexec = /bin/mount /cdrom
; postexec = /bin/umount /cdrom

satinet 02-10-2006 08:20 AM

when you say map, do you mean map a network drive??

and what is your error message(s)?

newinlinux 02-10-2006 10:18 PM

Yes, map the samba share via XP's Map Network Drvie.

Sorry I dont have access to that desktop now, so not able to reproduce the errors message in XP. Will post again when I go back to work next week. If i remember correctly, it was complaining unattached device or something.

The thing is that my XP notebook has no problem mapping the share. And it is the 1st XP that I have set up right after my samba server is done. The desktop that is having problem is the second XP that I intend to map samba.

Hope this is not too confusing, i dont speak/write english very well.

thanks

newinlinux 02-13-2006 02:24 AM

Ok, here's the error message shown in my XP Pro Desktop when I attempted to map the samba share:

The mapped network drive could not be created because of the following has occurred:

A device attached to the system is not functioning.

Anyone has any idea how to solve this? I intend to have all my files stored in my samba server and make accessible by both of my notebook and desktop.

TIA

newinlinux 02-23-2006 02:26 AM

Anyone has any idea on this? Please help a noob here :cry:

satinet 02-23-2006 04:46 AM

the reason it's hard to help is the ludocrous length of your smb.conf file - i'd be happy to look - but i'm not sifting thru that beast. maybe re- post will all the irrelevant stuff taken out.

which share are you actually trying to access? are you using the same username and password??? as far as i can see you've only set up homes for real browsing as you haven't put "valid users =" on any other share. so which share is the one you are trying to map?

newinlinux 02-23-2006 08:16 AM

sentinel, thanks for looking at this.

LOL, the reason for the long smb.conf is that i dont know what to remove :) I will spend some time tomorrow to reread the conf and see which one i should remove so that it will appear shorter.

I was trying to access my /home/newinlinux from 2 machines that run XP Pro. Both machines have signed into MS Server directory domain(my guess:scratch: )using identical username and passwd, this is a common arrangement for those who has a notebook and a desktop in my company.

1st machine, this case is my notebook, has no problem to browse /home/liewkmbr. But the problem is my 2nd machine, the desktop, cannot connect to the samba share.

About valid users, how should I make use of this?

Thanks!

satinet 02-23-2006 08:18 AM

are both machines trying to browse to:

/home/liewkmbr

newinlinux 02-23-2006 08:23 AM

Yes, that's right.

Thanks!

satinet 02-23-2006 08:25 AM

at thet same time?

not sure you can do that... both clients are XP??

newinlinux 02-23-2006 08:30 AM

yes, same time. And also permanently mapped to the share in XP too. So i cannot do this? I thought this is a very common situation in an office environment:scratch:

satinet 02-23-2006 08:46 AM

well, easy way to check this:

turn the machine that works off, then try the other machine.

several machines can access a directory at once. but not sure about the [homes] section as that is different/

i would also set up a seperated, test samba share.

e.g.

[test]
path = /tmp
read only = Yes
guest ok = no
browseable = yes
valid users = liewkmbr


and see if both / nay machines can browse it.

i have another idea. are both windows machines using the same NT logon? how did you map the usernames??

dracae 02-23-2006 09:30 AM

The homes section is created automatically based on username. For this to work with your windows clients, they must both be using the same username AND password. Windows has a ugly habit of allowing users without passwords.

newinlinux 02-23-2006 09:40 AM

Quote:

Originally Posted by satinet
well, easy way to check this:

turn the machine that works off, then try the other machine.

several machines can access a directory at once. but not sure about the [homes] section as that is different/

i would also set up a seperated, test samba share.

e.g.

[test]
path = /tmp
read only = Yes
guest ok = no
browseable = yes
valid users = liewkmbr


and see if both / nay machines can browse it.

i have another idea. are both windows machines using the same NT logon? how did you map the usernames??

Ok, I will try the suggestions on tomorrow when i am with the machines.

Yes, both machines are using the identical usernames & passwd ie liewkmbr and !@#$(passwd). These , i believe are stored in both the M$ server directory and my 2 PCs.

At my debian samba, I have created liewkmbr and also the identical passwd(same as the one used in XP) through smbpasswd too. These are fine and well for just one of my machine. The second one, as u alsready know, wont do.

newinlinux 02-23-2006 09:43 AM

Quote:

Originally Posted by dracae
The homes section is created automatically based on username. For this to work with your windows clients, they must both be using the same username AND password. Windows has a ugly habit of allowing users without passwords.

thanks for the suggestion. My company has strict passwd policy, i cannot have a set up without passwd. I have matched the XPs username and passwd with samba.

TIA


All times are GMT -5. The time now is 12:08 AM.