LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-30-2009, 12:31 AM   #1
wearetheborg
Member
 
Registered: Sep 2004
Distribution: Mint 13 Maya
Posts: 268

Rep: Reputation: 31
How to make X startup faster ?


Debian Lenny AMD64
Dell precision M6400 laptop with nvidia 2700M, 1920x1200
nvidia drivers, compiled into kernel.

Works great, except that X takes up a long(ish) time to load up. I'm currently trying to reduce my bootup time.
Currently its 27s of which 7s is just for X to startup

I get the feeling that the monitor is being probed everytime and this is wasting time.

I added my resolution to the xorg.conf file, it did not help

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder62)  Thu Feb  5 00:08:50 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
    Modeline "1920x1200_50.00"  158.08  1920 2032 2240 2560  1200 1201 1204 1235  -HSync +Vsync
    Option      "PreferredMode"   "1920x1200_50.00"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes       "1920x1200_50.00"
  EndSubSection
EndSection
 
Old 03-30-2009, 01:29 AM   #2
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Are you using some desktop effects of any kind? Because at least for me, in Ubuntu, Gnome with effects on takes a couple of extra seconds to start, so I disable it (besides, I found it ratter buggy and pointless).

You are also using a Nvidia card. Do you get the Nvidia logo when X starts? If you do, you could disable it by adding this line under Section "Device" on you xorg file:

Option "NoLogo"

Good luck!
 
Old 03-30-2009, 08:13 AM   #3
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Disable Xorg's autodetection of video devices.

http://sparc86.wordpress.com/2009/02...nfig-function/
Code:
Section “ServerFlags”
     Option “AutoAddDevices” “False”
EndSection
ignore probed EDID data and just use specified mode..
Code:
Section “Screen"
    Option "UseEdid" "False"
EndSection
Not sure if that will help or not.. but I think that is what you are asking for. In addition to Mega Mans suggestion.

Let us know if any or all those suggestions speed things up or just break X for you
 
Old 03-30-2009, 07:13 PM   #4
wearetheborg
Member
 
Registered: Sep 2004
Distribution: Mint 13 Maya
Posts: 268

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by Mega Man X View Post
Are you using some desktop effects of any kind? Because at least for me, in Ubuntu, Gnome with effects on takes a couple of extra seconds to start, so I disable it (besides, I found it ratter buggy and pointless).

You are also using a Nvidia card. Do you get the Nvidia logo when X starts? If you do, you could disable it by adding this line under Section "Device" on you xorg file:

Option "NoLogo"

Good luck!
Yes, I am using gnome effects, but I'm only timing bootup till the login screen.

I was getting the nvidia splash screen, and your line did disable it, but it has not decreased the boot time (or maybe decreased it by 0.5s, I could not tell).


farslayer
, X was still working under the ServerFlags option, but again no improvement in startup time.
With the UseEdid flag, I just got a blank black screen (powered).

Here is what happens when X is trying to start during bootup:
4 s black screen (powered)
2 s black screen (unpowerd)
2 s nvidia splash screen and gdm login menu.

Thanks guys

Last edited by wearetheborg; 03-30-2009 at 07:14 PM.
 
Old 03-31-2009, 01:44 PM   #5
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
What about Option "NoDDC" under nvidia device section to disable ddc probing?
 
Old 03-31-2009, 10:42 PM   #6
wearetheborg
Member
 
Registered: Sep 2004
Distribution: Mint 13 Maya
Posts: 268

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by makuyl View Post
What about Option "NoDDC" under nvidia device section to disable ddc probing?
Tried it, no effect.

What does the NoDCC option do ?
 
Old 04-01-2009, 10:23 AM   #7
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Quote:
Originally Posted by wearetheborg View Post
What does the NoDCC option do ?
Stops ddcprobing the video card and monitor for modes and syncs. Probably it doesn't happen on every X start anyway, but it was worth a shot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox/Iceweasel Seamonkey/Iceape ..faster startup times?? stratotak Linux - Newbie 5 06-19-2009 10:41 PM
faster startup scripts zvonSully Debian 2 02-16-2006 11:01 AM
Making startup faster with Knoppix 3.4 enemorales Linux - Newbie 1 11-05-2004 05:37 AM
How do I make suse faster on startup? AGilley007 Linux - Distributions 1 08-06-2004 09:32 PM
oOo --> that handy faster startup proggie Vlad_M Linux - Software 2 05-14-2003 08:11 PM


All times are GMT -5. The time now is 07:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration