LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-10-2007, 12:35 PM   #1
Tresmius
LQ Newbie
 
Registered: Mar 2007
Location: Scotland
Distribution: Debian Etch
Posts: 7

Rep: Reputation: 0
How to load modules?


I'm getting error messages - 'x*' not found in /proc/modules
i did a little research using google, and apparently that file lists modules which are loaded, so my question is, how do i load modules? Is there a package i can download to that loads them, one i already have even, do i do it manually?
Any help much appreciated
 
Old 03-10-2007, 12:39 PM   #2
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 41
using the command:

modprobe "nameofmodule"..

example:

modprobe forcedeth

You can load modules manually using this command.

My question though, when do you get your error ? During boot time?
 
Old 03-10-2007, 01:21 PM   #3
Tresmius
LQ Newbie
 
Registered: Mar 2007
Location: Scotland
Distribution: Debian Etch
Posts: 7

Original Poster
Rep: Reputation: 0
actually, your answer was probably correct, because the error message comes up when i type modprobe "nameofmodule"
e.g when i type modprobe ndiswrapper, i get FATAL: Module ndiswrapper not found in /proc/modules
so what is causing this, and how should i resolve the problem?
 
Old 03-11-2007, 12:43 AM   #4
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
How did you install the module?
 
  


Reply

Tags
module, modules, proc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modprobe: FATAL: Could not load /lib/modules/.../modules.dep Ankardo Debian 9 02-01-2011 05:09 PM
FATAL: Could not load /lib/modules/2.6.14-default/modules.dep no such file exist dr_zayus69 Linux - Software 3 12-26-2005 06:44 PM
Load old modules Infinite_Pizza Linux - Hardware 1 04-21-2004 02:17 AM
FATAL: could not load /lib/modules/2.6.1/modules.dep Fr33B33R Slackware 3 01-12-2004 05:40 AM
modules.conf - Cannot get modules to load automatically gundelgauk Linux - General 1 12-27-2003 11:27 PM


All times are GMT -5. The time now is 09:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration