LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 02-15-2005, 01:02 PM   #1
VertX
Member
 
Registered: Aug 2004
Posts: 115

Rep: Reputation: 15
How to install QT&GTK* without GNOME & KDE?


I'm installing debian sarge netinstall.

I want to install Qt & GTK* but without GNOME & KDE (I will use windowmaker or something), and Qt & GTK libraries are needed to run programs, written for them.

In package manager:
I deselect GNOME, package manager also deselects GTK! Why? GTK can't work without GNOME? I don't think so.. Manually selecting GTK packages after GNOME deselected them is not very good idea..

How to install QT&GTK* without GNOME & KDE?
 
Old 02-15-2005, 02:22 PM   #2
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 46
try: apt-get install gtk2 gtk2-devel qt qt-devel
 
Old 02-15-2005, 02:27 PM   #3
yotamk
Member
 
Registered: Nov 2004
Location: ~
Distribution: Debian
Posts: 145

Rep: Reputation: 15
Just install what you need with apt-get. When you'll "apt-get" a program that's depending on gtk or qt, apt will fetch them for you...

Good luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem after upgrade of gtk & gnome 2.11 (suse 9.0) xmarcusx Suse/Novell 2 09-13-2005 10:32 AM
Creating & Exiting Tray Icon in KDE & GNOME pihu Linux - General 0 09-07-2005 03:02 AM
Japanese canna won't work : Warning: かな漢字変&am OrganicOrange84 Debian 3 06-30-2005 03:28 PM
Phục hồi dữ liệu bị mất???, cứ pollsite General 1 06-27-2005 01:39 PM
Glib & GTK+ versions 1.2.10 & 2.4.0 RaVilj Linux - Software 9 06-18-2004 06:30 PM


All times are GMT -5. The time now is 03:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration