LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 12-17-2009, 03:58 AM   #1
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,019

Rep: Reputation: 63
How to increase font size of xterm?


How to increase font size of xterm and the size of xterm window?
 
Old 12-17-2009, 04:45 AM   #2
AleLinuxBSD
Member
 
Registered: May 2006
Location: Italy
Distribution: Ubuntu, ArchLinux, Debian, SL, OpenBSD
Posts: 272

Rep: Reputation: 37
Configuring Xterm in Linux
I have tried only the on fly method:
Quote:
pressing [Ctrl] key and the right mouse button simultaneously while you have focus in xterm window. Then a pop-up menu will come up which can be used to set the font size to your taste. By pressing [Ctrl] key and the middle mouse button, you get a pop-up menu which helps you set/unset a lot of other features of your xterm window like enabling/disabling the scroll bars and so on.
 
Old 12-17-2009, 04:45 AM   #3
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Debian, SL
Posts: 5,202

Rep: Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121Reputation: 1121
<Ctrl> Right-mouse, to get a menu.

Settings can be saved in your .Xdefaults or .Xresources

See:
http://invisible-island.net/xterm/xt...tml#how2_fsize

Cheers,

Evo2.
 
Old 12-20-2009, 11:37 AM   #4
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
an easy workaround is:
Quote:
xterm -fa monaco -fs 13 -bg black -fg green &
here is my .Xdefaults:
Quote:
!after editing .Xdefaults it may be reloaded with:
!xrdb -load ~/.Xdefaults

xterm*VT100*geometry: 94x28
xterm*font: -misc-fixed-medium-r-normal--20-200-75-75-c-100-iso8859-1
xterm*background: black
xterm*foreground: lightblue
xterm*loginShell: true
xterm*scrollBar: true
xterm*rightScrollBar: true
xterm*title: XTerm
xterm*iconName: XTerm
xterm*saveLines: 50000
xterm*jumpScroll: true
xterm*scrollTtyOutput: false
xterm*scrollKey: true
xterm*alwaysUseMods: true
xterm*metaSendsEscape: true
xterm*utf8Title: true
i only changed the fond, the foreground and the background.
fonts are to be found in /etc/X11/fonts. i did it the try and error way with the fonts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to increase the font size in emacs CodeWarrior Linux - Software 4 11-04-2009 10:34 PM
increase font size? MsDoomshroom DamnSmallLinux 4 04-22-2008 02:15 PM
Xterm font size onelung02 Slackware 4 03-28-2005 04:34 PM
Increase of fonts size in xterm macondo Debian 3 11-03-2004 08:46 AM
Xterm font size liguorir Linux - Software 3 01-10-2004 08:44 AM


All times are GMT -5. The time now is 03:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration