LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-25-2010, 12:12 AM   #1
Peterius
Member
 
Registered: May 2004
Distribution: Gentoo, Debian, OpenBSD, NetBSD
Posts: 157

Rep: Reputation: 16
how to get X not to use KMS?


A recent Debian update in unstable(sid?) seems to require KMS for my Thinkpad x60:

(EE) intel(0): No kernel modesetting driver detected.

Latest kernel 2.6.36 and i915.modeset=1 has the screen go black on booting and it doesn't come back.

Is there anyway to use X without modesetting?

Last edited by Peterius; 10-25-2010 at 02:34 AM.
 
Old 10-25-2010, 04:29 AM   #2
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Testing/Unstable Amd64
Posts: 1,476

Rep: Reputation: Disabled
Quote:
Is there anyway to use X without modesetting?
Change modeset=1 to nomodeset in /etc/default/grub.
Don't forget to run update-grub afterward.
 
Old 10-25-2010, 12:22 PM   #3
Peterius
Member
 
Registered: May 2004
Distribution: Gentoo, Debian, OpenBSD, NetBSD
Posts: 157

Original Poster
Rep: Reputation: 16
Thanks for reading. I meant X, not the kernel?
 
Old 10-25-2010, 01:21 PM   #4
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 481

Rep: Reputation: 108Reputation: 108
Modesetting is part of the vga drivers, which in turn are part of the kernel.
 
Old 10-25-2010, 01:35 PM   #5
Peterius
Member
 
Registered: May 2004
Distribution: Gentoo, Debian, OpenBSD, NetBSD
Posts: 157

Original Poster
Rep: Reputation: 16
I know that modesetting is part of the kernel. I also know that X worked without it before the debian update. The kernel driver is broken, and I want to get X to not have a problem with modesetting being off.

Nevermind, I'll submit a bug report and hope they fix it.

Last edited by Peterius; 10-25-2010 at 01:41 PM.
 
Old 10-27-2010, 01:30 AM   #6
Peterius
Member
 
Registered: May 2004
Distribution: Gentoo, Debian, OpenBSD, NetBSD
Posts: 157

Original Poster
Rep: Reputation: 16
Apparently you have to use KMS and KMS doesn't work with framebuffer drivers in the kernel. So I removed them and my laptop boots now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon kms works! dolphin77 Slackware 147 01-05-2012 05:32 AM
[SOLVED] 640x480 resolution with radeon and KMS bamdad Linux - Hardware 7 08-25-2010 07:07 PM
[SOLVED] i915 and KMS? Pratt Slackware 5 03-04-2010 10:19 AM
Linux KMS Intel 865G: Hacking KMS to use vesa... or disable hardware acceleration eantoranz Linux - Hardware 1 08-01-2009 12:58 PM
KMS with radeon gives garbled screen with x onlyolli Linux - Software 0 06-29-2009 04:14 PM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration