LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-21-2012, 10:11 AM   #1
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
How to disable gnome popup notifications in squeeze?


If I try to remove "notifications-daemon", a lot of other packages need to be removed that I don't want removed.

If I run "notification-properties", I have the option of selecting the popup window theme and position, but I don't have the option of turning it off.

Does anyone know where to go to disable popup notifications in Squeeze?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 01-21-2012, 02:26 PM   #2
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,200

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
I am not on Squeeze at the moment so I can't check this but have you checked in your gconf-editor?
Code:
gconf-editor
That is where I would look first.
 
Old 01-21-2012, 03:13 PM   #3
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Original Poster
Rep: Reputation: 54
I tried gconf-editor, and looked under Apps>Notification-daemon, but it has no option to turn off the popup notifications. The only fours options are default-sound, popup_location, sound_enabled, and theme.
 
Old 01-22-2012, 12:42 AM   #4
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,200

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
Boy I don't know. I popped over here to Squeeze to have a look. Does seem kind of hard wired.

I did look at the options in gconf-editor and wonder what would happen if you just blanked out the position key. Maybe change the position to "false" if leaving it blank is not an option. And blank out the "theme" too.

This is an OS I really like but don't use much. Set up for secure uses. Because of that I am not experimenting with something that is set up. Sorry.
 
Old 01-22-2012, 05:00 AM   #5
demosthenese
LQ Newbie
 
Registered: Sep 2010
Distribution: debian sid/xfce
Posts: 24

Rep: Reputation: 4
Quote:
Originally Posted by m_yates View Post
If I try to remove "notifications-daemon", a lot of other packages need to be removed that I don't want removed.
This is a classic metapackage problem. It is discussed at length here, with possible solutions.
 
Old 01-22-2012, 10:58 AM   #6
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Original Poster
Rep: Reputation: 54
I found a solution, as root do:

Quote:
chmod 000 /usr/lib/notification-daemon/notification-daemon
Gnome is frustrating. It is nice to have simplicity as a goal, but some times simplicity gets in the way. In any event, the above command will prevent the notification daemon from running. If you want to restore the popup notifications, you can reset permissions with:

Quote:
chmod 755 /usr/lib/notification-daemon/notification-daemon
 
2 members found this post helpful.
Old 01-22-2012, 01:32 PM   #7
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,200

Rep: Reputation: 368Reputation: 368Reputation: 368Reputation: 368
Very good. I like it.
 
Old 01-22-2012, 03:10 PM   #8
odiseo77
Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 968

Rep: Reputation: 282Reputation: 282Reputation: 282
Thanks for sharing the solution. I had exactly the same problem when I was using Gnome 2 (now I don't even use Gnome, but that's another story ).

Cheers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Temporarily disable notifications in KDE cantab Linux - Desktop 11 08-15-2010 11:06 PM
please help me disable volume meter popup phreakshew Linux Mint 4 06-01-2010 05:00 PM
How to disable mouse over popup on LQ? dbtarr LQ Suggestions & Feedback 1 12-18-2008 09:07 PM
Howto create popup notifications like on the pic vargadanis Programming 6 05-28-2007 02:37 PM
Disable Sound Notifications in Kmess? wh33t Linux - Software 1 10-29-2003 06:40 PM


All times are GMT -5. The time now is 05:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration