LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-11-2004, 09:27 AM   #1
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Rep: Reputation: 48
How to change background and fonts color in xterm?


Hi guys: i did a dist-upgrade and was fine, except, my xterm is in white with black fonts. I googled, and edited /etc/X11/apps-defaults/XTerm-color but nada!

I want my background black with white fonts.

Any ideas?

thank you!

mac
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 03-11-2004, 09:39 AM   #2
utabintarbo
LQ Newbie
 
Registered: Jan 2002
Location: Sterling Heights, MI
Distribution: Mainly Ubuntu, Gentoo, RedHat
Posts: 27

Rep: Reputation: 15
I believe you can do it with a command line option.

ie.
Code:
xterm -fg white -bg black
Bob
 
Old 03-11-2004, 12:10 PM   #3
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Original Poster
Rep: Reputation: 48
thanks utabintarbo: the thing is, as soon as you close the xterm and restart another one, it reverts to the original problem.

mac
 
Old 03-28-2004, 10:05 AM   #4
asabjorn
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Rep: Reputation: 0
To change the color permanently in the RHL default terminal you have to change the Terminals default profile. In the menu choose >>
edit->Profiles
Mark the profile named 'default' by clicking on it. In the menu choose>>
edit.
A window will pop up an in the top you will see 'colors', select that. Uncheck box 'Use colors from system theme', and then you will be able to select 'White on Black' or anything else as you please.

Andreas

Last edited by asabjorn; 03-28-2004 at 10:07 AM.
 
Old 03-29-2004, 01:22 AM   #5
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
type man xterm
create a file named(sensitive case) XTerm in your home directory with your specs

XTerm*Background: linen
XTerm*Foreground: black
XTerm*font: 9x15
XTerm*saveLines: 1000
XTerm*HiForeColor: white
XTerm*HiBackColor: #c06077
XTerm*geometry: +50+100

Last edited by mrcheeks; 03-29-2004 at 01:24 AM.
 
3 members found this post helpful.
Old 08-07-2008, 01:51 AM   #6
prajakta0shimpi
LQ Newbie
 
Registered: May 2007
Posts: 16

Rep: Reputation: 0
How do I do it in runlevel 3 or 2 ??
I do not find xterm command there....
 
Old 08-07-2008, 02:06 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,615

Rep: Reputation: Disabled
On run level 2 and 3 you already have a command line. These run levels are for that purpose. Why do you need a terminal emulator when you already are working on command line.
 
Old 08-07-2008, 02:31 AM   #8
prajakta0shimpi
LQ Newbie
 
Registered: May 2007
Posts: 16

Rep: Reputation: 0
Hi,

What I need is to change background to white
 
Old 08-07-2008, 03:41 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,615

Rep: Reputation: Disabled
This will help you a bit. You will have to look out for color schemes and color numbers. For making changes permanent put this line in .bashrc

export PS1="\e[0;31m[\u@\h \W]\$ \e[m "
 
Old 07-09-2012, 06:02 PM   #10
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,570

Rep: Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510
This topic is the first Google result for "xterm black background", so sorry for the necro, but the question is IMO not clearly answered and contains several totally irrelevant replies.

If you want your XTerm color to be white font on black background, then create or edit a file named .Xdefaults in your home directory, and place the following in it:

Code:
XTerm*Background: black
XTerm*Foreground: white
Then restart xterm.

You can of course switch the colors if you want black on white.
 
Old 09-20-2012, 06:22 PM   #11
60lpsdf250
LQ Newbie
 
Registered: Aug 2011
Location: Texas, USA
Distribution: Arch Linux, FreeBSD, Gentoo, LFS 6.8, 7.1 (updating to LFS 7.2)
Posts: 2

Rep: Reputation: Disabled
Quote:
Originally Posted by AlucardZero View Post
This topic is the first Google result for "xterm black background", so sorry for the necro, but the question is IMO not clearly answered and contains several totally irrelevant replies.

If you want your XTerm color to be white font on black background, then create or edit a file named .Xdefaults in your home directory, and place the following in it:

Code:
XTerm*Background: black
XTerm*Foreground: white
Then restart xterm.

You can of course switch the colors if you want black on white.
Thanks for the necro. Works perfectly.
 
Old 06-18-2013, 06:06 AM   #12
osirisgothra
LQ Newbie
 
Registered: Feb 2013
Posts: 1

Rep: Reputation: Disabled
and so...6 months later i say

Quote:
Originally Posted by AlucardZero View Post
This topic is the first Google result for "xterm black background", so sorry for the necro, but the question is IMO not clearly answered and contains several totally irrelevant replies.

If you want your XTerm color to be white font on black background, then create or edit a file named .Xdefaults in your home directory, and place the following in it:

Code:
XTerm*Background: black
XTerm*Foreground: white
Then restart xterm.

You can of course switch the colors if you want black on white.
This is exactly right, too many people are responding with irrelevant replies, please people read the | o )amn topic before posting messages!!
 
Old 03-07-2014, 08:42 AM   #13
MicBert
LQ Newbie
 
Registered: Mar 2010
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by AlucardZero View Post
This topic is the first Google result for "xterm black background", so sorry for the necro, but the question is IMO not clearly answered and contains several totally irrelevant replies.

If you want your XTerm color to be white font on black background, then create or edit a file named .Xdefaults in your home directory, and place the following in it:

Code:
XTerm*Background: black
XTerm*Foreground: white
Then restart xterm.

You can of course switch the colors if you want black on white.
There is also a parameter 'reverseVideo', which can be 'true' or 'false'. If it is true, like:
Code:
XTerm*reverseVide: true
background and foreground colors are inverted.

Mich
 
  


Reply

Tags
xterm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Change font color xterm aeruzcar Linux - Software 3 01-04-2012 04:48 PM
Change background in solaris and Xterm background also EvilAngel Solaris / OpenSolaris 2 01-31-2005 11:25 AM
Change background color chingyenccy Linux - Newbie 6 01-23-2005 03:17 AM
How do I change the background color of xterm permanently? vxc69 Linux - Software 7 11-19-2004 02:27 PM
Is there a way to change background color out of X? purpleburple Linux - General 1 01-23-2003 08:32 AM


All times are GMT -5. The time now is 09:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration