LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 12-13-2004, 10:10 AM   #1
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Rep: Reputation: 35
How to avoid xdm login at startup?


OK, I am a Slackware user and I have to configure a friend's machine to work with Debian. I have some experience (though I'm not experienced) with Slackware but I don't know much for Debian. So:

I was able to do a network install, booting the install process form DOS&Loadlin. I upgraded some of the packages with apt-get and after a lot of troubles, I installed the X packages. But on the next boot it loaded xdm instead of the console login.
The big problem is that X doesn't work properly and shows one wide white bar on a black background. From this moment the machine stops responding, and I can only restart it, damaging the filesystem(ext2). The same repeats on every boot. I can't break the execution of the startup scripts, so I can't change anything.
I can use the installation files to boot the system from Loadlin and I can mount the root filesystem, but I don't know how to make it not load X at startup.
/etc/inittab shows default runlevel 2. I thought this isn't graphical login, but I'm not sure. lso the videocard and monitor ARE properly configured and it's strange that they doesn't work.

Sure, I'll stay with Slackware on my machine.
The post seems too long, but I can't explain it shorter.
 
Old 12-13-2004, 10:18 AM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
When you boot into X, just press crtl+alt+f1, this will take to a command line.

Then edit your /etc/inittab file. The first config option you come too should look like this:
id:4:initdefault:

Then change the 4 to a 3. I hvaen't used Debian, but I think that is the right runlevel to use. It should say in the comment above the option.
 
Old 12-13-2004, 10:24 AM   #3
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Original Poster
Rep: Reputation: 35
Thank you for your fast reply, I know how to get to the console from X when the machine is responsible, but the keyboard doesn't work, nor the mouse.None of Ctrl-Alt-F1,F2, Ctrl-Alt-Backspace, Ctrl-Alt-plus/minus works.

And as I said inittab shows default runlevel to be 2. (not 4)
 
Old 12-13-2004, 10:31 AM   #4
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Using LILO? Hold down the CTRL key during boot. That'll force LILO to show the boot menu. Then you can force it to boot into a specific runlevel with imagename runlevel. For example, boot with Linux 1 will force it into runlevel 1.

I'm not 100% sure with Debian, since I'm having issues getting it working on my system, but I do know that CLI is runlevel 2 in Slackware, and was runlevel 3 in RedHat back when I was running that. (think back to RedHat 4... )
 
Old 12-13-2004, 10:35 AM   #5
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Original Poster
Rep: Reputation: 35
But, how can I know if I should go to runlevel 3 or runlevel 4 or other?
For now I'll try them one by one to see which should work. thanks.
 
Old 12-13-2004, 10:40 AM   #6
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
4 and 5 are usually X. 2 and 3 are usually CLI multi-user. 1 is CLI single-user.
 
Old 12-13-2004, 12:36 PM   #7
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Original Poster
Rep: Reputation: 35
My Debian loads xdm in all of the runlevels I tried. However I readed the scripts one by one to find out what is what and I removed from /etc/rc2.d/ a file with xdm in the name and made the default runlevel to be 2. Then I booted the normal system and I had the normal text-mode login.
But I still have the feel that this is not the normal way.
 
Old 12-13-2004, 05:53 PM   #8
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Rep: Reputation: 49
HOWTO INSTALL DEBIAN

i know you slakies don't like to read, but this will solve your menial problems and tell you the 'why' of things.

HOWTO install Debian with the net-installer-rc2
http://www.linuxquestions.org/questi...hreadid=261506
 
Old 12-13-2004, 07:11 PM   #9
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
Re: HOWTO INSTALL DEBIAN

Quote:
Originally posted by macondo
i know you slakies don't like to read, but this will solve your menial problems and tell you the 'why' of things.

HOWTO install Debian with the net-installer-rc2
http://www.linuxquestions.org/questi...hreadid=261506
Nah, we really do like to read. Just that we don't want to read a 100 page doc on how to install a OS.

We do have to read the config files to configure stuff. Just makes more sense to do this:

vi /etc/inittab
<change run level>
:wq

And the problem is if fixed. Everything should be as easy as Slack.
 
Old 12-13-2004, 08:44 PM   #10
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
FYI, in Debian runlevels 2-5 are identical after installation -- it's left for the admin to decide which runlevel to use for text mode and which one for GUI. So, tweaking /etc/inittab does little to no good unless you edit the symlinks in /etc/rc{2-5}.d/ , like iZvi has already noticed. BTW, I have also chosen in my Debian system runlevel 2 for text mode and runlevel 3 for GUI, but it's really up to yourself how you wish to set them.

You can add/remove/modify these symlinks with any means you wish -- there are even GUIs available for this, but Debian provides a command line tool called update-rc.d, that is quite handy if you know the syntax (it's documented in "man update-rc.d").

And Debian has also a tool for configuring X, "dpkg-reconfigure xserver-xfree86".

Please read the instructions before you try to install Debian, use the Debian tools for setting up Debian, and tell what version of Debian you are installing when you ask for help. This makes things easier for all of us.
 
Old 12-13-2004, 11:40 PM   #11
NetSnake
LQ Newbie
 
Registered: Sep 2004
Location: China
Distribution: Debian 3.0r2 unstable
Posts: 28

Rep: Reputation: 15
Why so traditional?

Just remove /etc/rc2.d/S99xdm.
If you want start it again, create a link from /etc/init.d/xdm:
ln -s /etc/init.d/xdm /etc/rc2.d/S99xdm

Or you can chmod -x /etc/init.d/xdm to disable xdm auto start.
 
Old 12-14-2004, 05:50 AM   #12
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
Just remove /etc/rc2.d/S99xdm.
If you want start it again, create a link from /etc/init.d/xdm:
ln -s /etc/init.d/xdm /etc/rc2.d/S99xdm

Or you can chmod -x /etc/init.d/xdm to disable xdm auto start.
Yes, these are the traditional methods and they should work just fine. However, you should stick to only one method (whichever you happen to choose) and not mix chmod'ing some services and manipulating others via symlinks, or you might end up in confusion.

To disable xdm the Debian way you'd first remove symlinks to /etc/init.d/xdm from all runlevels with "update-rc.d -f xdm remove". Then, if you wish, you can make xdm to start only when you enter runlevel 3 and to stop when you shutdown or reboot with "update-rc.d xdm start 99 3 . stop 01 0 6 .". There, now that was easy.

The Debian method, update-rc.d, is most useful on computers where the runlevels 2-5 are all customized to start different services. The more you edit different runlevels, the more you'll want to use a simple and efficient tool like update-rc.d. But if disabling xdm is about the only service tweak you're ever going to make, then by all means use any old method that you happen to know.
 
Old 12-14-2004, 08:27 AM   #13
iZvi
Member
 
Registered: Mar 2004
Location: Valhalla
Distribution: Slackware-current, kernel 2.6.31
Posts: 284

Original Poster
Rep: Reputation: 35
Quote:
Originally posted by macondo
i know you slakies don't like to read, but this will solve your menial problems and tell you the 'why' of things.
I am not going to learn the "why of things" for the moment, but I like to read about Linux and progs, however the Debian docs are quite big and make sense when you read from the beginning to the end.
So in a case when time is important factor it is not apropriate to read enormouse docs. Also Slackware isn't that kind of distro, coming with GUI install and hardware autodetection, so a Slackware user should read a lot to configure everything and I wonder why you mentioned this about us not liking to read.

Thanks for the replies. The first running of debian was disappointing, but I see one needs to understand it (basically package management and its tools seem most important to be understood) in order to use and enjoy it. So the feel of disappointment disappeared after some hours with it.
It is complicated for unexperienced/first users with Debian and that's all.

One last thing I'll ask for is some links to good readings (docs,tuts, and books) for Debian to pass to my friend (It's early for me to dive in the deep waters of Debian ).

Last edited by iZvi; 12-14-2004 at 08:28 AM.
 
Old 12-14-2004, 10:50 AM   #14
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Rep: Reputation: 49
LOL! you prove my point...

"I am not going to learn the "why of things" for the moment, but I like to read about Linux and progs, however the Debian docs are quite big and make sense when you read from the beginning to the end."

Hehe! i can see you never clicked on the url, i gave you, it only takes 15 minutes to read, but you are not going to read it, because it's simpler to hack, and when something comes out wrong it's debian's fault.

The secret is in the installation. If you do it correctly, there's nothing to hack!
 
Old 12-14-2004, 12:04 PM   #15
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Yes, Debian package management with apt-get (or Aptitude or Synaptic) is perhaps the most important part to learn if your friend wants to enjoy his/her ride with Debian. (Although I agree with macondo that a clean install makes the rest of the journey much smoother.) Here's the official APT HOWTO:
http://www.debian.org/doc/manuals/ap.../index.en.html

And here are some (not too long) newbiedocs:
http://newbiedoc.sourceforge.net/sys...get-intro.html
http://newbiedoc.sourceforge.net/sys...els-intro.html

And macondo's Debian Post-Install Configuration guide offers many useful tips for new Debian users:
http://www.linuxquestions.org/questi...hreadid=224547

When your friend has some extra time to do some heavy-duty reading, he/she will find many answers from this document:
http://www.debian.org/doc/manuals/re...erence.en.html

And here are some more in-depth guides to GNU/Linux operating system in general, often represented from the Debian point of view:
http://www.dsl.org/cookbook/cookbook_toc.html
http://www.icon.co.za/~psheer/book/index.html.gz

And, finally, here's a useful tip: Don't forget to install the apt-listbugs package. It will warn about packages that are reported to be buggy. Perhaps I need not emphasize that it is NOT recommendable to install the packages that apt-listbugs warns about, unless your friend decidedly wants to break his/her Debian system.

I hope you got the X startup problem solved. The X log file in /var/log/ often helps to locate such problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xdm doesn't login Tylerious Linux - Software 5 09-22-2005 08:30 AM
Xdm and login backgrounds. Paiway Linux - Software 1 12-14-2004 02:40 AM
Automatic login to X without XDM? JohnKFT Slackware 3 10-02-2004 12:22 PM
default login name in XDM - How2do? tortenteufel Linux - Software 0 06-26-2004 02:22 AM
XDM opens XDM after login jpbarto Linux - Software 1 01-26-2004 10:23 PM


All times are GMT -5. The time now is 02:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration