LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-06-2005, 01:31 AM   #16
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53

You could try something like this in /etc/fstab :
/dev/hda1 /mnt/window ntfs noauto,users,exec,ro,umask=000 0 0

If you want to set uid and gid use the following but umask already took care of permissions to read and execute.
/dev/hda1 /mnt/window ntfs noauto,users,exec,ro,uid=root,gid=users,umask=000 0 0
 
Old 10-06-2005, 07:34 AM   #17
Matty-J
Member
 
Registered: Jun 2004
Distribution: SuSE 9.3, Debian Sarge
Posts: 65

Rep: Reputation: 15
Hi,

thanks for your help, I'll try that tonight after work.

Should I add the ntfs support to modconf since I usually have to do modprobe ntfs to get it to work? Or does fstab take care of that?

Thanks,
Matt
 
Old 10-06-2005, 08:44 AM   #18
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
You can add it with modconf or manually to whatever file you use for loading modules. Perhaps under some file in /etc/modprobe.d/ or with 2.4 kernels /etc/modules.conf
 
Old 10-06-2005, 04:05 PM   #19
Matty-J
Member
 
Registered: Jun 2004
Distribution: SuSE 9.3, Debian Sarge
Posts: 65

Rep: Reputation: 15
Hi,

When I edited fstab, I got this after I exited:

Code:
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
Any idea?
I entered
/dev/hdb1 /mnt/window ntfs noauto,users,exec,ro,umask=000 0 0
into fstab.

Thanks,
Matt
 
Old 10-06-2005, 04:17 PM   #20
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
The error has nothing to do with what you typed in fstab, but rather how you edited it. It is often easiest to use a console editor to edit files as root. "apt-get install nano" and as root type "nano /etc/fstab", nano is self explanatory at the bottom of the screen, ctrl-x to quit and so on. If you wish to use a gui editor as root, "apt-get install sux" and use sux instead of su to become root.
 
Old 10-06-2005, 04:38 PM   #21
Matty-J
Member
 
Registered: Jun 2004
Distribution: SuSE 9.3, Debian Sarge
Posts: 65

Rep: Reputation: 15
HI,

I was using vi, is that not good enough?

Also, now the filesystem is mounted when the computer starts up, but I still can't access it. If I try through Konqueror, it says it doesn't exist. If I try through Konsole as root, I can get into the directory, but ls doesn't bring up anything.

Any ideas?

Thanks,
Matt

Edit: I'm not sure, but I don't think fstab mounted it properly because I can still actually use the mount command to mount /dev/hdb1 to /mnt/windows. If I do this, I'm then able to see all the files in the directory... Still can't access with a normal user though.

Last edited by Matty-J; 10-06-2005 at 04:42 PM.
 
Old 10-07-2005, 02:46 AM   #22
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
It shouldn't be automounted on bootup while you have the noauto option for it in fstab. Change it to auto if you like.
What does the command "mount" say about it?
What are the permissions on the mountpoint? Writable to users?

Last edited by makuyl; 10-07-2005 at 02:47 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help me to add support! ilectrcbob Linux - Newbie 1 06-19-2004 09:38 AM
How do I add support for NTFS to Fedora? jdruin Fedora 9 05-08-2004 04:10 AM
Rebuilding kernel to add NTFS support Odd_Bloke Linux - General 4 11-10-2003 01:40 AM
How to add access 4 ntfs? Quest Linux - General 1 11-07-2002 05:01 AM
Add NTFS Support to RedHat 7.2 Kernel RedHatMN Linux - Distributions 4 01-22-2002 07:49 PM


All times are GMT -5. The time now is 12:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration