LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-25-2005, 07:48 PM   #1
shuego
LQ Newbie
 
Registered: Nov 2005
Posts: 18

Rep: Reputation: 0
How do you disable console mode?


I went to restart my comp and came back about 15 mins later and I discovered my computer was in console mode and I have no clue how to get out of it. I can log in as root but thats all I know right now at this point. if anyone can help me with this please post asap cause I just did something on my comp I need to finish.

Thanks
 
Old 11-25-2005, 07:58 PM   #2
Samsara
Member
 
Registered: May 2003
Distribution: Ubuntu, Mac OS X Tiger
Posts: 481

Rep: Reputation: 32
On most systems, Alt+F7 gets you into graphical mode. If this does not work, it's likely that graphical mode is not running. In this case, return to console with Alt+F1 and as root, execute
Code:
/sbin/init 3 && /sbin/init 5
If this does not work, it is likely that your X configuration is broken.

HTH,

Samsara
.
 
Old 11-25-2005, 10:27 PM   #3
kmoffat
Member
 
Registered: Jul 2003
Location: near Seattle
Distribution: Debian/Ubuntu/Suse
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
From console mode,
you can try "startx",
or "/etc/init.d/gdm start" to get to a graphical login screen.
(assuming X is set up)
 
Old 11-26-2005, 04:56 AM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally posted by Samsara
On most systems, Alt+F7 gets you into graphical mode. If this does not work, it's likely that graphical mode is not running. In this case, return to console with Alt+F1 and as root, execute
Code:
/sbin/init 3 && /sbin/init 5
If this does not work, it is likely that your X configuration is broken.

HTH,

Samsara
.
Debian does not use the same runlevel system as other distros. Almost everything is run in runlevel 2 using scripts to enable or disable services.
 
Old 11-26-2005, 05:12 AM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,309

Rep: Reputation: 1032Reputation: 1032Reputation: 1032Reputation: 1032Reputation: 1032Reputation: 1032Reputation: 1032Reputation: 1032
Quote:
Originally posted by reddazz
Debian does not use the same runlevel system as other distros.
Why am I not surprised ...
One day I must try Debian and figure it out once and for all ...
 
Old 11-26-2005, 08:45 AM   #6
dastrike
Member
 
Registered: Apr 2004
Location: Stockholm, Sweden
Distribution: Debian 'sid'
Posts: 250

Rep: Reputation: 30
Starting up the X Window System through a display manager if for some strange reason it didn't start automatically
Code:
/etc/init.d/gdm start
(if you are not using gdm as your display manager replace gdm with kdm or xdm or some other...)

But I suspect there is something wrong since it is to say the least not exactly common for it not to start automatically.

To list all errors and warnings from the X log file, execute:
For XFree86 (Debian 3.1 'sarge'):
Code:
grep '^(EE)\|^(WW)' /var/log/XFree86.0.log
For X.Org (Debian testing 'etch', unstable 'sid'):
Code:
grep '^(EE)\|^(WW)' /var/log/Xorg.0.log
This should give a good clue on to what is going wrong. If this is still not enough, you can take a look at the entire X log file by:
For XFree86 (Debian 3.1 'sarge'):
Code:
less /var/log/XFree86.0.log
For X.Org (Debian testing 'etch', unstable 'sid'):
Code:
less /var/log/Xorg.0.log
Press q to quit less when you are done.


To re-run the X Window System configuration, execute:
For XFree86 (Debian 3.1 'sarge'):
Code:
dpkg-reconfigure xserver-xfree86 --priority=medium
For X.Org (Debian testing 'etch', unstable 'sid'):
Code:
dpkg-reconfigure xserver-xorg --priority=medium
Omit the --priority=medium part if you want to see all the questions (that normally aren't that necessary to explicitly answer)
 
Old 12-02-2005, 07:08 PM   #7
shuego
LQ Newbie
 
Registered: Nov 2005
Posts: 18

Original Poster
Rep: Reputation: 0
I just decided to download Fedora Core 4. Im running it now and I love it! Also I tried all those things and they wouldnt work.... Thanks anyway
 
Old 12-04-2005, 07:51 PM   #8
Samsara
Member
 
Registered: May 2003
Distribution: Ubuntu, Mac OS X Tiger
Posts: 481

Rep: Reputation: 32
Quote:
Originally Posted by reddazz
Debian does not use the same runlevel system as other distros. Almost everything is run in runlevel 2 using scripts to enable or disable services.
My apologies. People should not assume, however, that by posting in a Debian forum, they are declaring to use Debian. TS could make things much easier by indicating this in their profile or actual post.

Samsara
.
 
Old 12-08-2005, 06:50 PM   #9
mjolnir
Member
 
Registered: Apr 2003
Posts: 669

Rep: Reputation: 68
Nice info dastrike, I am going to bookmark this page because I am certain sooner or later I will need it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable the new mail notification in console mode? retypedef Linux - Newbie 6 03-21-2010 04:15 AM
how do I disable graphics acceleration in console mode lemuel Linux - General 4 01-10-2005 04:57 PM
Mandrake 9.2's boot process entirely done in console mode before loading in X mode... mishmash Mandriva 6 02-17-2004 09:19 PM
disable standby mode? wimva Linux - Newbie 7 09-23-2003 09:06 AM
Booting up in X server... how do I disable it or fall back to console mode? Delmarc Linux - Newbie 3 09-06-2003 08:23 PM


All times are GMT -5. The time now is 05:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration