LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-31-2008, 07:52 AM   #1
walterbyrd
Member
 
Registered: Apr 2004
Posts: 565

Rep: Reputation: 30
How do I set default font size in Debian Sid - using xorg.conf not xfree86


I am using debian sid with xorg - not xfree86, and icewm. My fonts are very sharp, but now they are sometimes too small.

After a recent apt-get upgrade, my fonts in the toolbar in my apps like iceweasel, gedit, and abiword, became very tiny, the same thing happened to the fonts in the icewm toolbar and menus. The screen resolution did not change - just the font size.

I edited userChrome, and my ~/.icewm/preferences file, and fixed the fonts in iceweasel and icewm; but the fonts in the toolbars of my apps are still too tiny. Also, when a help box appears - like when I want to open of save a file - the fonts are all very tiny.

There is a file called /etc/X11/fs/config that may have something to do this. There is a section at the bottom that looks like this:

# in decipoints
default-point-size = 120
# x1,y1,x2,y2,...
default-resolutions = 100,100,75,75

I am guessing I could change the font size by editing this, but I have no idea how.
 
Old 02-02-2008, 11:22 AM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 455Reputation: 455Reputation: 455Reputation: 455Reputation: 455
IceWM - LQWiki
http://wiki.linuxquestions.org/wiki/IceWM
 
Old 02-20-2008, 11:24 AM   #3
walterbyrd
Member
 
Registered: Apr 2004
Posts: 565

Original Poster
Rep: Reputation: 30
A poster called "rbochan" on forums.debian.net answered my question, and got it exactly right:

----
I'm guessing you use startx instead of a GUI login manager?
Check the file /etc/X11/xinit/xserverrc. You should see a line like this:
exec /usr/bin/X11/X -dpi 100 -nolisten tcp
However, yours is most likely missing the -dpi 100 part. If that's the case, add it, and restart X
----
 
Old 02-20-2008, 01:24 PM   #4
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 694
Blog Entries: 1

Rep: Reputation: 32
install sux(su X wrapper) .operate as "sux -" the X session of root in Debian(careful).
go to appearance>fonts>details in System menu.
set dpi as 96 .enable hinting to ur like.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Emacs - changing default font size and font type? neilcpp Linux - Software 16 05-20-2013 11:29 AM
Problems in font size after upgrade to Xorg on Debian bagualdocavera Linux - General 2 10-22-2006 04:49 PM
convert XFREE86-4 to xorg.conf? hesher Linux - Software 1 01-20-2005 05:49 PM
how to set mozilla default font size mfeat Linux - Software 2 05-28-2004 09:55 AM
Default Xfree86 font encoding produkc Linux - General 3 09-02-2002 02:53 AM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration