LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 11-16-2005, 04:48 PM   #1
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
Hibernate option in Debian for Laptop


Hi guys,

I have a Dell Inspiron 5160 Laptop with Debain Sarge Installed on it with kernel 2.6.13 from kernel.org (compiled as per my laptop requirement)

Everything looks fine except that there is no hibernate option just as we have in Windows. So everytime I have to boot the entire system whenever I want to work in linux after shutting down the machine. Where and how can I get the hibernate option?

Does any have any idea/experience in this matter?

Thanks
 
Old 11-17-2005, 04:20 AM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
On my laptop with debian 3.1 and kernel 2.6.12.3:

http://www.linuxquestions.org/questi...hreadid=375314

Then I use acpid package and put in /etc/acpi/default.sh the handling of the on/off button (if ev_type is button and event is power then call hibernate)

Feel free to ask anything, I've played a bit with this.
 
Old 11-17-2005, 03:27 PM   #3
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Thanks. I will try out and let you know if I have more questions. by reading the thread which you gave me, it seeps that I need to have a swap space so that I can use hibernate option.
 
Old 11-18-2005, 03:00 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Or you can use a file and your context is saved to a file.

At least , you need this:

In your kernel config : activate SUSPEND2_FIREWRITER . But it is said to be in testing phase so it might be dangerous!!
In /etc/hibernate/hibernate.conf : uncomment FIlewriterLocation and VerifyFilewriterResume2

I have not tested writing to a file.. I would advice before testing to swap.
In any case, for the first try, unmount all you can before suspending!!
 
Old 11-18-2005, 03:45 AM   #5
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
I recently added "hibernate" support to my laptop, so I studied this issue a bit. There couple of options: swusp and swusp2. It should be possible to use ACPI suspend (was it ACPI S4 mode?).

"Swusp" is bundled with recent linux kernels, at least in 2.6.13+, probably also in earlier ones. "Swusp2" requires you to patch the kernel first. I use basic swusp and it work like a charm. Only if I have mounted any NFS shares the laptop refuses to go to sleep. Otherwise it just works, even with files open from removable media. Network comes up like it should, at least with the "ifplugd" package.

It is possible that "swusp" is enabled in your kernel already; just download the "hibernate" package and follow instructions. If it works with "swusp" option then you don't have to roll your own kernel. Alternatively you could try the ACPI option in "hibernate".

Also, check out my website, there are some scripts and additional info:

http://users.utu.fi/sjsepp/linuxcompaqarmadam700.html
 
Old 11-18-2005, 07:07 AM   #6
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Good, I have to check for swsusp because suspend2 patches a lot of files. and I see in the changelog of the 2.6.14 that they are actively correcting the swsusp.

With swsusp, you still need the hibernate package?

If you download it, then you should have a /etc/hibernate/hibernate.conf file then, in which you can unmount shares before suspending?

This would help the person of this thread:

http://www.linuxquestions.org/questi...hreadid=383809


Your page is nice. I see you have problems with X.

Until last week I had no problems with X; just pushed the on/off button and the resume comes back on X.

Then I managed to install drm for my Intel 855GM (only for opengl screensaver.. and the challenge..) and now when I resume, opengl is not working properly. I can't unload the "drm" module because I think its taken by X. So I have not yet found a solution (I'm also having more important problems with my disks, I hope not due to suspend2)


edit:
xosd (last line of hibernate.conf ) is really nice, you should have a try!


Last edited by nx5000; 11-18-2005 at 07:09 AM.
 
Old 11-19-2005, 03:35 AM   #7
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
I believe you don't really _need_ hibernate package, but it makes life much easier. I use it, anyways.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enable hibernate or sleep in laptop running Slack9.1 chud67 Slackware 2 08-11-2006 05:16 AM
Getting my laptop to Hibernate or Sleep Scott7 Debian 2 10-15-2005 05:33 AM
Hibernate Laptop lennysokol Linux - Laptop and Netbook 4 05-02-2005 08:23 PM
sleep / suspend / hibernate on Toshiba laptop (satellite 2410) cpbl Linux - Laptop and Netbook 0 01-16-2005 12:55 PM
laptop battery and hibernate paulr1984 Linux - Hardware 7 11-15-2004 05:32 AM


All times are GMT -5. The time now is 11:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration