LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-20-2009, 03:40 PM   #1
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 532

Rep: Reputation: 30
help with apt-get: dependency error (Depends: but is not going to be installed)


Hello folks,

I have an ancient computer on which has been happily running Debian 3.0 (Woody). Yes, I know it is extremely old, but it works great on my old hardware, does what I need it to and I am of the mindset "if it ain't broke..."

The main purpose of this computer is to serve a simple Intranet site for our company. It uses PHP, apache and mysql.

So yesterday I had the bright idea to install phpmyadmin so I could backup my database from my desk (remotely). Sadly, my normally happy computer has been fighting me on this one.

I've updated my sources.list to point to Debian archives, and verified that the computer can read them.

So here's the problem.

Code:
INTRANET:/etc/apt# apt-get install phpmyadmin
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
  phpmyadmin: Depends: ucf (>= 0.8) but it is not going to be installed
  smbfs: Depends: samba-common (= 3.0.14a-3) but 2.2.3a-14.1 is to be installed
         Depends: libc6 (>= 2.3.2.ds1-21) but 2.2.5-11.1 is to be installed
         Depends: libcomerr2 (>= 1.33-3)
         Depends: libkrb53 (>= 1.3.2) but it is not going to be installed
         Depends: libldap2 (>= 2.1.17-1) but 2.0.23-6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
What do I do to fix this?
 
Old 08-20-2009, 03:51 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Do you have a mixed sources.list? It appears that you're trying to install one package from a newer repository but that it doesn't have access to a repository with the newer dependencies.

Note, that installing something from a modern repository is likely to dump you straight into dependency hell since Woody is so old...
 
Old 08-20-2009, 04:33 PM   #3
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux
Posts: 1,054

Rep: Reputation: 95
The Woody repository does exist in the archives. So, add the following to your sources.list:
Code:
deb http://archive.debian.org/debian woody main contrib nonfree
I strongly suggest eliminating repositories of different versions from your sources.list -- as others have already said, it's a recipe for a broken system (sometimes with a preferences file, you can manage some mixing, but, usually it's best just to avoid mixing versions).

The archives does have the phpmyadmin package, so it may just exist in Woody (or it may not, given that the archives is also for Sarge and others). Try it out and see.
 
Old 08-20-2009, 05:36 PM   #4
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 532

Original Poster
Rep: Reputation: 30
Yes, it did exist for Woody, as far as my googling can tell. However, I do not know how to tell if it exists in the repositories I'm using.

Here is my sources.list; I modified it today as the old one was the original from when I installed the distro:
Code:
 deb http://archive.debian.org/debian/ woody main contrib non-free
deb-src http://archive.debian.org/debian/ woody main contrib non-free

deb http://security.debian.org/ oldstable/updates main contrib non-free
This sources.list appears to be working (when I did apt-get update, it was happy).

Should I add anything else?
 
Old 08-20-2009, 05:54 PM   #5
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
I wouldn't use oldstable on the security.debian.org line. oldstable is now referencing Etch (4.0) so that may cause you some grief. In fact, I'm pretty sure that you don't even need the security line since no further security updates are done to anything before Etch.
 
Old 08-20-2009, 06:59 PM   #6
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,644

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
'oldstable' is Etch, not Woody. try removing that line, apt-get updating, and then try again.
 
Old 08-21-2009, 08:41 AM   #7
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 532

Original Poster
Rep: Reputation: 30
Okay, I removed the last line and did apt-get update.

I'm getting a same, but slightly different error this time.

Here is my result.
Code:
INTRANET:/etc/apt# apt-get update
Hit http://archive.debian.org woody/main Packages
Hit http://archive.debian.org woody/main Release
Hit http://archive.debian.org woody/contrib Packages
Hit http://archive.debian.org woody/contrib Release
Hit http://archive.debian.org woody/non-free Packages
Hit http://archive.debian.org woody/non-free Release
Hit http://archive.debian.org woody/main Sources
Hit http://archive.debian.org woody/main Release
Hit http://archive.debian.org woody/contrib Sources
Hit http://archive.debian.org woody/contrib Release
Hit http://archive.debian.org woody/non-free Sources
Hit http://archive.debian.org woody/non-free Release
Reading Package Lists... Done
Building Dependency Tree... Done
INTRANET:/etc/apt# apt-get install phpmyadmin
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
  phpmyadmin: Depends: wwwconfig-common (>= 0.0.7) but it is not going to be installed
  smbfs: Depends: samba-common (= 3.0.14a-3) but 2.2.3a-14.1 is to be installed
         Depends: libc6 (>= 2.3.2.ds1-21) but 2.2.5-11.1 is to be installed
         Depends: libcomerr2 (>= 1.33-3)
         Depends: libkrb53 (>= 1.3.2) but it is not going to be installed
         Depends: libldap2 (>= 2.1.17-1) but 2.0.23-6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Should I try and install the dependencies (smbfs, wwwconfig-common) on their own and see what happens? I don't want to break anything...

On a related note, how can i tell if I already have one of those installed and what version? I typed dpkg -s smbfs and it was listed, but I don't know if that means it is installed or what.

Last edited by Avatar; 08-21-2009 at 08:48 AM.
 
Old 08-21-2009, 10:01 AM   #8
Avatar
Member
 
Registered: May 2001
Location: Canada
Distribution: old ones
Posts: 532

Original Poster
Rep: Reputation: 30
Never mind! I fixed it.

The problem was with SMBFS.

I did "dpkg -s smbfs" and it showed version 3.0.14a-3 was "installed ok unpacked" so, partially on my system
but the versions for its dependencies were the versions listed in the error (2.2.3a-14.1).

doing "apt-cache show smbfs" showed version 2.2.3a-15 was in the repository (I think that's how it works?)

So how I fixed it:

dpkg -r smbfs (to remove wrong version of smbfs)
apt-get install smbfs (to install correct version)
apt-get install phpmyadmin (now worked!)

Man, that felt like deciphering Egyptian hieroglyphs! But anyway it worked now, so thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
See original version of an apt-installed file after fixing an error in it pwabrahams Linux - Software 1 09-07-2008 09:27 AM
apt-get upgrade error (stops at kernel due to "dependency issues") n0dl Debian 2 02-16-2007 06:20 PM
Apt Dependency Deadlock Quantumstate Debian 7 04-23-2006 09:33 AM
Can't install via adept/apt-get, weird dependency error... Letherian Linux - Software 0 02-26-2006 04:12 PM
Dependency error in apt-get. How to solve? kushalkoolwal Debian 2 11-28-2005 12:36 PM


All times are GMT -5. The time now is 11:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration