LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Help! I can't record line-in/mic on ALSA cs46xx! (http://www.linuxquestions.org/questions/debian-26/help-i-cant-record-line-in-mic-on-alsa-cs46xx-438831/)

akp913 04-25-2006 08:14 PM

Help! I can't record line-in/mic on ALSA cs46xx!
 
Thanks for reading:

I use the ALSA sound driver CS46xx. This is on a ThinkPad T20 laptop running kanotix. I can play sound with no problem, so I figured my sound card was working okay. I plugged a device playing sound in line-in and it started playing on the speakers. So far everything was working great. I opened audacity and tried to record line-in and it didn't work. I messed around with every setting and still nothing. For about 4 hours I messed with KMix and ALSAMixer. I tried using other apps to record. I've used KRecord and Krec. I got out my mic and tried that and nothing wanted to record. Any ideals for me to try?

Thanks! :)

kencaz 04-25-2006 08:30 PM

I use the SoX record utility for recording my line-inputs. Something like this:


rec -c 2 -r 44100 -s w my_file.wav

do a search on "SOund eXchange" (SoX) You wont be disappointed.

KC

akp913 04-25-2006 09:21 PM

I tried rec but it doesn't work with the default settings. Is their a seperate device for the line input or the mic?

Thanks! :) SoX will be nice once I get the audio working. :D

kencaz 04-25-2006 10:13 PM

It will rec the current active input. Make sure your Line-in is not muted in your mixer...

KC

akp913 04-26-2006 05:22 PM

If I hear line-in on the speakers, it can't really be muted can it. Anyway I'll try using more SoX utilities.

kencaz 04-27-2006 10:21 PM

Quote:

Originally Posted by akp913
If I hear line-in on the speakers, it can't really be muted can it. Anyway I'll try using more SoX utilities.

Yes you can mute the line input.

Use Kmix's input tab... Clicking the green button will mute...

KC

jon_flanders 05-16-2006 10:01 PM

Quote:

Originally Posted by akp913
Thanks for reading:

I use the ALSA sound driver CS46xx. This is on a ThinkPad T20 laptop running kanotix. I can play sound with no problem, so I figured my sound card was working okay. I plugged a device playing sound in line-in and it started playing on the speakers. So far everything was working great. I opened audacity and tried to record line-in and it didn't work. I messed around with every setting and still nothing. For about 4 hours I messed with KMix and ALSAMixer. I tried using other apps to record. I've used KRecord and Krec. I got out my mic and tried that and nothing wanted to record. Any ideals for me to try?

Thanks! :)


I'm having the same problem. The sound from a tape recorder plays through line in no problem, but Audacity won't pick it up. It won't pick up the cdrom playing a sound album either. Possibly because in preferences the input devices are specified as dev/dsp?

Let me know if you find a solution.

[AudioIO]
PlaybackDevice=/dev/dsp
RecordingDevice=/dev/dsp
RecordChannels=1
Duplex=0
SWPlaythrough=0

ax11 06-17-2006 11:58 PM

1. Fire up alsamixer, change to the capture view and set capture active for ADC and DAC as well as for "capture" and line-in/mike.
2. Adjust input level
3. Record

rickh 06-18-2006 12:08 AM

Quote:

2. Adjust input level
That's in Audacity, itself. Also in Alsa Mixer, click on the little microphone by the Line-in volume control.

It does work. Keep messing with it. If you can hear the sound through your speakers, you can record it.

jon_flanders 06-18-2006 05:13 AM

Quote:

Originally Posted by ax11
1. Fire up alsamixer, change to the capture view and set capture active for ADC and DAC as well as for "capture" and line-in/mike.
2. Adjust input level
3. Record

How do you set these? With what keys? I tried enter, up, down arrow, tab, etc.

ax11 06-19-2006 06:39 PM

O.K. I could have been a little more specific: Alsamixer - I literally meant "alsamixer" - a simple but effective console mixer, not alsamixergui or gnome-alsamixer. You'll probably find those two first when working with X11, but they are not too useful in this case. Gnome-Alsamixer works, if you know exactly what you want to do, but the purist alsamixer is the best choice to solve problems like this.
Hit TAB to switch between capture and playback views and the space bar to toggle capture. I also found out that you'll need capture mode for DAC and ADC only if recording digitally via AC97 loopback.
To capture line-in only ADC (Analog-Digital Converter) needs to be active.

rivalarrival 09-11-2006 09:46 PM

I'm having the same problem as 1 and 7, the only difference is I have a T22, not a T20: It's the same audio system, though. I'm running Fedora Core 5.

Alsamixer-gui locks up as soon as I touch any of the "mic" controls... in alsamixer, I can adjust the "capture" gain on capture, adc, and dac, but not mic. (I can adjust the mic gain in "playback" though)

Audio doesn't work on Skype, (not suprising from what I've read about the linux version) audacity, krec... It DOES play through the speakers at times, but nothing will record.

Help??!? I'm at my wits end!

hendrikBln 09-11-2006 11:02 PM

Hey guys,

I've just had the very same problem here. Could hear my own voice on the headphone but nothing was recorded. Sh..

After changing every setting which I could think of, here's the solution, at least for my soundcard (Dell D600 build-in. called SigmaTel, I think):

- of course, select mic-input to be activated. use the slider to set the input level to something reasonable

- with "PCM Out Path & Mute" you _must_ select the 'post 3D', otherwise you will only hear white noise

- Let "Mono Output Select" the value 'Mix' and NOT 'Mic' (whatever this is). Without setting this, my voice sounded really slow. It's probably that the sample rate will be doubled when recording stereo (i.e. double the samples in the same time). My laptop (or headset?) doesn't seem to support stereo recording :(

- I switched various other options, but I don't think that those have / had any effect. Let me know if this helps (or doesnt ;).


Cheers,
Hendrik

rivalarrival 09-11-2006 11:07 PM

Figured it out
 
Fixed it: Had to install new alsa-driver from atrpms.

(I'd explain how to do that, but apparantly, I can't enter URL's right now...)

sleutelaar 05-18-2007 05:30 PM

audio on an AMD64 debian etch box motherboard A8V de luxe
 
Audio would not function when I used Fedora 4 for my AMD64. So I changed to Debian Etch, and I am completely happy with Debian now, but unfortunately, the motherboard audio would still not function fully. So, I disabled the motherboard audio and put in an PCI-audio card (Ensoniq). Now I had sound from the speakers in the monitor, but still no signal in Audacity. After long searching and Googling, I decided to upgrade to Lenny, the testing of Debian. Immediately everything functioned, recording and so on. The problem is something with older drivers in Etch, I think. Problem solved! :)


All times are GMT -5. The time now is 01:02 AM.