LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Having problems with installing xfce4 from apt-get (http://www.linuxquestions.org/questions/debian-26/having-problems-with-installing-xfce4-from-apt-get-178141/)

meastp 05-05-2004 08:46 AM

Having problems with installing xfce4 with apt-get
 
Hi!


Code:

apt-get install xfce4
This gives me errors:

Code:

Sorry, but the following packages have unmet dependencies:   
  xfce4: Depends: xfwm4 but it is not going to be installed
            Depends: xfwm4-themes but it is not going to be installed
            Depends: xfce4-mcs-plugins but it is not going to be installed
            Depends: xfce4-panels but it is not going to be installed
            Depends: xfce4-themes but it is not going to be installed
            Depends: xfdesktop4 but it is not going to be installed
            Depends: xffm4s but it is not going to be installed
            Depends: xfce4 but it is not going to be installed
            Depends: gtk2-engines-xfce but it is not going to be installed
            Depends: xfce4-session but it is not going to be installed
E: Sorry, broken packages

----------
Mats Taraldsvik

macondo 05-05-2004 10:28 AM

Did you check if this package is available in the version of Debian you are using? There is no information in the post as to what version you're using.

Did you perform an apt-get update/upgrade before attempting to install?

IIRC, XFCE4 is only available in Sarge (Testing) and Sid (Unstable)

You can look in:
debian.org>Packages>your version>X Window System Software

OR

in the terminal:

apt-cache search <name of package>
apt-cache show <name of package>

IOW, if you are using Woody, you are not going to get it, unless there is a backport for it. Check apt-get.org or backports.org .

meastp 05-05-2004 10:38 AM

Quote:

Originally posted by macondo
Did you check if this package is available in the version of Debian you are using? There is no information in the post as to what version you're using.

Did you perform an apt-get update/upgrade before attempting to install?

IIRC, XFCE4 is only available in Sarge (Testing) and Sid (Unstable)

You can look in:
debian.org>Packages>your version>X Window System Software

OR

in the terminal:

apt-cache search <name of package>
apt-cache show <name of package>

IOW, if you are using Woody, you are not going to get it, unless there is a backport for it. Check apt-get.org or backports.org .

Oh, I'm sorry, I'm on unstable. Yes, I did update my system.

apt-cache search xfce4 gave me a lot of hits. Among them was the xfce4 package.

I'm really stuck...

---
Mats Taraldsvik

funkydan2 05-06-2004 07:07 PM

How about you run something like:
apt-get install xfce4 xfwm4 xfdesktop4
or maybe
apt-get install xfce4*
and keep adding to that list until it installs?

Sometimes all the dependencies aren't installed automagically, and you need to specify some yourself.

dan

macondo 05-07-2004 01:28 PM

If you are in Sid do a:

apt-get update
apt-get -f dist-upgrade

see if that helps you. :)


All times are GMT -5. The time now is 02:17 PM.