LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 07-27-2005, 11:27 AM   #1
rock_wrench05
LQ Newbie
 
Registered: Jul 2005
Location: Originally from Tennessee
Distribution: Debian 3.1
Posts: 15

Rep: Reputation: 0
Have to run alsaconf after every boot


Just installed Debian 3.1 on a Dell Inspiron 4150 laptop. Everything went well despite all the horror stores I had read while lurking the forums. Only problem I am having is that I have to run the "alsaconf" command in a terminal everytime I reboot for sound to work.

I think that I have read somewhere around here about there being a conflict with my modem sound. Not really sure though, I browse thru here so much I may be mistaking, and I just cant seem to find that post again.

Any help? Thanks in advance.

Rock_Wrench Out!
 
Old 07-27-2005, 12:50 PM   #2
harken
Member
 
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
After running 'alsaconf', also run as root 'alsactl store'. That should save your settings.
 
Old 07-29-2005, 01:37 PM   #3
rock_wrench05
LQ Newbie
 
Registered: Jul 2005
Location: Originally from Tennessee
Distribution: Debian 3.1
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks for the reply - but that didnt work. Listed is my terminal after I run alsaconf - lspci - lsmod. Anyone else have any suggestions?

Code:
debianwrench:/home/chad# alsaconf
Terminating processes: 1688 1773.
Unloading ALSA sound driver modules: snd-intel8x0 snd-intel8x0m snd-pcm-oss snd-mixer-oss snd-ac97-codec snd-pcm snd-timer snd-page-alloc.
Building card database...


Running update-modules...
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-pdaudiocf.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vx-cs.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vxp440.o
depmod: *** Unresolved symbols in /lib/modules/2.4.27-2-386/updates/alsa/snd-vxpocket.o
Loading driver...
Setting default volumes...


===============================================================================

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!


debianwrench:/home/chad# lspci
0000:00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 04)
0000:00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 04)
0000:00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 42)
0000:00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio Controller (rev 02)
0000:00:1f.6 Modem: Intel Corp. 82801CA/CAM AC'97 Modem Controller (rev 02)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
0000:02:00.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
0000:02:01.0 CardBus bridge: Texas Instruments PCI1420
0000:02:01.1 CardBus bridge: Texas Instruments PCI1420
debianwrench:/home/chad# lsmod
Module                  Size  Used by    Not tainted
snd-pcm-oss            34048   0  (autoclean)
snd-mixer-oss          11000   1  (autoclean) [snd-pcm-oss]
snd-seq-oss            21760   0  (autoclean) (unused)
snd-seq-midi            3008   0  (autoclean) (unused)
snd-seq-midi-event      2976   0  (autoclean) [snd-seq-oss snd-seq-midi]
snd-rawmidi            11552   0  (autoclean) [snd-seq-midi]
snd-seq                32048   2  (autoclean) [snd-seq-oss snd-seq-midi snd-seq-midi-event]
snd-seq-device          3588   0  (autoclean) [snd-seq-oss snd-seq-midi snd-rawmidi snd-seq]
snd-intel8x0           16704   1  (autoclean)
snd-ac97-codec         48280   0  (autoclean) [snd-intel8x0]
snd-pcm                50216   0  (autoclean) [snd-pcm-oss snd-intel8x0 snd-ac97-codec]
snd-timer              12548   0  (autoclean) [snd-seq snd-pcm]
snd                    28260   0  (autoclean) [snd-pcm-oss snd-mixer-oss snd-seq-oss snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-intel8x0 snd-ac97-codec snd-pcm snd-timer]
snd-page-alloc          4296   0  (autoclean) [snd-mixer-oss snd-seq-oss snd-seq-midi snd-rawmidi snd-seq snd-seq-device snd-intel8x0 snd-pcm snd-timer snd]
soundcore               3268   6  (autoclean) [snd]
input                   3040   0  (autoclean)
radeon                 94176   1
apm                     8428   1  (autoclean)
ip_conntrack_ftp        3440   0  (unused)
ip_conntrack_irc        2640   0  (unused)
ipt_LOG                 3032   5  (autoclean)
ipt_limit                824   5  (autoclean)
ipt_state                504  15  (autoclean)
iptable_filter          1644   1  (autoclean)
ip_conntrack           17000   2  [ip_conntrack_ftp ip_conntrack_irc ipt_state]
ip_tables              10400   4  [ipt_LOG ipt_limit ipt_state iptable_filter]
af_packet              11048   1  (autoclean)
usb-uhci               19504   0  (unused)
usbcore                52268   1  [usb-uhci]
ide-scsi                8272   0
scsi_mod               86052   1  [ide-scsi]
3c59x                  23312   1
agpgart                39108   3
ide-cd                 27072   0
cdrom                  26212   0  [ide-cd]
rtc                     5768   0  (autoclean)
ext3                   65388   5  (autoclean)
jbd                    34628   5  (autoclean) [ext3]
ide-detect               288   0  (autoclean) (unused)
piix                    7784   1  (autoclean)
ide-disk               12448   6  (autoclean)
ide-core               91832   6  (autoclean) [ide-scsi ide-cd ide-detect piix ide-disk]
unix                   12752 195  (autoclean)
debianwrench:/home/chad#
 
Old 07-29-2005, 02:38 PM   #4
ironwalker
Member
 
Registered: Feb 2003
Location: 1st hop-NYC/NewJersey shore,north....2nd hop-upstate....3rd hop-texas...4th hop-southdakota(sturgis)...5th hop-san diego.....6th hop-atlantic ocean! Final hop-resting in dreamland dreamwalking and meeting new people from past lives...gd' night.
Distribution: Siduction, the only way to do Debian Unstable
Posts: 506

Rep: Reputation: Disabled
You mentioned that you can get sound to work after alsaconf on every boot.
Ok,get your sound working.
Set up the mixer to your likeing.
Once all is fine use the
alsactl store
command to save everything and have it there for next boot.
If it doesn't work you may need to be root...I dont remember.
 
Old 07-29-2005, 02:44 PM   #5
rock_wrench05
LQ Newbie
 
Registered: Jul 2005
Location: Originally from Tennessee
Distribution: Debian 3.1
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks for the reply, but as you see that was the first suggestions and it didnt work. Anyone else?

Thanks in advance.
 
Old 07-30-2005, 02:46 AM   #6
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Rep: Reputation: 32
Are u sure after alsaconf sound not working?after alsaconf alsactl store reboot.try right click xmms->preferences/options/alsa/oss/esd .try changing these three options and try playing any song.if not did u compiled custom kernel and forgot any modules?
 
Old 07-30-2005, 10:37 AM   #7
rock_wrench05
LQ Newbie
 
Registered: Jul 2005
Location: Originally from Tennessee
Distribution: Debian 3.1
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Are u sure after alsaconf sound not working?after alsaconf alsactl store reboot.
Maybe I didnt ask the question properly. My sound works perfectly after I run alsaconf. But once I shutdown my machine and power it back up, I have to run alsaconf all over again. Running alsactl store after alsaconf does not save my settings, and again after I shutdown my machine and power it back up, I am going thru the same process to get my sound back up.

I loaded the default Kernel (2.4.27) from the Debian 3.1 Sarge Official DVD set, and have not recompliled my Kernel. I have googled this and searched this forumn but I have not found anyone with a similar problem. Anyone else have and suggestions?

Thanks in advance!
 
Old 08-04-2005, 01:15 PM   #8
netcrawl
Member
 
Registered: Jan 2004
Location: British Columbia
Distribution: Slackware64 14.1, m0n0wall
Posts: 143

Rep: Reputation: 20
Just wondering if you worked this out? DId a search here and found this thread.

I'm having the same problem, using Debian-testing, alsa and kernel 2.6.12.3. No sound on reboot, rerun alsaconf, alsactl store, and sound works, reboot, no sound, run alsaconf, alsactl store, sound works again... etc.
 
Old 08-04-2005, 02:17 PM   #9
rock_wrench05
LQ Newbie
 
Registered: Jul 2005
Location: Originally from Tennessee
Distribution: Debian 3.1
Posts: 15

Original Poster
Rep: Reputation: 0
Negative. Nothing here has worked out. I have googled - searched - and pulled my hair out (next step is the Library of Congress) . But nothing has helped. Was just trying again actually when I saw your post. Maybe someone else will reply.

Anyone else have any suggestions. At least I am not the only one with a problem.
 
Old 08-04-2005, 02:24 PM   #10
netcrawl
Member
 
Registered: Jan 2004
Location: British Columbia
Distribution: Slackware64 14.1, m0n0wall
Posts: 143

Rep: Reputation: 20
I just got it worked out...
I had a couple of OSS modules that conflicted with alsa, apparently. Removed them, rebooted, alsa works perfectly.
I compared the output of lsmod before and after running alsaconf, found the two modules in question and removed them in xconfig.

Hope that's of some help to you,
netcrawl.
 
Old 08-04-2005, 02:39 PM   #11
rock_wrench05
LQ Newbie
 
Registered: Jul 2005
Location: Originally from Tennessee
Distribution: Debian 3.1
Posts: 15

Original Poster
Rep: Reputation: 0
Yeah I am seeing some oss modules on my lsmod output. Guess I need to get rid of those. What is the path to the xconfig files that you edited?
 
Old 08-04-2005, 03:04 PM   #12
netcrawl
Member
 
Registered: Jan 2004
Location: British Columbia
Distribution: Slackware64 14.1, m0n0wall
Posts: 143

Rep: Reputation: 20
Xconfig is just an easy GUI for configuring a kernel... you can use 'make oldconfig' or 'make config' or whatever... It's pretty straightforward if you are familiar with compiling kernels. I compile kernels in /usr/src/ .

This is how I accomplish this, your mileage may vary:
As root, cd to /usr/src/linux, (a sym-link to the kernel, in my case /usr/src/linux-2.6.12.3), enter 'make xconfig', find the modules in question and remove them, exit and save xconfig, enter 'make modules', enter 'make modules_install' and reboot.

Hope that's not more info than you need, good luck.
netcrawl
 
Old 08-09-2005, 10:33 AM   #13
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 20; Arch; Kubuntu; Debian
Posts: 711

Rep: Reputation: 31
I'll have to try this. It seems semi-related to a problem I'm having an posted in another thread. Sound only works for me in KDE, not any other Window Manager. It's pretty bizzare. I'll reply here if I get it to work.
 
Old 08-15-2005, 03:27 PM   #14
lefty.crupps
Member
 
Registered: Apr 2005
Location: Minneap USA
Distribution: Debian, Mepis, Sidux
Posts: 470

Rep: Reputation: 32
I, too, have this problem (MEPIS 3.3.1). I think its due to my having two sound cards: an onboard and a PCI (which is the one I want to use).

I will try "alsactl store," but I am wondering if there is something else here? OSS causes some people problems, huh? (Will we ever be moving away from that?)

I hope this works leter; let you know.
 
Old 09-08-2005, 10:29 AM   #15
elschemm
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
I just had the same problem as documented here. For me, though, it was not a case of OSS modules loaded.
In my case, the snd_sbawe driver was not loading. So, when alsa ran as part of init, it would immediately fail, as /proc/asound did not exist. The solution was easy:

add snd_sbawe to /etc/modules. Hopefully this tidbit will be useful to someone else.


Schemm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
must re-run alsaconf to get sound fatman Debian 8 08-26-2006 06:37 PM
ALSA boot problem - have to run alsaconf every time(ASUS A7V266-MX) aneeshm Linux - Software 2 07-11-2004 08:02 AM
Need to run alsaconf everytime i boot up! RaVilj Red Hat 3 06-13-2004 06:23 PM
Sound comes each time only when I run alsaconf. rsamurti Slackware - Installation 3 05-06-2004 07:54 AM
Configure alsaconf to run on boot... vi0lat0r Linux - Hardware 3 03-31-2004 06:35 PM


All times are GMT -5. The time now is 07:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration