LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Hangcheck timer elapsed ... GPU hung (http://www.linuxquestions.org/questions/debian-26/hangcheck-timer-elapsed-gpu-hung-897766/)

kidsin 08-17-2011 01:59 AM

Hangcheck timer elapsed ... GPU hung
 
My Debian squeeze is getting hung unpredictably.

Error:
Code:

[drm i915_hangcheck_elapsed] *Error* Hangcheck timer elapsed ... GPU hung
render error detected, ECR: 0x00000000

I was going to try this solution but i dont find any xorg.conf in my /etc/X11/.

cynwulf 08-17-2011 02:31 AM

You can try that - simply create the xorg.conf with those contents, but leave out some of the extra options, i.e.

Code:

Section "Device"
Identifier "Card0"
Driver "intel"
Option "Shadow" "true"
EndSection

I think enabling the shadowfb was a workaround of some kind - not sure if it's still needed now possibly still is in squeeze.

Original thread: http://forums.debian.net/viewtopic.p...=63662#p375172

But first post the output of

Code:

lspci
uname -r
grep EE /var/log/Xorg.0.log
grep WW /var/log/Xorg.0.log

I assume that you're running squeeze?

kidsin 08-17-2011 03:23 AM

I am confused the link you wrote, asks to put shadow to false, but you want me to put it as true?

Currently, i hve create a xorg.conf as

Section "Device"
Identifier "Card0"
Driver "intel"
Option "Shadow" "false"
Option "DRI" "false"
BoardName "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)"
BusID "PCI:0:2:0"
EndSection

Here is output yu asked: https://gist.github.com/6bdbb6d6f7873d3c4f29

cynwulf 08-17-2011 04:08 AM

You didn't read the next page of the thread. You need to enable it to get any kind of stability with xf86-video-intel and KMS on the 8xx chips. Clear that lot out of your xorg.conf and use the device section in my previous post instead of the one in the link.

kidsin 08-27-2011 11:58 AM

I have been trying all sorts of things mentioned on the thread link you gave, and also the setting that you wrote.
But, nothing seems to resolve the GPU hung bug. :(

cynwulf 08-27-2011 12:55 PM

Ok add the backports repo

http://backports-master.debian.org/Instructions/

Install the latest kernel e.g. linux-image-2.6.39-bpo.2-amd64 or linux-image-2.6.39-bpo.2-686-pae (note architecture)

Reboot into the kernel - see if the problem persists.

kidsin 08-29-2011 02:50 AM

I check my uname -a, it said my kernel was 686, so installed using that name

Code:

# apt-get -t squeeze-backports install linux-image-2.6-686
Reading package lists... Done
Building dependency tree     
Reading state information... Done
The following extra packages will be installed:
  initramfs-tools linux-base linux-image-2.6.39-bpo.2-686-pae linux-image-686-pae
Suggested packages:
  linux-doc-2.6.39
Recommended packages:
  firmware-linux-free
The following NEW packages will be installed:
  linux-image-2.6.39-bpo.2-686-pae linux-image-686-pae
The following packages will be upgraded:
  initramfs-tools linux-base linux-image-2.6-686
3 upgraded, 2 newly installed, 0 to remove and 75 not upgraded.
Need to get 29.3 MB of archives.
After this operation, 83.7 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y

i hope this works.


All times are GMT -5. The time now is 07:24 AM.