LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2013, 04:58 PM   #16
davetesc
LQ Newbie
 
Registered: May 2012
Location: UK
Distribution: Debian testing KDE, Mint 14 XFCE, Ubuntu Studio
Posts: 19
Blog Entries: 4

Rep: Reputation: Disabled

Adding to previous post, do need password for gksu, it must have been in wallet already when testing.
Tried Defaults env_keep=DISPLAY didn't work.

Tried sudo xauth merge username/.Xauthority got unable to open file ......

Using deb testing KDE recently updated.

Any tips ????

Thanks Davetesc
 
Old 01-17-2014, 01:19 PM   #17
GroZouRs
LQ Newbie
 
Registered: Jan 2014
Distribution: Ubuntu,Archlinux,Gentoo,OpenBSD.
Posts: 1

Rep: Reputation: Disabled
On my system, i had the same issue.


Looking at my X process :
$sudo ps -eaf | grep [/]X
root 13755 1399 3 Jan03 tty7 13:03:18 /usr/bin/X :1 -auth /var/run/lightdm/root/:1 -nolisten tcp vt7 -novtswitch

but my $DISPLAY value was this :
$echo $DISPLAY
:0

i just corrected it :
$export DISPLAY=":1"

and then everything was fine.

Are you using hibernation on a laptop ?
 
Old 01-26-2014, 06:36 AM   #18
Phiebie
Member
 
Registered: Oct 2004
Location: Austria
Distribution: Debian testing
Posts: 102

Rep: Reputation: 17
Quote:
Originally Posted by davetesc View Post
Adding to previous post, do need password for gksu, it must have been in wallet already when testing.
Tried Defaults env_keep=DISPLAY didn't work.

Tried sudo xauth merge username/.Xauthority got unable to open file ......

Using deb testing KDE recently updated.
Try this:
Quote:
This time I had more luck when investigating alternatives... and I
think I have the solution using su, no need of wrappers, just PAM.
Probably also the reason sux is dead upstream and sux was pretty much
a Debian issue.

To /etc/pam.d/su add:
---8<---
# Forward xauth keys between users if invoker is root or UID 1000 or higher
session optional pam_xauth.so systemuser=999
--->8---
 
Old 01-27-2014, 01:05 PM   #19
davetesc
LQ Newbie
 
Registered: May 2012
Location: UK
Distribution: Debian testing KDE, Mint 14 XFCE, Ubuntu Studio
Posts: 19
Blog Entries: 4

Rep: Reputation: Disabled
Thanks for posts, forgot this thread way still open, either solved it or problem went away, sorry will now mark solved if I can. Davetesc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gtk-WARNING **: cannot open display: ncsuapex Slackware 7 01-04-2013 05:54 PM
gtk warning cannot open display bosewicht Linux - Newbie 2 03-10-2010 07:53 PM
export display and Gtk-WARNING **: cannot open display: zimma Linux - Server 0 04-24-2009 02:51 AM
Gtk-WARNING **: cannot open display mmisoo Fedora 4 07-24-2006 07:33 PM
Gtk-WARNING **: cannot open display ocset Linux - Software 2 10-18-2004 03:18 PM


All times are GMT -5. The time now is 10:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration