LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 02-10-2005, 02:07 PM   #1
Mathiasdm
LQ Newbie
 
Registered: Aug 2004
Distribution: Ubuntu Gutsy Gibbon
Posts: 25

Rep: Reputation: 15
Going back to the command line?


I just installed Debian on a virtual partition (VMWare).
I can't seem to get into CLI. Whenever I change the runlevel in /etc/inittab and reboot, the runlevel goes back to 4, and I'm in X again.
Ctrl+Alt+Backspace doesn't work either.

I can't get a resolution higher than 800*600 until I install VMware-tools, and I need to be in CLI to do that (X mustn't be running).
 
Old 02-10-2005, 02:40 PM   #2
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 46
CTRL + ALT + F1
 
Old 02-10-2005, 03:30 PM   #3
Mathiasdm
LQ Newbie
 
Registered: Aug 2004
Distribution: Ubuntu Gutsy Gibbon
Posts: 25

Original Poster
Rep: Reputation: 15
Doesn't work. Ctrl+Alt+F1 doesn't do anything.
 
Old 02-10-2005, 03:36 PM   #4
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,176

Rep: Reputation: 54
You can try opening a terminal and typing "init 1" and see if that works. I you use kdm to login, you can select a console login option so that X will be killed and you can just get a text prompt.
 
Old 02-10-2005, 03:38 PM   #5
sigsegv
Senior Member
 
Registered: Nov 2004
Location: Third rock from the Sun
Distribution: NetBSD-2, FreeBSD-5.4, OpenBSD-3.[67], RHEL[34], OSX 10.4.1
Posts: 1,197

Rep: Reputation: 46
Interesting ... Does the keyboard work at all? Are you able to log in?

If nothing else, look in the initab and see what runlevel you're coming up to and then remove the symlink for your (g|k|x)dm from /etc/rc.d/rcN.d/ where N is the runlevel.

Edit: Hehe ... This post bears the mark of the beast

Last edited by sigsegv; 02-10-2005 at 03:39 PM.
 
Old 02-10-2005, 03:55 PM   #6
Mathiasdm
LQ Newbie
 
Registered: Aug 2004
Distribution: Ubuntu Gutsy Gibbon
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by m_yates
You can try opening a terminal and typing "init 1" and see if that works. I you use kdm to login, you can select a console login option so that X will be killed and you can just get a text prompt.
That worked. I managed to install VMWare tools.
However, X died on me ;-) I'll take a look at the configuration files later. I'm going on holiday tomorrow, so it might be a while before I figure it out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get back into command line interface bonniehandi Linux - Newbie 1 11-19-2005 01:07 AM
Command to output file content line by line aznluvsmc Programming 2 09-12-2004 08:45 PM
51 characters only in the 1st Line of command line eggCover Linux - General 2 07-29-2004 02:28 PM
Command line runs back on itself SharpyWarpy Linux - General 2 11-25-2003 07:56 PM
Serial line is looped back? Unknown_User Linux - Hardware 1 02-28-2003 09:31 PM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration