LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   gnome-settings-daemon prevents scim working on Emacs (http://www.linuxquestions.org/questions/debian-26/gnome-settings-daemon-prevents-scim-working-on-emacs-420914/)

realwhz 03-02-2006 08:10 AM

gnome-settings-daemon prevents scim working on Emacs
 
Hi,

I'm using emacs-snapshot-gtk, and the locale of mine is en_US.UTF-8.

By setting GTK_IM_MODULE=SCIM (I also tested XIM) and XMODIFIERS="@im=SCIM", scim works well on all gtk applications. But scim cannot be actived on emacs-snapshot-gtk no matter how I configure language environment in dot emacs file.

But, if I login in Failsafe xterm session of GDM, that is, the simplest X session with only xterm started. Then I started scim daemon and configured all environment variables needed, such as XMODIFIERS, scim can be used on emacs-snapshot-gtk, however. As soon as gnome-settings-daemon is started, scim cannot work on emacs-snapshot-gtk any more.

I also tested emacs-snapshot and emacs21, the same results are obtained. So it seems that gnome-settings-daemon prevent scim working on emacs, including emacs-snapshot and emacs21.

By the way, a very strange thing is, scim can work on emacs on my laptop, which runs also Debian Sid on it. I don't know why :(

Thank you.


All times are GMT -5. The time now is 04:43 PM.