LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-28-2004, 10:47 AM   #1
computergeek84
Member
 
Registered: Nov 2003
Location: /dev/null
Distribution: Gentoo, Ubuntu
Posts: 61

Rep: Reputation: 15
gnome-panel won't start after upgrade to GNOME 2.6


I run Debian/unstable on my desktop. Last night I upgraded the GNOME desktop environment (which I use all the time) from version 2.4 to 2.6 using synaptic, but when I restarted X and tried to login to gnome 2.6, the gnome-panel program (now version 2.6.2) gives the following error message:
Quote:
I've detected a panel already running, and will now exit.
I never had any problem with this using gnome 2.4. I either need help downgrading back to gnome 2.4 or help solving this problem with gnome 2.6.
Googling for this problem returned scant results, mostly other people having the same problem but I found no solutions/workarounds to fix this problem.
Any suggestions?
 
Old 06-29-2004, 04:46 AM   #2
sterrenkijker
Member
 
Registered: Mar 2004
Location: the Netherlands
Distribution: Debian Sarge
Posts: 302

Rep: Reputation: 30
I remember having that problem too when I upgraded to gnome 2.6, but it disappeared when I restarted (if I remember well, not sure). If you don't want to restart, maybe you can kill all gnome-programs maybe...

I had lots of trouble upgrading, the upgrade made my desktop quite useless. I solved it by adding experimental ( deb http://ftp.nl.debian.org/debian/ experimental main ) and unstable (I use testing) to my apt-sources and updating my gnome again, and it finally worked quite well. Now I can use most programs again, but some gnome-programs are still broken unfortunately. I'm afraid that's just the pain of living on the edge...

Succes,

Sterrenkijker
 
Old 06-29-2004, 02:36 PM   #3
comp12345
Member
 
Registered: Feb 2004
Posts: 467

Rep: Reputation: 30
Testing still has a mixture of gnome 2.4 and gnome 2.6 packages. In my mind, this make testing less stable than unstable. For instance gnome-media and gnome-utils are still at 2.4 in testing.
 
Old 06-29-2004, 10:40 PM   #4
computergeek84
Member
 
Registered: Nov 2003
Location: /dev/null
Distribution: Gentoo, Ubuntu
Posts: 61

Original Poster
Rep: Reputation: 15
I rather crudely solved the problem by restoring a backup image of my root partition I had made a week before, thus wiping out gnome 2.6 (and a week's worth of changes not stored somewhere in my home directory, which were minimal, fortunately). I am happily running gnome 2.4 again, and I may try to upgrade to gnome 2.6 when they release the next upgrade.
I'll try that experimental line in my sources.list when I get a chance to play with apt some more.

Thanks for the suggestions!
 
Old 08-12-2007, 03:13 AM   #5
huibui
LQ Newbie
 
Registered: May 2005
Location: Auroville, India
Distribution: Feisty, Cent OS 5
Posts: 5

Rep: Reputation: 0
I've detected a panel already running and will now exit.

Problem: Suddenly Gnome logins get the error message: "I've detected a panel already running, and will now exit". One can with a right click open a terminal and write 'killall gnome panel' then 'gnome-panel'.

What triggered this on my computer was that another user (in my case root) changed the desktop background (no joking!) and used a .png file. After either removing the file or use a .bmp the problem was solved.

Check that out.

gnome-panel-2.8.1-5.el4

Last edited by huibui; 08-13-2007 at 02:56 AM.
 
Old 08-12-2007, 01:37 PM   #6
reverse
Member
 
Registered: Apr 2007
Distribution: Gentoo
Posts: 337

Rep: Reputation: 30
I run GNOME + Debian Unstable too.. the version on *my* system is 2.18.3. Could you post your sources.list?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome panel keeps crashing when starting gnome-session elluva Linux - Software 3 01-24-2006 04:26 PM
upgrade to GNOME 2.12==default icons in panel edman007 Linux - Software 0 09-15-2005 07:36 PM
Gnome-panel, nautilus and gnome settings daemon Fail on Startup hitman_et Linux - General 0 04-01-2005 09:06 PM
gnome-panel crashes :: shortcuts from start menu vanish... hpnadig Mandriva 2 01-02-2004 12:20 PM
GNOME panel and Nautilus don't start! defa0009 Linux - General 0 06-27-2003 07:51 PM


All times are GMT -5. The time now is 08:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration