LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 09-09-2008, 07:38 PM   #1
posix_memalign
Member
 
Registered: Aug 2008
Posts: 81

Rep: Reputation: 15
GLIBC 2.4 in Debian 4.0


I need >= GLIBC 2.4 in Debian 4.0, this is needed in order to run e.g. OpenArena 0.8.
However, the latest version available in Debian Etch through apt is 2.3.6, how do I solve this issue?
 
Old 09-10-2008, 03:24 AM   #2
Valery Reznic
ELF Statifier author
 
Registered: Oct 2007
Posts: 670

Rep: Reputation: 134Reputation: 134
Quote:
Originally Posted by posix_memalign View Post
I need >= GLIBC 2.4 in Debian 4.0, this is needed in order to run e.g. OpenArena 0.8.
However, the latest version available in Debian Etch through apt is 2.3.6, how do I solve this issue?
You can install glibc >= 2.4 somewhere in the system let's say in directory
/OpenArena.
Then run OpenArena as
LD_LIBRARY_PATH=/OpenArene OpenArena.

Or you can on another box, which has needed glibc install OpenArena,
pack it using Ermine (http://magicErmine.com) or staifier (http://statifier.sf.net)
and then copy packed executable to your Debian box. Packed executable will have all needed libraries embedded, so virtually it has no dependencies.
 
Old 09-13-2008, 12:00 PM   #3
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 355

Rep: Reputation: 30
Can not find version 2.4 but

Package libstdc++2.10-glibc2.2
* etch (stable) (libs): The GNU stdc++ library


http://www.debian.org/distrib/packages#search_packages
 
Old 10-08-2008, 03:16 PM   #4
posix_memalign
Member
 
Registered: Aug 2008
Posts: 81

Original Poster
Rep: Reputation: 15
When I attempt to compile glibc 2.4 or glibc 2.7 I get the following errors:

Prior to the errors I have unpacked, created the directory "build" from which I execute the configure script with --prefix=/opt/glibc as argument.
Then I do "make 2> errors.log" and get the following errors in errors.log:

Code:
mawk: scripts/gen-sorted.awk: line 19: regular expression compile failed (bad class -- [], [^] or [)
/[^
mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
mawk: scripts/gen-sorted.awk: line 19: runaway regular expression /, "", subd ...
mawk: scripts/gen-sorted.awk: line 19: regular expression compile failed (bad class -- [], [^] or [)
/[^
mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
mawk: scripts/gen-sorted.awk: line 19: runaway regular expression /, "", subd ...
make[1]: *** No rule to make target `/home/foo/temp_install/glibc-2.4/build/Versions.all', needed by `/home/foo/temp_install/glibc-2.4/build/abi-versions.h'.  Stop.
make: *** [all] Error 2
 
Old 10-08-2008, 03:50 PM   #5
posix_memalign
Member
 
Registered: Aug 2008
Posts: 81

Original Poster
Rep: Reputation: 15
Never mind, I corrected the bad use of regex in the script.
 
Old 10-08-2008, 03:52 PM   #6
posix_memalign
Member
 
Registered: Aug 2008
Posts: 81

Original Poster
Rep: Reputation: 15
However, even with the environment variable LD_LIBRARY_PATH=/opt/glibc240 when I execute openarena I get:

Code:
x86-1$ ./openarena.i386 
./openarena.i386: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by ./openarena.i386)
x86-1$ echo $LD_LIBRARY_PATH
/opt/glibc240/
x86-1$
Any ideas?
 
Old 10-08-2008, 03:59 PM   #7
Total-MAdMaN
Member
 
Registered: May 2008
Distribution: Gentoo
Posts: 306

Rep: Reputation: 34
Did you run ldconfig after installing glibc? You might also want to add the directory to /etc/ld.so.conf

Last edited by Total-MAdMaN; 10-08-2008 at 04:00 PM.
 
Old 10-09-2008, 09:07 AM   #8
posix_memalign
Member
 
Registered: Aug 2008
Posts: 81

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Total-MAdMaN View Post
Did you run ldconfig after installing glibc? You might also want to add the directory to /etc/ld.so.conf
Yes, unfortunately I've tried that as well, it doesn't seem to do anything at all.
 
Old 10-15-2008, 12:27 PM   #9
posix_memalign
Member
 
Registered: Aug 2008
Posts: 81

Original Poster
Rep: Reputation: 15
What if I merely compile and install the glibc manually, and overwrite the old (Debian package-based) system wide glibc-install? Will that correct the issue, or will it cause hell with Debian's package manager/system?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY Debian Glibc configure. Soulseller Linux - Software 0 02-28-2008 08:05 AM
Multiple glibc versions on Debian Sarge Magik Debian 4 06-21-2005 05:49 PM
Looking for glibc 2.3 debian packet;( cracken Debian 1 12-28-2004 04:15 PM
How to install glibc in Debian kawdk Debian 1 05-04-2004 01:49 AM
make glibc 2.3.2 debian error storma Linux - Software 0 01-01-2004 02:29 AM


All times are GMT -5. The time now is 12:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration