LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   getting sound modules to work on a Thinkpad T20 with a custom 2.6.10 kernel (http://www.linuxquestions.org/questions/debian-26/getting-sound-modules-to-work-on-a-thinkpad-t20-with-a-custom-2-6-10-kernel-304837/)

donkeygod 03-22-2005 05:33 PM

getting sound modules to work on a Thinkpad T20 with a custom 2.6.10 kernel
 
Behold my |\|00|3n355. I configured and installed a 2.6.10 kernel and everything works fine. Except for the sound that is. The kernel is configured to load the alsa stuff as modules (I left oss out). At the end of dmesg I see the following error:
Code:

(...)
cs46xx: failure waiting for FIFO command to complete
NET: Registered protocol family 17
Generic RTC Driver v1.07

When I check lspci I get:
Code:

(...)
0000:00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
(...)

and lsmod gives me this:
Code:

snd_pcm_oss            48996  0
snd_mixer_oss          17728  1 snd_pcm_oss
genrtc                  8116  0
af_packet              13192  2
snd_cs46xx            82568  0
snd_rawmidi            19872  1 snd_cs46xx
snd_seq_device          6796  1 snd_rawmidi
snd_ac97_codec        73728  1 snd_cs46xx
snd_pcm                85288  3 snd_pcm_oss,snd_cs46xx,snd_ac97_codec
snd_timer              21316  1 snd_pcm
snd                    45764  8 snd_pcm_oss,snd_mixer_oss,snd_cs46xx,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm,snd_timer
soundcore              7328  1 snd
snd_page_alloc          7524  2 snd_cs46xx,snd_pcm
(...)

which seems fine, but when I check dmesg again it now also gives an IRQ error:
Code:

(...)
cs46xx: failure waiting for FIFO command to complete
NET: Registered protocol family 17
Generic RTC Driver v1.07
spurious 8259A interrupt: IRQ7.

Anyway, I might have found solution here: main.linuxfocus.org/~guido/gentoo-tpt20/.
It involves adding the line "options snd-cs46xx thinkpad=1 index=0" to /etc/modules.d/alsa. But that is in Gentoo. Debian does things differently. So (I guess) my question is, where the hell in Debian is the alsa kernel module (config) file located so that I can try adding said line? Or if anyone knows of a different remedy, please tell me...

m_yates 03-23-2005 09:51 AM

Try editing alsa-base:
Code:

nano /etc/modutils/alsa-base
Then run:
Code:

update-mudules
I'm not sure what the options you found do, but I think you should be able to add them in the alsa-base file. Hopefully that will work!

initialdrifteg6 03-23-2005 11:04 AM

hmmm i dunno...

do

apt-cache search alsa

and download the also if it's in your source lists. then do

alsaconf

to configure your alsa audio drivers.... it seems to work okay for me... does anyone know if there is a way to get the actual drivers runnin for linux so i could get the best performance from my audio card? (i do a lot of audio recording and so far windows has been good, but it's the last reason why i still have a windows partition on my hdd(


All times are GMT -5. The time now is 06:38 PM.