LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   getting notified of updates in xfce (http://www.linuxquestions.org/questions/debian-26/getting-notified-of-updates-in-xfce-4175460151/)

Andy Alkaline 04-30-2013 09:04 AM

getting notified of updates in xfce
 
Wheezy-amd64

I scoured through synaptic and google trying to find if there was a package that would allow getting notified of updates in xfce.

I saw one possible solutions as xfapplet, but it appears to be only available in squeeze and sid.

Quote:

The XfApplet Plugin is a plugin for the Xfce 4 Panel which allows one to use applets designed for the Gnome Panel inside the Xfce Panel. You can think of XfApplet as a tiny Gnome Panel that lives inside the Xfce Panel and allows you to show the same applets that the Gnome Panel is capable of showing.
I tried building from source, but after I satisfied most dependencies, it got stuck on libpanel-applet-dev, and wouldn't complete the ./configure.

I finally cobbled together my own solution this morning:

http://www.linuxquestions.org/questi...nt-4175460142/

Any other solutions that exist right now for wheezy that I missed? Thanks...

odiseo77 04-30-2013 11:38 AM

I don't use XFCE on a regular basis, but I think you can use update-notifier on XFCE (at least, it worked last time I tried). Once you've installed it you will probably have to add it to the startup XFCE services.

Andy Alkaline 04-30-2013 11:49 AM

Thanks, odiseo. I found update-notifier under the section Gnome Desktop Environment and it only needed a few deps so I installed it. Then I went to settings -> session and startup -> application autostart and saw it in the list and auto-magically checked.

I would expect that will work, so I'm going to mark the thread solved.

Andy Alkaline 04-28-2015 10:11 PM

Using Jessie now. I switched to "testing/Jessie" several months ago (upgraded from Wheezy, not a fresh installation)

update-notifier hasn't worked since the switch.

I found this related bug, but haven't figured out the problem yet: https://bugs.debian.org/cgi-bin/bugr...cgi?bug=710565

I have gnome-packagekit installed. I use Xfce.

Code:

dpkg -l gnome-packagekit
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name          Version      Architecture Description
+++-==============-============-============-=================================
ii  gnome-packagek 3.14.0-1    i386

My sources.list:
Code:

deb ftp://debian.cites.illinois.edu/pub/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb ftp://debian.cites.illinois.edu/pub/debian/ jessie-updates main contrib non-free
deb ftp://ftp.deb-multimedia.org jessie main non-free


odiseo77 04-29-2015 11:08 AM

I'm not using XFCE or gnome-packagekit/update-notifier (I manually upgrade my system through the CLI every day), but according to this link (post #11), GTK is compatible with gnome-session only. Not sure if there is a fix for this though, but it might be worth to check the link.

Andy Alkaline 05-03-2015 11:45 PM

@odiseo77: Thank you. I think I'll just use this: http://www.linuxquestions.org/questi...nt-4175460142/

odiseo77 05-04-2015 08:41 PM

Great. In case you use conky, I have these lines in my ~/.conkyrc file (they were taken from someone who created a special conky configuration named Conky Colors):

Code:

# |--UPDATES
${goto 32}Updates: ${alignr}${font Ubuntu:style=Bold:size=8}${color1}${execi 360 aptitude search "~U" | wc -l | tail}${color}${font} ${color2}Paquetes${color}

In case you're interested, the whole configuration and instructions are here.

Cheers.


All times are GMT -5. The time now is 08:37 PM.