LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-25-2005, 04:58 PM   #1
kzar
Member
 
Registered: Oct 2003
Posts: 66

Rep: Reputation: 15
Getting lirc modules working


Hi guys, I could use some help getting the lirc modules working, but I'm having some problems.

I have installed the lirc-modules-source package and compiled the package on my faster computer and then copied the package over to install it. Everything seems to work fine but "modprobe lirc_serial" still returns module not found. Even though /lib/modules/2.6.10/misc/ has the lirc modules in it. (lirc_serial.o etc)

Next I tried installing all the tools for compiling and the kernel source on the pc with the reciever, installed the lib-modules-source thing, installed it again, still same problem.

Now I am trying it a different way by going to /usr/src/kernel-source-2.6.10/ and doing "debian/rules binary-modules" but its saying some errors about the configuration of lirc-modules-source being poor and to try setting it up manualy rather than using the automagical option.

So heres my problem now, I need to figure out things like I/O port and IRQ for my serial infra red reciever thingy and I don't know how. The people in #debian sugested looking at /proc/interrupts, /proc/ioports which of course I did but I don't understand it . Heres what they contain:

Quote:
pvr:/usr/src# cat /proc/interrupts
CPU0
0: 5437307 XT-PIC timer
2: 0 XT-PIC cascade
8: 4 XT-PIC rtc
9: 0 XT-PIC acpi
10: 3 XT-PIC saa7146 (0)
11: 139154 XT-PIC eth0
14: 1329536 XT-PIC ide0
15: 19 XT-PIC ide1
NMI: 0
LOC: 0
ERR: 0
MIS: 0
Quote:
pvr:/usr/src# cat /proc/ioports
0000-001f : dma1
0020-0021 : pic1
0040-0043 : timer0
0050-0053 : timer1
0060-006f : keyboard
0070-0077 : rtc
0080-008f : dma page reg
00a0-00a1 : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
0cf8-0cff : PCI conf1
4000-400f : 0000:00:00.1
5000-5003 : PM1a_EVT_BLK
5004-5005 : PM1a_CNT_BLK
5008-500b : PM_TMR
5014-5017 : GPE0_BLK
d000-dfff : PCI Bus #01
d000-d07f : 0000:01:00.0
e000-e07f : 0000:00:09.0
e000-e07f : 0000:00:09.0
e400-e4ff : 0000:00:0c.0
Well I hope you guys can help because this is starting to wind me up because I can't think of any more ideas of what to try!

Thanks, Kzar
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LIRC: lircmd not working on XF86Config-4 ElChef Linux - Software 0 04-22-2005 01:07 AM
LIRC: lircmd not working on XF86Config-4 ElChef Linux - Newbie 0 04-21-2005 10:11 AM
Lirc not working after reboot Basta Linux - General 0 06-13-2004 03:53 AM
my modules arent working even after... c0rderr0y Linux - Newbie 2 02-22-2004 12:07 AM
Kernel Modules for Lirc Quis Linux - Hardware 6 09-05-2003 12:04 AM


All times are GMT -5. The time now is 04:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration