LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-03-2004, 05:34 AM   #1
kulmis
Member
 
Registered: Aug 2003
Posts: 33

Rep: Reputation: 15
Getting getty to run.


Hi,

I'm quite new with Debian and I'm having problems with running getty at the startup (so that I get text mode login screen). All I get is graphical login screen and when I try to switch to tty1 (Ctrl-Alt-1) my monitor just switches off (and this happens with all ttys). Same happens (naturally) if I kill the X server.

I have the following in my /etc/inittab

1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

And also:

#which getty
/sbin/getty


My current runlevel is 2.

What else do I need to add or remove and where?
 
Old 09-03-2004, 09:35 AM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Re: Getting getty to run.

Quote:
Originally posted by kulmis



My current runlevel is 2.

What else do I need to add or remove and where?
You have to remove the display manager you are using (kdm, gdm, xdm, wdm ...) then you will start in console mode. You can if you do not wish to remove the display manager entirely remove the symbolic link to it in the /etc/rc2.d/ directory or edit the file in the /etc/init.d directory and put exit 0 as the second line in the file and it will exit without running any other commands in the file when starting. But you have a bigger problem than that for some reason you are not getting a console at all. Using the CTRL +ALT + F1 should put you at the console without problems. So what kind of video card/hardware is in the machine? Do you see boot messages when you start?
 
Old 09-03-2004, 01:51 PM   #3
kulmis
Member
 
Registered: Aug 2003
Posts: 33

Original Poster
Rep: Reputation: 15
OK, I got it fixed. I don't know what I actually changed from XF86Config file (I played with the settings a lot so i dont know which one actually helped ), but now it works. I have Radeon 7500, so I had updated xfree86 to 4.3.0 (testing) because 4.1.0 doesn't support it. I guess Xserver tried to load some wrong driver somewhere (config file was produced by xf86config).

And apparently console has been "on" all the time because when my monitor went blank I could still give commands and my HD led went nuts. My Radeon just wouldn't for some reason output any signal after I had switched from X to text-mode.

Well, now it works anyway...

Thanks for the help

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help my getty is being a yetti!! Law1213 Slackware 6 06-24-2006 02:07 AM
What is getty? swmok Linux - Software 2 07-07-2004 05:54 AM
getty in RedHat 8.0 kprocter Linux - General 1 06-02-2003 10:23 AM
Autologin Getty rch Linux - Security 5 04-15-2003 01:04 AM
ititilize ttySX using other than getty frieza Linux - Software 3 10-01-2002 11:46 AM


All times are GMT -5. The time now is 03:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration