LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-17-2006, 07:08 PM   #1
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
framebuffer during booting and the Tux Logo


I have seen generally that whenever we boot from a Knoppix CD, the booting process happens with the framebuffer driver and also there is a small colourful tux logo on the top left hand side of the screen.

Right now when I boot my Debain Sarge 3.1 (GNOME Installed) the booting process happens in regular text mode.

How I can make the booting process happen in the frame buffer mode?

Just to be clear I am not talking about the splashy package. I just want simple verbose booting on the framebuffer driver and if possible with the Tux logo on the Left hand side.

thanks
 
Old 01-17-2006, 09:13 PM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
Quote:
Originally Posted by kushalkoolwal
I just want simple verbose booting on the framebuffer driver and if possible with the Tux logo on the Left hand side.
Why not go with a debian logo? Install the kernel-patch-debianlogo package, then patch your kernel using a process similar to below:

Code:
cd /usr/src/linux
patch -p1 < /usr/src/kernel-patches/diffs/debianlogo/debian-logo-2.x.x
Config the kernel:

Quote:
Graphics support --->[*] Support for frame buffer devices[*] VESA VGA graphics support
Console display driver support --->[*] Video mode selection support
<*> Framebuffer Console support[*] Select compiled-in fonts[*] VGA 8x8 font[*] VGA 8x16 font
Logo Configuration --->[*] Debian GNU/Linux Open Use logo (NEW)
Recompile and you've got your logo. If you really want the tux image you should be able to just choose 'bootup logo' (or similar) in the Logo Configuration section of the kernel config.
 
Old 01-18-2006, 02:50 AM   #3
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Thanks a lot. I will try that and see how it goes.
 
Old 01-18-2006, 05:17 PM   #4
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
It seems that the site packages.debian.org is down for some reason since last couple of weeks. Now how do I download the patch? Is there any temporary workaround?
 
Old 01-18-2006, 07:51 PM   #5
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
You can go straight to the Deb repo.
 
Old 01-19-2006, 05:33 PM   #6
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
hi Xian,

I tried what you had suggested, but it seems in my case it did not work. It still boots with the text mode with any framebuffer drivers. When I tried passing the kernel argument vga=791 the screen went blank and after sometime(when booting was finished) straight away I got the Gnome login screen. I am using kernel-source-2.6.15-1 from www.kernel.org.

Any ideas?

thanks
 
Old 01-19-2006, 09:24 PM   #7
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
I would suggest using a Debian kernel-source package, and compiling that to your preference. I've never tried the method I outlined on a vanilla kernel. This isn't to say that it can't be done, but I do know it works with a Debian kernel.
 
Old 01-20-2006, 02:58 AM   #8
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
Originally Posted by Xian
I've never tried the method I outlined on a vanilla kernel.
Last time I applied the patch to the vanilla 2.6.16-rc1 and it worked fine, thanks for pointing this MUST-feature
Just had to change 2.6.15 to 2.6.16 in the apply file.
 
Old 01-20-2006, 06:24 PM   #9
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
I found the solution. Actually, by default the framebuffer driver for my Intel 855 GM card was also set to be compiled as module. So to try, I just disabled the native Intel framebuffer driver from my the kernel and I was able to find the Happy little tux on my screen.
 
Old 01-23-2006, 01:57 AM   #10
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Glad you found your little tux
The funny thing is that for me when the driver for 855GM is compiled as module, it is not loaded. So on my box, it doesn't change anything having it compiled as module or not.
But well, the most important is that it works..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change tux logo Tuttle General 17 11-27-2005 06:15 PM
Change Suse Logo to KDE Logo little_penguin Suse/Novell 2 04-05-2005 05:35 PM
Missing tux logo in Sarge? uk_dave Debian 33 08-06-2004 07:17 PM
Framebuffer and logo working with kernel 2.6.5? theo_ianus Linux - Newbie 1 05-05-2004 02:35 PM
Kernel option to supress framebuffer logo? bender647 Linux - Software 1 06-22-2003 11:27 AM


All times are GMT -5. The time now is 01:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration