LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Forth time not a charm..need help (http://www.linuxquestions.org/questions/debian-26/forth-time-not-a-charm-need-help-296410/)

jolphil 03-01-2005 03:21 PM

Forth time not a charm..need help
 
Hi All,
I have tried four times to install Debian on a small hard drive..
I get it installed and download files from a ftp server but after I answer questions about my Xserver it still cannot find a screen and thus fails to start the GUI(KDE)..
I use the NV driver,1024x768 24 bit..My Horiz =30-95khz Vert=50-150 those values were plugged in but when I try to start x No go..I looked on the /etc/X11/XF86Config-4 file and the values seem correct ..At least they are like the other distros..Suse and MDK..It flashes a few times then returns the error..Failed to find a screen..
Any tips or suggestions?

Thank You for any information..
jolphil

dastrike 03-01-2005 03:42 PM

Look at the file /var/log/XFree86.0.log file for some more error messages (look near the end of the file....)



A possible cause (that I've seen a few times): There is an additional mouse device in the configuration file (called "Generic Mouse"). In my experience it helps to remove the Section "InputDevice" for that "Generic Mouse" (but keeping the other mouse, typically called "Configured Mouse" there), and also removing the reference to it in the Section "ServerLayout".

And I repeat: this is just a possible solution.
Without seeing your XF86Config-4 and XFree86.0.log, I can't say much more at this moment (and preferably don't post the entire contents of those files here as that just gets way too cluttered... preferred way is to upload the files somewhere and then link to them, but of course if one doesn't have that option one can't do that)

EliotK 03-01-2005 07:05 PM

I wish every linux os would go x11, xfree86 blows.

BlueLaser 03-01-2005 07:14 PM

Correct me if I am wrong but Xfree86 is X11. I presume it is Xorg that you are talking about. That will come out on its next testing release "Etch".

EliotK 03-01-2005 07:21 PM

yeah sorry, thats what i meant, been editing the config files in x11 folder got a little confused (my system runs xorg), Why you a xfree86 fan or something.

dastrike 03-01-2005 07:48 PM

X.org and XFree86 are both implementations of X Window System, protocol version 11 (a k a X11)

Debian will go over to X.org after Debian 3.1 ('sarge') has been released. Debian is one of the main porters of XFree86 (and X.org) to architectures beyond x86. It takes time to get it working on all the 10+ platforms/variants of Debian. That, and there was no interest on starting the porting before there was a modular version of x.org available is why Debian has been sticking with XFree86 for so long.

EliotK 03-01-2005 07:51 PM

just booted the new debian sarge iso, i didnt want to erase all my data, becuase i have fc3 installed on 1 big partition (basically my whole hd excpet for swap space), is it possible i can mount debian on the same partition as fedora

dastrike 03-01-2005 07:57 PM

Quote:

Originally posted by EliotK
just booted the new debian sarge iso, i didnt want to erase all my data, becuase i have fc3 installed on 1 big partition (basically my whole hd excpet for swap space), is it possible i can mount debian on the same partition as fedora
I'd say no. You can't put them both on the same partition. You should make a backup of all the valuable data you have on that partition before you proceed (and by proceeding you will destroy the existing installation of FC3 on that partition).
The swap partition can be shared though, but that is a bit of moot in your current sitiuation.

EliotK 03-01-2005 08:00 PM

Yeah pain in the ass, I hear suse can resize linux and windows partitions, which is good, becuase im thinking about buying suse, or getting a free version from somewhere ;)

jolphil 03-02-2005 07:37 AM

dastrike,
Looks like I have a section for "serial mouse" "ps/2 mouse" and "USBmouse" but no generic mouse..I use the ps/2 wheel mouse(microsoft explorer mouse..)
see below..(copied from my xf86config-4 file with Knoppix)



Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "true"
Option "Emulate3Timeout" "70"
Option "SendCoreEvents" "true"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

What do you suggest?
Thank You,
jolphil


All times are GMT -5. The time now is 03:48 PM.