LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 07-06-2007, 01:13 PM   #1
harmattan
LQ Newbie
 
Registered: Jun 2007
Location: Spain
Distribution: Debian, Trisquel, Slackware, OpenBSD, NetBSD
Posts: 21

Rep: Reputation: Disabled
Question Firestarter not starting: solved


Hi everybody,

My change to Etch from Sarge (new installation) is a bit of a headache up until now.
Although I successfully installed Firestarter as my firewall (using Synaptic at first and then uninstalling and installing again with apt-get install) it isn't starting when I enter my normal Gnome session (/etc/init.d/firestarter status = Firestarter is stopped).
It starts OK when I open the front end and test again.

I'm also having trouble while deactivating all the unneeded services (ssh, exim4, and so). For some reason rpcbind doesn't want to go off. I have thoroughly followed the /etc/rc2.d/README instructions on how to set services off. I only have succeeded making chmod -x to the /init.d/portmap file, as I do in Slackware, but I understand that's not the right way to do it in Debian. Is it?

Please, although I welcome all kinds of advice, the "change to Guarddog" answer is not an option. I am very happy with this firewall in several other distros (including Sarge).

Last edited by harmattan; 07-06-2007 at 05:17 PM.
 
Old 07-06-2007, 01:17 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
For choosing which services run at startup, I use a console based program, sysv-rc-conf. Just use the arrow keys and spacebar to set services for any runlevel.

As to why firestarter isn't coming up, I don't know. Is there anything your syslog saying it failed to load at boot?
 
Old 07-06-2007, 01:35 PM   #3
harmattan
LQ Newbie
 
Registered: Jun 2007
Location: Spain
Distribution: Debian, Trisquel, Slackware, OpenBSD, NetBSD
Posts: 21

Original Poster
Rep: Reputation: Disabled
mmmh. This is what I have found a few times (different logs) in my syslog:

NetworkManager: <WARNING>^I nm_spawn_process (): nm_spawn_process('/usr/sbin/nscd -i hosts'): could not spawn process. (Failed to execute child process "/usr/sbin/nscd" (No such file or directory))

Maybe I have set to off something I shouldn't?
 
Old 07-06-2007, 02:23 PM   #4
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
nscd - Name Service Cache Daemon
A daemon which handles passwd, group and host lookups for running programs and caches the results for the next query. You should install this package only if you use slow Services like LDAP, NIS or NIS+

-------------------------------------------------------------------

Maybe the firewall is trying to start before the Network is up..

Check to see the startup script is linked in runlevel 2.
it-etch:/etc# ls /etc/rc2.d/*firestarter
/etc/rc2.d/S20firestarter

If that startup script exists, maybe you should try moving it to a later startup time and see if that resolves the issue.

mv /etc/rc2.d/S20firestarter /etc/rc2.d/S25firestarter

Last edited by farslayer; 07-06-2007 at 02:26 PM.
 
Old 07-06-2007, 02:51 PM   #5
harmattan
LQ Newbie
 
Registered: Jun 2007
Location: Spain
Distribution: Debian, Trisquel, Slackware, OpenBSD, NetBSD
Posts: 21

Original Poster
Rep: Reputation: Disabled
It doesn't work, farslayer.
I have tried with S25 and later with 50. None of them starts the firewall.
 
Old 07-06-2007, 03:18 PM   #6
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Try doing it with update-rc.d

update-rc.d -f firestarter remove
update-rc.d firestarter start 20 2 .

Does "sudo iptables -n -L -v" say anything?

EDIT: You are using runlevel 2 aren't you? "runlevel" will tell.
 
Old 07-06-2007, 03:32 PM   #7
harmattan
LQ Newbie
 
Registered: Jun 2007
Location: Spain
Distribution: Debian, Trisquel, Slackware, OpenBSD, NetBSD
Posts: 21

Original Poster
Rep: Reputation: Disabled
Yes, runlevel is number 2.
This is what iptables -n -L -v says:

Quote:
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
 
Old 07-06-2007, 04:35 PM   #8
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Well, iptables isn't loaded as you already knew.
Are you using network manager? If yes, perhaps you need to start it even later. See if this helps: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=417663
 
Old 07-06-2007, 05:16 PM   #9
harmattan
LQ Newbie
 
Registered: Jun 2007
Location: Spain
Distribution: Debian, Trisquel, Slackware, OpenBSD, NetBSD
Posts: 21

Original Poster
Rep: Reputation: Disabled
Wow! Thank you very much, makuyl.
Now it works just fine!! :-)
I applied the patch they show in the link and it went perfect.
I suppose it will be an official Debian patch in the next few weeks.

Here it goes again for anybody who might be experiencing the same problem

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=417663

Thanks again makuyl and thanks to the rest of the people also. I have learned a few things in the process ;-)

I love this forum!
 
Old 07-07-2007, 01:30 AM   #10
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
No problem, and there most probably will be a security update to etch for this in a while.
 
Old 12-19-2009, 09:38 AM   #11
ericdanc
LQ Newbie
 
Registered: Dec 2009
Location: Norddeutschland
Distribution: Etch and Lenny
Posts: 25

Rep: Reputation: 15
firestarter "Authentication Rejected...failed" in Lenny boot

I tried moving firestarter boot script around, calling firestarter in /etc/rc.local and in gnome-sessions (start programs) and so forth. Alas, only way to get it started is from root terminal with
# firestarter --start-hidden &
i use wicd, wlan0 and a router. Network monitor and iptables are installed.
 
  


Reply

Tags
networking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help starting firestarter minm Linux - Software 10 09-28-2007 08:44 PM
firestarter not starting otoomet Debian 2 07-01-2007 08:01 AM
Starting Firestarter GUI in GNOME as single user LinODE Slackware 1 01-28-2006 07:58 PM
Won't Boot - Starting Printer Service - Starting CUPS jeansond Linux - Newbie 0 10-11-2004 07:39 PM
Starting Firewall on boot (using firestarter) psychoholic Linux - Networking 3 03-15-2003 07:22 AM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration