LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-08-2007, 12:07 PM   #1
micder
Member
 
Registered: Aug 2003
Location: Terneuzen Netherlands
Distribution: Slack current
Posts: 131

Rep: Reputation: 16
Question Firestarter does'nt start automatically


Just installed Etch with KDE desktop.
One of the first things was installing a firewall; used firestarter.
Started Firestarter as root and checked at Shields Up: OK.
Found lots of documentation on installation of non-free apps such as NVidia.
(My GeForce 6200 TurboCache does not work with nv).
I had a complete desktop in a short time.
And Etch is very fast !!

However info on Firestarter does not make sense (for me).
I have to start Firestarter manually with sudo firestarter after logging in.
Why does Firestarter not start during boot?
firestarter in /etc/init.d is executable.
 
Old 05-08-2007, 12:12 PM   #2
nomb
Member
 
Registered: Jan 2006
Distribution: Debian Testing
Posts: 675

Rep: Reputation: 58
You have to add the sudo firestarter command to your rc.local I think it is. I tried firestarter on debian and had a few issues with it. As an alternative try something like this:

http://www.nombyte.com/?q=node/5
 
Old 05-08-2007, 12:21 PM   #3
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
It's probably running. It just doesn't open a desktop window.

Try this:
$ pidof firestarter

If that returns a number, it's running.
 
Old 05-08-2007, 12:43 PM   #4
micder
Member
 
Registered: Aug 2003
Location: Terneuzen Netherlands
Distribution: Slack current
Posts: 131

Original Poster
Rep: Reputation: 16
It does not start during boot, even after adding sudo firestarter to rc.local.
Up to now only sudo firestarter in a konsole did start the firewall.
BTW checked that with shields up.

There's a lot of scripts in /etc/init.d that get started at the right time.
It still puzzles me that firestarter is not triggered.
Did not have that problem with Mepis.

Thx for the reactions :-)
 
Old 05-08-2007, 12:51 PM   #5
nomb
Member
 
Registered: Jan 2006
Distribution: Debian Testing
Posts: 675

Rep: Reputation: 58
using sudo to start firestarter is how it says to do it in the documentation. Make sure that firestarter is one of the programs you can use sudo for and if not add it. And also in the rc.local file you need to put the full path. /sbin/firestarter or whatever it is for you. As an alternative take a look at the link I gave you. especially the init scripts. You could take that script and convert it for firestarter if you really want to.
 
Old 05-08-2007, 01:31 PM   #6
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
My response in #3 was wrong. The only way "pidof firestarter" will return a process number is if the GUI is running. But once you have it set up, it will probably start on boot.

My setup depends on a NAT firewall in the router which has several ports that I regularly use left open. Those ports are defended by Firestarter unless I use Firestarter to open them. I also have a policy defined in Firestarter that allows connections from any "local" PC attached to the router.

I just rebooted, and have not opened the Firestarter GUI, but I know it's working because # iptables -L -n includes the line:

ACCEPT 0 -- 192.168.123.0/24 0.0.0.0/0

Last edited by rickh; 05-08-2007 at 01:33 PM.
 
Old 05-08-2007, 03:14 PM   #7
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
If you are just trying to get the Firestarter GUI to start, check out this link.
 
Old 05-09-2007, 04:22 AM   #8
micder
Member
 
Registered: Aug 2003
Location: Terneuzen Netherlands
Distribution: Slack current
Posts: 131

Original Poster
Rep: Reputation: 16
Smile

Thank you all for your suggestions.
Understand now that I can start the firewall via KDE autostart.
That's one way to start automatically.
Had a look at the README in /etc/init.d
Quote:
/etc/init.d/*.sh scripts must conform to the rules for sh scripts as
spelled out in the Debian policy section entitled "Scripts" (10.4).
It seems that firestarter does not comply:
I can't find a link in /etc/rcS.d.

Installed guarddog and there is a link in /etc/rcS.d.
I did not find the required /etc/rc.firewall as said in the guarddog documentation.
So did that myself and now the firewall is started automatically at boot.

cheers
 
Old 05-09-2007, 09:09 AM   #9
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Quote:
I can't find a link in /etc/rcS.d.
How about rc2.d ... That's where mine is.
 
Old 05-09-2007, 01:20 PM   #10
micder
Member
 
Registered: Aug 2003
Location: Terneuzen Netherlands
Distribution: Slack current
Posts: 131

Original Poster
Rep: Reputation: 16
Ya, rickh, its (firestarter) in my rc2.d too.

Pls enlighten me:

Looking at the scripts, I still don't get why firestarter does not start at boot.
According to the README in rc2.d
Code:
The scripts in this directory are executed each time the system enters
this runlevel.

The scripts are all symbolic links whose targets are located in
/etc/init.d/ .
The starter link for firestarter resides in rc2.d and the one for Guarddog in rcS.d.
I'm not familiar with the (for me) complicated initialization of Debian.
Anyhow complicated compared with Slackware.
 
Old 05-09-2007, 02:12 PM   #11
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Quote:
complicated initialization of Debian
It's not complicated. It's just new to you. I still maintain that Firestarter is starting when you boot. It's just not opening a gui. There is no reason it should. Open the gui, and add a very specific rule, like ... allow inbound connections on port 6001 from anyone. Reboot, and run # iptables -L -n and you will see the rule in place.

If what you want is a gui open on boot, that's a different issue.
 
Old 05-09-2007, 02:21 PM   #12
nomb
Member
 
Registered: Jan 2006
Distribution: Debian Testing
Posts: 675

Rep: Reputation: 58
Thinking back what I did was add a sudo /sbin/firestarter to gnome's start program each session option. But again, that made the gui start. What rickh said makes a lot of sense so you should definately add a rule and see if it is in you chain when you reboot.
 
Old 05-10-2007, 07:15 AM   #13
micder
Member
 
Registered: Aug 2003
Location: Terneuzen Netherlands
Distribution: Slack current
Posts: 131

Original Poster
Rep: Reputation: 16
OK, removed guarddog and reinstalled Firestarter.
See something like firestarter starting..? flashing along during boot.
Checking at Shields up after boot: all common ports closed except 113 Ident.
I then do sudo firestarter, go back to Shields up and see that all ports are Stealth.
 
Old 05-10-2007, 07:29 AM   #14
nomb
Member
 
Registered: Jan 2006
Distribution: Debian Testing
Posts: 675

Rep: Reputation: 58
now u can add that to your list of programs to start when your session does and be done with it.
 
Old 05-11-2007, 05:06 AM   #15
micder
Member
 
Registered: Aug 2003
Location: Terneuzen Netherlands
Distribution: Slack current
Posts: 131

Original Poster
Rep: Reputation: 16
nomb said:
Quote:
now u can add that to your list of programs to start when your session does and be done with it.
I could do that, but my firewall will start only when starting X.
Or do I miss something?
Guarddog is started before X is started.
It's maybe a small difference, but I thought that the firewall should be up asap.
Thank you all for your patience and help.

cheers
 
  


Reply

Tags
firestarter, firewall


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firestarter wizard doesn't start sixerjman Linux - Software 2 05-18-2006 07:05 PM
firestarter start neilcpp Slackware 4 11-20-2005 09:09 AM
Firestarter will not start BradW Linux - Networking 3 06-02-2004 07:18 AM
Fedora does'nt start after installation ivansinopoli Fedora 1 01-15-2004 07:54 AM
writing a script running firestarter automatically with kppp without root priviliges melquiades Linux - Newbie 3 08-11-2003 06:50 AM


All times are GMT -5. The time now is 02:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration