LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 02-26-2005, 11:21 AM   #1
Baruch
LQ Newbie
 
Registered: Feb 2005
Posts: 8

Rep: Reputation: 0
External connection fails after exactly 1 hour


I'm trying to set up a Debian "sarge" gateway with a 2.6.8-2-686 kernel. But the external connection(DHCP) with my ISP keeps failing after exactlyt 1 hour. I guess this has something to do with DHCP. But i can't find anything strange in the logs. When i reboot everything is fine for 1 hour. When i do "dhclient eth0" connection comes up again to. I tried to make a cronjob with that command, but after a while i end up with dozens of dhclients running. By the way, same problem happens with and without iptables firewall.

Anybody know what's wrong?
 
Old 02-26-2005, 05:18 PM   #2
dhcolesj
LQ Newbie
 
Registered: Jul 2004
Location: Dickson TN
Distribution: Debian Sid, and SUSE Pro
Posts: 20

Rep: Reputation: 0
Quote:
But the external connection(DHCP) with my ISP keeps failing after exactlyt 1 hour. I guess this has something to do with DHCP. But i can't find anything strange in the logs. When i reboot everything is fine for 1 hour
How do you connect to your ISP? Looking at your message I noticed you were using eth0, which would mean you are connecting over an ethernet cable to something. My question mainly will center on where you are getting your IP address from.
 
Old 02-26-2005, 07:08 PM   #3
Baruch
LQ Newbie
 
Registered: Feb 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by dhcolesj
How do you connect to your ISP? Looking at your message I noticed you were using eth0, which would mean you are connecting over an ethernet cable to something. My question mainly will center on where you are getting your IP address from.
I have 3 nics in my gateway. Eth0 connects to my adsl-modem, and gets a DHCP-lease from my ISP. Eth1 and eth2 use a static ip-address, and those continue to work. Renewing the DHCP-lease of eth0 works fine by rebooting or by doing it manually, but it doesn't work autmatically like it should. It works fine under Windows2000 or Slackware, but not in Debian, with or without firewall.
 
Old 03-05-2005, 01:39 PM   #4
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If the problem is that your Debian box suddenly loses nameserver information, then installing the resolvconf package (and adding the addresses for dns-nameservers to /etc/network/interfaces) might provide a solution. I haven't used it myself, but other users on this forum have reported that resolvconf can solve some dhcp/dns related problems.
http://packages.debian.org/testing/net/resolvconf
 
Old 03-05-2005, 03:38 PM   #5
Baruch
LQ Newbie
 
Registered: Feb 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Dead Parrot
If the problem is that your Debian box suddenly loses nameserver information, then installing the resolvconf package (and adding the addresses for dns-nameservers to /etc/network/interfaces) might provide a solution. I haven't used it myself, but other users on this forum have reported that resolvconf can solve some dhcp/dns related problems.
http://packages.debian.org/testing/net/resolvconf
Unfortunatly the problem isn't DNS-related. I tried pinging ip-addresses directly, but that didn't work. Info in /etc/resolv.conf seemed ok to.
 
Old 03-05-2005, 05:07 PM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Well, that would have been too easy, wouldn't it?

If I was in your position, I'd go through all the config files under /etc that seem to be even remotely networking-related, starting from /etc/network/ and /etc/default/ , trying to figure out what settings make your network connection under Debian behave differently from Windows and Slackware. Here's an overview of setting up net connection on Debian plus introduction to some tools that will help in this task:
http://www.debian.org/doc/manuals/re...ateway.en.html

Of course, it could be also some process that is not networking-related at all but nevertheless interferes with your net connection, but this should show in the log files under /var/log/ and you said you've already went through them finding nothing unusual.
 
Old 03-06-2005, 06:46 AM   #7
Baruch
LQ Newbie
 
Registered: Feb 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Dead Parrot
If I was in your position, I'd go through all the config files under /etc that seem to be even remotely networking-related, starting from /etc/network/ and /etc/default/ , trying to figure out what settings make your network connection under Debian behave differently from Windows and Slackware. Here's an overview of setting up net connection on Debian plus introduction to some tools that will help in this task:
http://www.debian.org/doc/manuals/re...ateway.en.html
Maybe next time, i already gave up and went back to my old and trusted friend Slackware.

I actually do real work on computers, so i don't have to much time to get things working properly.

But thanks anyway.
 
Old 03-06-2005, 09:05 AM   #8
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Your problem is quite unusual but there's no magic involved -- both Debian and Slackware use the same Linux kernel for their networking features. Distros like Debian, Fedora, and Mandrake have some advanced features, like additional hardware detection, and most often these features make them easier to use but sometimes they can interfere and a simple distro like Slackware can come out as the winner. If you actually do real work on computers, as you say, then I suggest that you spend some time learning how to troubleshoot Linux-related problems because you'll meet many other problems using Slackware. But I agree that Slackware is one of the most stable and trouble-free distros out there, so you've made an excellent choice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aergh. X dies on the hour, every hour l00zer Linux - Software 4 06-07-2005 11:02 PM
External USB 2.0 HD - fails after copying 10-20% dehuszar Linux - Hardware 9 05-09-2005 04:37 PM
change clock from 24 hour to 12 hour in suse 9.2/KDE 3.3 jmlumpkin Linux - Newbie 1 01-23-2005 12:45 AM
External modem dials then fails westone Linux - Hardware 0 07-07-2004 09:55 PM
External MASQ ICMP forwarding test fails blackphiber Linux - Networking 9 01-27-2004 09:56 PM


All times are GMT -5. The time now is 04:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration